Sluggish video playback (6s plus to MBP 2010 17")

Discussion in 'Mac Basics and Help' started by hajime, Apr 13, 2016.

  1. hajime macrumors 68030

    Joined:
    Jul 23, 2007
    #1
    Hello, I used my iphone 6s plus to take some videos in 4K. Playback from the phone was fine but when I played back the videos from Photos on my MBP 2010 17" (2.66GHz i7, 8GB 1067MHz DDR3, 1T Samsung EVO 850, Nvidia GeForce GT 330M 512MB), the videos became sluggish. Often, there were pauses. Anybody knows what is going on? Hope the computer is not too old to have problem in playing back 4K videos.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    It does sound like it's the graphics card that isn't powerful enough to smoothly play 4K videos. Just to put it into perspective, the 330M has fairly equivalent/worse performance when compared to 4th gen Intel integrated graphics.

    As you've got the RAM maxed out & an SSD in there, I doubt there's any other component causing the bottleneck.
     
  3. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007
    #3
    My 2010 MBP can handle 3D CAD very well. If it cannot handle 4K videos, it would mean I have to spend money to buy a new computer :-(
     
  4. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #4
    Yep that about sums it up its just not a good enough graphics card for 4K video, it was made before 4K was even a consideration and even a modern mobile GPU may struggle with 4k.
     
  5. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007
    #5
    So, my iPhone is more powerful than my laptop?
     

Share This Page