Small Menu Bar Bug

Discussion in 'OS X Mavericks (10.9)' started by Drew017, Dec 16, 2013.

  1. Drew017 macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #1
    I recently tried to install the Obsidian Black Menubar theme for Mavericks (10.9.1), and although it successfully installed, the white text for the menu never showed up- it stayed black. I uninstalled the theme, but I now have one (very small) issue- When I click one of the menu extras on the menubar on the right, then mouse over to another extra beside it (like the wifi icon or sound icon), the drop down menu will not follow the mouse (like it does if I tap the file menu and move to the edit menu etc). I tried deleting the com.apple.systemuiserver.plist file in my preferences folder, but the issue appears after a restart. I know it's a small problem, but it bothers my OCD :p Any ideas are appreciated!

    Also- has anyone gotten Obsidian to work in 10.9.1??
     
  2. benjamin831, Dec 22, 2013
    Last edited: Dec 22, 2013

    benjamin831 macrumors newbie

    Joined:
    May 15, 2013
    #2
    Bump!

    I have the exact same problem regarding the font color on a black bar! Would love some help on this.
     
  3. 82asmdf203, Dec 23, 2013
    Last edited: Dec 23, 2013

    82asmdf203 macrumors member

    Joined:
    Nov 18, 2013
    #3
    Regarding the font color on the menu bar, you did follow either steps 3a or 3b, correct?

    Obsidian works for me in 10.9.0 and 10.9.1. For many others I think as well.
     

    Attached Files:

  4. hp. macrumors newbie

    Joined:
    Mar 17, 2012
    #4
    I had the same problem with black menubar text instead of white, I fixed it by manually replacing the Extras2.rsrc file. I had to manually change the icons for Time Machine, Bluetooth, Spotlight, etc. Any ideas why the installer isn't replacing everything?

    You'll need to use something like Pacifist if you want to manually extract the files you need....
     
  5. Sital macrumors 68000

    Sital

    Joined:
    May 31, 2012
    Location:
    New England
    #5
    Obsidian is working fine for me on 10.9.1, although I already had it installed before I updated from 10.9.

    My drop down menu for the menu bar extras also does not follow the mouse, although it does for the app menus. Honestly, I don't remember what the behavior was before I installed Obsidian. Does the drop down menu for the menu bar extras normally follow the mouse?
     
  6. Drew017 thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #6
    After a few restarts my menubar was back to normal (following the mouse) but I'm afraid to try to install Obsidian unless it has been updated...

    And yes I did follow the steps when I tried to install it, but it was the text in the menubar (i.e. File, Edit, View etc) that would not change to white.
     
  7. benjamin831 macrumors newbie

    Joined:
    May 15, 2013
    #7
    I suspect for those who have Obsidian working in 10.9.1 had it installed in 10.9.0?

    Perhaps we'll just have to wait for the developers to make it 10.9.1 ready when installing from scratch?
     
  8. leodbil macrumors newbie

    Joined:
    Dec 23, 2013
    #8
    I have the same issue using Obsidian along with Bartender istat whiteclock and whiteUIserver.menu. You can't really tell from this photo but the text shows up on the left but very faint like it is only a highlight or shadow edge of the text and certain system icons on the right are the same, spotlight ,clock, bluetooth, eject etc.

    @ hp -- where is the package containing Extras2.rsrc file you speak of?

    it would be great to find a solution to this.

    BTW I'm on 10.9.1 ... thanks for the discussion, Bill
    a click on the pic will take you to the site where you can click again to see a larger version where you can see the faint text. Sorry about all that new at this. :eek:


    [​IMG]
     
  9. hp. macrumors newbie

    Joined:
    Mar 17, 2012
    #9
    I uninstalled Obsidian before I updated to 10.9.1. Maybe the installer isn't replacing files for anyone, but if you didn't go back to the default menu bar first you don't notice.

    leodbil - If you open the installer with a program like Pacifist, the Extras2 file is in Obsidian/extras.pkg
     
  10. leodbil, Dec 23, 2013
    Last edited: Dec 23, 2013

    leodbil macrumors newbie

    Joined:
    Dec 23, 2013
    #10
    Thanks @hp for sending me in the right direction! What a relief. I think you are right ... something with the installer or it could be it doesn't work right from within the .dmg I pulled the package out of the dmg, opened it with pacifist, selected everything except the Extras2 file, right clicked and chose 'install to default location' , then did the same with the Extras2 file and everything worked. I really don't know if pulling the package out of the dmg or installing the Extras2 file last had anything to do with anything but I like the result.

    thanks again everyone, bill

    [​IMG]
     
  11. big albie macrumors newbie

    Joined:
    Dec 27, 2013
    #12


    I am trying to do what you did, but don't know exactly what to do. can you help me through it? Pull the package out of the .dmg and put it where - on my desk top?

    ----------

    Forget it - I got it to work.
     

Share This Page