Smart SVN and Java - Security?

Discussion in 'Mac Basics and Help' started by Reg88, Mar 14, 2013.

  1. Reg88 macrumors regular

    Joined:
    Jun 8, 2010
    #1
    Hi,
    I'm looking to use SmartSVN as a SVN client, but it needs Java. I always keep my Macs updated with Mac updates, but is Java still too big a security risk to run on OS X?

    Thanks.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    The security issues you keep seeing with Java are related to the web (browser) plugin. If you install Java and just use it to run a local app like SmartSVN, and disable the browser plugin, you will be fine.
     
  3. Reg88 thread starter macrumors regular

    Joined:
    Jun 8, 2010
    #3
    Thank you!!!!
     

Share This Page