SMB File Display Issue?

Discussion in 'OS X Mavericks (10.9)' started by aaairsci, Oct 22, 2013.

  1. aaairsci, Oct 22, 2013
    Last edited: Oct 23, 2013

    aaairsci macrumors newbie

    Joined:
    Aug 16, 2013
    #1
    Hi everyone!

    So I've upgraded to Mavericks, and everything seems to be working fine so far.... except one very important thing: SMB shares. Sort of. Let me walk you through what is happening:

    So I go to connect to a file server like I normally do in Finder via Go > Connect To Server. I enter smb://pdxchief/pdxdata/ as I want to connect to a volume on a server. Here is what appears:

    [​IMG]

    Note that under 'SHARED' the newly connected drive is pdxchief... NOT pdxdata. Also note the weird pdxchief(SAMBA)... this does not appear upon connection but rather is a permanent fixture in my sidebar that won't go away. Clicking on it connects me to pdxchief as a 'Guest' instead of my username and disconnects me if I click off of it.

    Anywho, that's not the big issue (although I would like that to go away). Here's the big issue. Let's say I click off of the pdxdata window to view my Documents... then try to get back to pdxdata by clicking on the real pdxchief button with the eject sign. Here's what happens:

    [​IMG]

    It's blank... and it stays blank. To get back to pdxdata, I have to click the eject and/or disconnect in the black bar buttons, wait for an inordinate amount of time, close the finder window, reopen finder, and reconnect via Go > Connect To Server. It's quite annoying.

    Any thoughts/advice? Or is this likely a bug with the new SMB2 implementation? Thanks!
     
  2. aaairsci thread starter macrumors newbie

    Joined:
    Aug 16, 2013
  3. scaredpoet, Oct 23, 2013
    Last edited: Oct 23, 2013

    scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    This has actually been the case since Mountain Lion for me. The "shared" section of the finder sidebar is showing the server names, not the share names, of the connected servers. This is the way OS X is does it, it's not a "bug," at least as far as Apple as concerned. Why the display is taking so long though, might be a configuration issue on your smb server.

    What you can do to get around it is:

    - Make sure you're connected to your smb share,

    - In your finder window, hover your mouse pointer over the "shared" header above the listed servers and click the "hide" option that appears.

    - In Finder Preferences under "General," check the box to show "Connected Servers" on the desktop, like this:

    [​IMG]



    - Open a finder window. Click and drag the share that appears on the desktop, and drag it to the "favorites" sidebar on the finder window.

    You can then go back into preferences and uncheck the "show connected servers" option if you want to. Or you can keep it, your shares will show up on your desktop like a drive would.
     
  4. aaairsci thread starter macrumors newbie

    Joined:
    Aug 16, 2013
    #4

    Thanks for your help! Hopefully this solves the disappearing files problem, too.
     

Share This Page