SMB/File transfer slow with Windows Server 2003?

Discussion in 'macOS' started by Ekim Neems, Feb 3, 2008.

  1. Ekim Neems macrumors member

    Joined:
    Aug 23, 2007
    #1
    After some searching, I've seen three tricks: disabling IPV6 on the Mac, doing the same on the PC (my Windows Server 2003 installation didn't have it installed), and adding a line to my /etc/smb.conf file. None seem to really give me full transfer speeds.

    Are there any tricks specific to Windows Server 2003 or anything new to make this work like normal? It's simple file transfer over SMB, seems like at the 5th iteration of Mac OS X we'd have better speeds. Thanks!
     
  2. gbsigz macrumors newbie

    Joined:
    Nov 8, 2007
    #2
    I have the excact same problem as you man, it´s was almost funny to read your post, the symptoms are that similar.

    I have not found any solution to this yet, so if you have please send me a mail, private message or something.

    I actually tried the same windows server on a macbook air and it was very fast, but not my trusy old macbook.
     
  3. tony4d macrumors member

    Joined:
    Jul 10, 2008
  4. DisposableHero macrumors member

    Joined:
    Nov 17, 2007
    #4
    i'm using a windows home sever file server and I get maybe 5MB/s over a gigabit connection :confused:
     
  5. Cattywampus_ macrumors 6502

    Joined:
    Apr 19, 2006
    #5
    Bumping this as I am having similar problems.

    10.5.5 Leopard machine - takes an age to copy files to a Windows machine (think it might be running Windows SBS) using SMB. Was fine on 10.4.11.

    Any ideas?

    Thanks.
     
  6. tony4d macrumors member

    Joined:
    Jul 10, 2008
    #6
    I use Windows Home Server and from Leopard 10.5.5 file transfers are very fast, 80 - 100MB/sec.
     
  7. iTech-Larry macrumors newbie

    Joined:
    Aug 2, 2009
    Location:
    Portland, Maine, USA
    #7
    Very similar...

    Another bump.

    I'm troubleshooting the same issue for a group of 4 late-2008 iMacs running Leopard. They're connecting to a PC running Windows Server 2003 and having profound delays in reading files via SMB.

    The PCs on the network connect at reasonable speeds but the iMacs almost always take a minute or more to open (or copy) a 3 MB file. But, writing the file back onto the server takes less than 10 seconds.

    FWIW, I tried opening some files on the server with my MacBook Pro 13" unibody (about 6 weeks old) and had identical issues.

    I've been working with the network admin and we've tried the three usual fixes (disabling IPV6 on the Mac, on the Server, editing the /etc/smb.conf file) with no improvement.

    Has anyone had any breakthroughs???
    TIA! - Larry
     
  8. Decrepit macrumors 65816

    Decrepit

    Joined:
    Sep 6, 2007
    Location:
    Foothills to the Rocky Mountains
    #8
    I'm moving a customer from SMB to NFS because the network is SO SLOW with SMB.

    They've got Macs connecting to Linux servers now so NFS is possible. But They had Windows before and had been dealing with SMB.

    I feel your pain.
     
  9. iTech-Larry macrumors newbie

    Joined:
    Aug 2, 2009
    Location:
    Portland, Maine, USA
    #9
    Update!

    Folks -

    Y'know how they say that "Hindsight is 20/20"? :)

    Well, I just heard from my client and we think we've figured out the source of the problem... and it makes plenty of sense (in hindsight).

    In addition to the four new iMacs, the company also has an oooold PowerMac G3 (I think... I never looked closely at it) still on their network. First thing this AM, my client opened up a couple files via the SMB share and they opened *fast* on his iMac. Soon after, the user of the old PMac started it up... and immediately the slow file reading came back. So... 2 + 2 = 4. :)

    It makes sense to me that a decrepit Mac using (likely) 10mBit network hardware, running OS9, and connecting using AppleTalk could well be causing so much 'noise' on the network that it's interfering with the SMB traffic for the iMacs.

    I also don't know if the iMacs have AppleTalk turned off (I'll next verify that). I suspect that turning off the AppleTalk protocol on the iMacs may allow them to ignore all the noise from that old Mac.

    I welcome any thoughts folks have on this. :)
    Larry
     
  10. DisposableHero macrumors member

    Joined:
    Nov 17, 2007
    #10
    my problem was solved by replacing the gigabit switches i was using... I had two 5 port gigabit switches, one linksys and one netgear.. guess they didnt like eachother.

    As soon as i replaced them with one 12port switch.. my speeds went up to 40MB/s
     

Share This Page