SMB guest access

Discussion in 'Mac OS X Lion (10.7)' started by eradicator006, Jul 12, 2011.

  1. eradicator006 macrumors newbie

    Jul 12, 2011
    I'm trying to set up smb guest access to my public folder. I'm sharing the folder from 10.7 to a windows 7 machine. When I try to connect to my mac, I get invalid username/password. I also get the same error when I try to access my mac from a ubuntu machine so I doubt it's a windows configuration issue.

    Here is what I have set up:

    - Windows sharing is turned on under the sharing preference pane
    - No users are checked under sharing (I want guest access)
    - My public folder is listed under folders to share and "Everybody" has read access.
    - Under users preference pane, Guest User is set to "Sharing Only"

    Is anybody else able to get guest smb access working? I'm beginning to think this is a bug in the new smb daemon.

    Outgoing smb connections from my mac work fine. I have an ubuntu samba server set up and I can access it no troubles.
  2. c0b4lt macrumors newbie

    Jul 21, 2011
    I have this same problem. Previously in Snow Leopard guest access to SMB shares from Windows 7 clients to my mac mini worked perfectly fine. Now after upgrading to Lion I get prompted for user/password info. Supplying it with my account info does work however.

    I would much rather have guest access working once again then to go save credentials on all of my Windows 7 clients. Any ideas on what might be wrong? Nothing has changed in the settings that I can see since before updating. And it was previously working in Snow Leopard.
  3. eradicator006 thread starter macrumors newbie

    Jul 12, 2011
    Guest sharing started to work properly for me after installing all of the Lion server components ( and server admin tools).
  4. c0b4lt macrumors newbie

    Jul 21, 2011
    orly? and where is that found? I've never had a need to install such things before so I have no idea lol
  5. eradicator006 thread starter macrumors newbie

    Jul 12, 2011
    That's the problem. You shouldn't need anything extra for guest sharing to work. I'd say it's a bug.

    You need to purchase OS X Lion Server from the app store. I think it's $50. That is the I'm not sure if the server admin tools are required to make guest sharing work, but You can get thm directly from apple's website for free. The server admin tools are basically a more advanced version of
  6. c0b4lt macrumors newbie

    Jul 21, 2011
    ok i tried removing and re-adding the share with Enabling guest access this way changes nothing. :( Getting slightly annoyed that guest access for smb shares isnt working in Lion for me since upgrading lol.
  7. eradicator006 thread starter macrumors newbie

    Jul 12, 2011
    Yeah I'm not sure why mine works. I had originally set up the guest share using the regular sharing preference pane. Last night I had installed the server stuff. I didn't set up or change anything in the server app. The guest shares just started working as soon as I installed server.
  8. eradicator006 thread starter macrumors newbie

    Jul 12, 2011
    My mistake. Guest access is NOT working. Some how my user account got enabled in smb sharing.
  9. c0b4lt macrumors newbie

    Jul 21, 2011
    Ya I just tried a fresh install of lion instead of an upgrade and it still doesn't work. :(
  10. ruvil macrumors regular

    Dec 26, 2010
    Nope there's something dodgy with the new version of lion, i and i guess several others as well has problems with smb too. Even if they're not the same.

    I guess we all just have to wait for a fixed version :confused:
  11. tstraus13 macrumors newbie

    Jul 23, 2007
    Same Problem Here

    I have been having the same exact issues you all are facing, something is just wonky with Lion's SMB server. I was actually able to login as guest with Linux but would not be able to actually access or change anything. I would just get errors when I would try, so it did not actually work. The funny thing is I can login as guest only using another Lion client. Using smb:// at the Connect to server dialog window I am able to use guest and login fine. Though when it comes to Windows 7 trying to login, I type in guest/Guest as username and it doesnt work. I can only login when I have my username enabled within the file sharing smb options. Definitely a weird bug that I hop is smashed soon. I'll let you all know if I make any progress.
  12. madman555 macrumors member

    Feb 20, 2009
    I created a new user account called "share" and set the new account to "Sharing Only". Left the password field blank too. When I went to connect to my shared folder on my Mac from Vista, I just typed "share" instead of "guest" and it worked. Not sure what's wrong with the Guest account but it seems like there's a password set to it.

    One more thing, I had to go to Sharing -> File Sharing -> Options and then check the box next to the "share" account
  13. tstraus13 macrumors newbie

    Jul 23, 2007
    dsbnz... I tried you method but was still unable to log in as guest on a windows based machine. madman555 your method is actually the only one we have right now and is what I may end up doing. I have read around and it seems apple was unable to use the actual samba software and needed to create their own from scratch, so it easy to see why there are bugs. I guess we will have to wait for a proper update to come to fix these samba issues.
  14. madman555 macrumors member

    Feb 20, 2009
    I just noticed a minor issue. When copying a file to my Mac using the "share" account, only that user account has Read/Write permission. My account is not listed and "everyone" has no access. Any ideas on how I can automatically give Read/Write to the everyone account or to my account? If it matters, I shared my Public folder
  15. c0b4lt macrumors newbie

    Jul 21, 2011
    well i found a fix today. If that's what you'd like to call it anyways.

    Basically I installed mac ports then installed samba3. Then I made a smb.conf file that has my shares, that I want public/guest access to, defined. Turned off the native smb file share and started the copies of smbd and nmbd that mac ports installed. Voila guest shares working again.

    This method isn't exactly ideal for most people because they have no idea how to manually configure samba. But really its not difficult since theres an example conf file you can use. It even has a public share already defined. You could simply uncomment it and change the path and name and be all set to go.

    All I need to do now is figure out how to make them autostart with a launchdaemon and I'm set till apple releases an official fix for their implementation. I wanted to look at the /System/Library/LaunchDaemons/smbd.plist and /System/Library/LaunchDaemons/nmbd.plist files from a SL install to see if I could modify them to use the copies of smbd and nmbd that gets installed by mac ports. But don't have another machine available to install SL on atm to grab them from lol.
  16. stiwi macrumors regular

    Nov 13, 2010
    After few hours of searching I found your suggestion and it worked. Thanks.
    Seriously, what's wrong with SMB sharing for Windows devices? It worked properly on SL with Guest account and now it doesn't. Previously it was possible to share files with Windows devices without ticking any accounts under file sharing options.
  17. glennschmidt macrumors newbie

    Nov 19, 2011
    Here's a workaround I've found that doesn't involve creating a new account on the mac.

    Use the windows command prompt to connect the share to a drive letter, and explicitly force it to use a blank username and a blank password. Like this:

    net use J: \\macserver\sharename "" /USER:
    Where J: is the drive letter you want to use, and macserver is the name of your server, or its IP address.

    PS. This is just one of six different SMB filesharing problems I have encountered since moving to Lion. The new SMB server seems to be badly broken.
  18. eradicator006 thread starter macrumors newbie

    Jul 12, 2011
    I ended up disabling apples smb and using samba 3 from macports. I have some folders on an ntfs volume that I need to share. I was unable to share anything on ntfs volumes with apples smb or afp.
  19. pjgois macrumors newbie

    Aug 4, 2012
  20. eniveld macrumors newbie

    Jan 13, 2014
    Apple doesn't play well with friends

    Here it is, 2014, and I can't freakin' mount a windows share on a Macintosh as guest. This ranks up there with banning Flash as one of the stupidest things Apple has done as far as actively refusing compatibility with non-Apple technology. Apple could easily have gotten this working.

    This use case just isn't supported by Apple, and likely never will be. Use a named account instead.

Share This Page