SMB Shares Broken

Discussion in 'OS X Mountain Lion (10.8)' started by 618537, Jul 27, 2012.

  1. 618537 Guest

    Sep 21, 2011
    Attempting to connect an iMac to Windows Server 2008 and unable to connect to the shares.

    Done a little bit of Googling and there are a few vague reports on the Apple Communities.

    Is anyone else experiencing this issue and have they found any solution?

    (Only problem I've encountered on ML but a major issue for when at work if we want to roll out ML)
  2. pianodude123 macrumors 6502a


    Mar 1, 2005
    in the internet
    I'm having huge problems with getting connected to my Ubuntu NAS server with SMB. ALl I get is beach balls.
  3. rgarjr macrumors 603


    Apr 2, 2009
    Southern California
    I'm able to connect to my W7 machine (which has 2 SMB drives) just fine on my MB.
  4. eddienyc1 macrumors newbie

    Mar 4, 2011
    Brooklyn, NY
    Change Computer name to IPAddress to fix SMB shares

    I was having the same trouble yesterday once I installed ML but resolved it this morning.
    When I tried using my existing "connect to Server" connections which worked fine in Snow Leopard I kept getting an error message that it couldn't connect.
    I decided to change the computer name to the actual IPAddress and it worked fine.

    old method SMB://UserName@computerName
    new method SMB://IPAddress/
    which them prompted me to sign in as a register User. I saved the password in my keychain and was successful in connecting to my Windows Computer.
  5. callan37 macrumors newbie

    Nov 3, 2011
    In Lion, I would type "smb://ipaddress", - this stopped working in ML, however, typing "smb://ipaddress/sharename" is working - there is still an issue that I can't simply connect to the server (there are 4 different share drives on the same server, so I used to be able to simply connect to the server). Also, the server comes up under 'shared', but if I click this it just has a folder that says " /" and the link doesn't connect to anything.

    So this workaround worked for me, but still not ideal.
  6. 618537 thread starter Guest

    Sep 21, 2011
    Advice coming from Applecare at the moment is this ^.

    Not ideal but at least not disastrous.
  7. BernieC macrumors newbie

    Jun 20, 2002
  8. gerryf macrumors newbie

    Jul 25, 2012
    Were these pre-connected shares that worked, and then no longer work after an upgrade?

    Did you browse to the connection, or just try to direct connect with smb://computer/share?

    What OS is the server running?

    I haven't had any issue with ML, but I had some periodic issues with Lion....
  9. gogg macrumors newbie

    Nov 11, 2010
    Dundee, Scotland
    SMB connect failure

    Ever since I updated to ML, SMB share to my NAS drive the connection no longer works. The only way I can connect is using a virtual Mac running Lion under Parallels. Seems its an Apple problem, hopefully they release a patch soon.
  10. stucazzo81 macrumors newbie

    Mar 9, 2012
    The Fix! - At least for me

    I had this same issue after upgrading to ML. I have a Windows 7 server at home with data that I access through SMB. After hours of troubleshooting, I removed the stored usernames/password for the shares in keychain and repaired my disk permissions (from within ML). SMB started working again. Sad how this issue was noticed and reported back when ML first hit developers. Good luck to all, hopefully this fix works for you too!
  11. zombiecakes macrumors regular

    Jul 11, 2012
    I can connect fine but it has never automatically detected a network pc, for some reason it seems to work fine at work
  12. smoledman macrumors 68000

    Oct 17, 2011
    I can't get SMB share working since upgrading to ML. ******* Apple.,
  13. itsamacthing macrumors 6502a

    Sep 26, 2011
  14. costabunny macrumors 68020


    May 15, 2008
    Weymouth, UK
    Yeh I had this too so I disabled File Sharing and installed Samba3 using Macports - so much easier and works like a charm
  15. al5x macrumors newbie

    Feb 11, 2013

    I found this thread whilst looking for the solution to a slightly different issue which may or may not be apologies if this takes things off track!

    I recently migrated some data from a Mac server onto a Windows 2008 server and shared it out via SMB; result was as follows:

    1. Windows clients could connect to shares ok and see all file & folders.

    2. 10.7.x Mac clients and above were able to connect to the share but some sub folders were missing/invisible.

    3. 10.4.x Mac client could see all the contents of the folders within the share.

    Turns out that some of the folders had a <space> character following the folder name (which is effectively invisible unless you go to rename a folder). I was unable to rename the folder (removing the space) via Windows explorer as it thinks that 'foldername<space>' and 'foldername' are the same name (I didn't get round to trying to rename it via a command prompt encapsulating the folder in quotes but this may work), however renaming it via the old 10.4.x Mac did the trick, all folders were then visible on all clients.

    In one particular case you could see a top-level folder that contained a trailing space but you couldn't see any sub-folders within it (some sub-folders contained spaces, some didn't).

    So long story short, if you're connecting ok to an SMB share but can't see certain folders, look for any rogue trailing <space> chars.

    Hope this helps anybody else with a similar issue!


Share This Page