SMB Sharing cant deselect main account

Discussion in 'Mac OS X Lion (10.7)' started by jmcgeejr, Aug 14, 2011.

  1. jmcgeejr macrumors 6502

    jmcgeejr

    Joined:
    Oct 7, 2010
    Location:
    Seattle, WA
    #1
    Ok so I was going to setup smb sharing for my windows PC's however no matter what I do it keeps checking the main account to use I basically cant deselect it. So everything that my account has access to get's shared via SMB and I dont want that. Any ideas?
     
  2. eljanitor macrumors 6502

    eljanitor

    Joined:
    Feb 10, 2011
    #2
    It keeps checking which main account on the PC or Mac?

    So the share is on the Mac? When you try to file share on the Mac it wants to share the entire Macintosh HD, and won't let you just share selected folders?

    This is what I hear. I have a Peer to peer network that I'm trying to create between a Mac and a PC. My Mac is running Lion and it wont share just the folder I want to share. How do I just share what I want and not my whole hard drive.

    Please be as specific as you can and lets see if we can help you. What version of Windows are you using as well?
     
  3. jmcgeejr thread starter macrumors 6502

    jmcgeejr

    Joined:
    Oct 7, 2010
    Location:
    Seattle, WA
    #3
    Ok here are the details.

    Mini=OSX 10.7
    HTPC=Windows 7

    When enabling SMB on the mini, it shows my only account on the mini (Mike) and that account is checked. I dont want SMB to use that account to share because then it shares EVERYTHING because that account is the main admin account and has access to everything. I have tried creating a share account and using that but NO MATTER what I do the SMB sharing uses the Mike account, I can't deselect it. If I deselect it and type in the password it just reselects it again.

    When I access the mini from the windows 7 PC I see all disks as being shared and have access to them because it's using the Mike account.


    Hope that makes more sense.

    Cheers.
     
  4. eljanitor, Aug 14, 2011
    Last edited: Aug 14, 2011

    eljanitor macrumors 6502

    eljanitor

    Joined:
    Feb 10, 2011
    #4
    Ok I noticed this glitch as well. So What I did was I made another limited account on the  Lion Machine. Went to "Sharing" and then I then selected the shared folder(s) that I wanted and added the new limited account account to the share. Then I gave Admin no access to the share. I selected the new limited account in the SMB preferences, and typed in the password. Then I restarted the Lion Mac. Went back to Sys preferences and was able to deselect the Admin account. Then I restarted the Lion Machine one last time.

    • On the windows 7 machine It then shouldn't let you just go to Network and select you Lion Mac Mini. and it should ask you for the username and password.

    To log on to the Mac from windows:
    Once asked for your password etc......
    • Select option B "Use different credentials."
    •Then log on using that new limited Mac account and password to the Mac share(s).

    Let me know if that helps at all.
     
  5. jmcgeejr thread starter macrumors 6502

    jmcgeejr

    Joined:
    Oct 7, 2010
    Location:
    Seattle, WA
    #5
    Ah I think I see what you mean I will go and try that. Cheers.

    ----------

    That didnt work I am not sure I am understanding your directions exactly, I still cant deselect the main account.
     
  6. eljanitor macrumors 6502

    eljanitor

    Joined:
    Feb 10, 2011
    #6
    Sorry, it's not working for you, I reworked the info one last time to make more sense. Try the last edit. Otherwise Try to zap the P-RAM on the Mac Mini. That may help release the Admin account from SMB sharing.

    Zap P-RAM:http://support.apple.com/kb/ht1379

    Spent many many hours making Lion and Windows 7 share files properly. it's really difficult to make it work properly. Thank God it finally worked!

    Some days dealing with computers can be like:http://www.youtube.com/watch?v=WUUptX0i55g&feature=related pardon the language.
     
  7. jmcgeejr thread starter macrumors 6502

    jmcgeejr

    Joined:
    Oct 7, 2010
    Location:
    Seattle, WA
    #7
    Cheers, I went through your steps twice and I still cant deselect it, oh well :) thanks for the help though!
     

Share This Page