SMC Fan Control not working properly?

Discussion in 'Mac Apps and Mac App Store' started by Michael13, Nov 3, 2008.

  1. Michael13 macrumors member

    Joined:
    Nov 2, 2007
    Location:
    Rockland County NY
    #1
    I have a MacBook pro (pre-2008 update), and recently had to reinstall smc fan control after trying out another fan control app i thought might be better. After finding out that smc was the way to go, i reinstalled it. After reinstalling smc, it was never working properly like it was before i uninstalled it. When I make a favorite and then set that favorite on the menubar, the fans kick up to the speed i set it to for about 3 seconds then they return to the normal 2000 rpms. nothing I do can fix this. i have tried reinstalling, reinstalling different versions etc. Anyone else having this issue?
     
  2. Michael13 thread starter macrumors member

    Joined:
    Nov 2, 2007
    Location:
    Rockland County NY
  3. cptrios macrumors newbie

    Joined:
    Oct 31, 2008
    #3
    I've got the same issue...I'm thinking it's just something silly we're missing. Anyone have the answer here?
     
  4. cptrios macrumors newbie

    Joined:
    Oct 31, 2008
    #4
    Alright, I sent the developer an e-mail to see if he has any idea what's going on. So we'll see how that goes.

    I THINK that the problem lies in the fact that I tried smfancontrol 1.2 before 2.1.3, and didn't uninstall the first one before I ran the second. It functioned perfectly the first time I ran it but now it's just ramping up for a second and settling right back down. I should mention as well that the problem persists even after I do an SMC reset AND a PRAM reset and reinstall. And version 1.2 won't even open up anymore!

    And neither, for some reason, will iCyclone! Ugh, this is terrible...I'm afraid to run anything in Boot Camp until I get this straightened out.
     
  5. andybill macrumors newbie

    Joined:
    Jun 3, 2008
    #5
    I am having the same problem. Any answers yet?
     
  6. jugdish69 macrumors newbie

    Joined:
    Jan 11, 2009
    #6
    you need to remove fan control by deleting it from the startup menu in the library folder, then removing it from the preference panes also found in the library folder. Restart your computer, then run the app smc fan control to put everything back to normal......
    To be safe.....reset you computers SMC by unplugging the ac cord, remove the battery and hold down the power button for 10 seconds......
     
  7. SoundesignDanny, Nov 27, 2010
    Last edited: Nov 27, 2010

    SoundesignDanny macrumors newbie

    Joined:
    Nov 27, 2010
    #7
    Same Issue :(

    Hey jugdish69. I'm having exactly the same problem. I originally had smcfancontrol before on my 2010 MBP and liked it, this was before my hard drive died of its own accord and I got a new one installed by apple and had to reistall everthing.

    Anyway I just went to get a fan control app again and forgot the name of it, downloaded and installed fan control 1.2 which I then noticed was different and didnt like it. I decided to try and find what I now know is smcfancontrol.

    I simply right clicked on the fan control 1.2 icon in the OSX Prefferences menu and clicked 'Delete fan control 1.2' and restarted.

    Iv now installed smcfancontrol 2.2.2 and when I change the fan speed they change for around 4 seconds before going back to default.


    I noted your suggestions however i do not seem to have a 'Startup' menu/folder or 'Login Items' as I read somewhere else, and my 'Preference Panes' folder is empty. Maybe suggesting fan control 1.2 was removed but somehow altered the fan settings? :/

    Is there any other way to rectify this problem without the hard reset you suggested to save me having to reistall everything once more for what seems such a small app choice mistake? And do you think this would even fix the issue?

    Thanks in advance for any help :)

    Danny
     
  8. mac-burn macrumors newbie

    Joined:
    Jan 26, 2008
    Location:
    in the sun
    #8
    no GUI on 10.6.5 snow leopard

    Has anyone successfully run smcfancontrol on snow leopard?

    I installed this for the first time and there is no GUI, however there is a process running;"smcFanControl".

    I re-booted; same, no GUI, so no way to adjust the fan settings!!

    Has anyone seen this problem, perhaps solved it?

    Thanks.....
     
  9. roughbeast macrumors newbie

    Joined:
    Dec 19, 2010
    #9
    I have this exact problem and no solution. It's in my apps utilities, it's running and using 7.9MB memory, yet there is no GUI, no controls, and my computer is as hot as ever '(iMac 10.6.6/3.06GHz Intel i3). I uninstalled (trashed) it, dl again, same thing - nothing, zip, nada. Back to the trash. And the developer's site says it's compatible with Snow Leopard. Not my Snow Leopard.
     
  10. PhantomPumpkin macrumors member

    Joined:
    Feb 4, 2011
    #10
    SMC Fan Control

    If I remember correctly, when I installed it on my 2009 MBP it told me it was "not supported for this machine, but should still work". I found that odd, but I did have some of the same issues. A reboot appears to have fixed it, although I have far fewer options than on my iMac. My minimum speed is 5k, whereas it's 1k on the iMac. I'm aware they should have different settings, just found it odd that 5k was the minimum. :)
     
  11. PhantomPumpkin macrumors member

    Joined:
    Feb 4, 2011
    #11
    It's no longer in the preferences pane, but installed on the menu bar. If nothing else, search for it? It works wonders on my iMac.
     
  12. roughbeast macrumors newbie

    Joined:
    Dec 19, 2010
    #12
    It never was in Preferences, and it's not on the menu bar or the dock. Finding it is easy - it's in Apps, and when I "open" it, it shows up on the Activity Monitor. But opening it doesn't do anything else - no GUI, no nothing. I've uninstalled and reinstalled 3 times, rebooted afterward, still nothing. Running, but not under my control and not doing anything - like I said, my computer is as hot as ever, and I cannot adjust fan speed or anything. It's like it's there, but that's all. I can see from the download site that others are having the same problem.

    I wonder if it's got something to do with 10.6.6.
     
  13. jasl10 macrumors newbie

    Joined:
    Apr 27, 2011
    #13
    Hey I just found the solution to this problem if you had previously installed fan control.

    Go into Macintosh HD (or what you called it) > Library > Preference Panes and delete fan control.

    Then go to: Macintosh HD > Library > Startup Items and delete "Fan COntrol Daemon or something similar.
    After this delete the icon for fan control in the system preferences pane if it is still there.

    Restart your computer and SMCFanControl should work. It worked for me after this.

    Hopefully this works for you guys. Email me if my instructions were not clear.

    * This requires that fan control is STILL INSTALLED! Just re-instal if you deleted it.
     
  14. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #14
    With smcfancontrol running, look up in the menu bar,,,, you should see it up there. That is the "GUI." From there you can select preferences and make new settings, etc.
     
  15. avdheshsmaurya macrumors newbie

    Joined:
    Mar 18, 2012
    #15
    SMC Fan Control Not working properly!!!

    Hi Folks,
    I just found out that after deleting the file from pref.pane there was one more start up item in the folder Library\StartupItems named FanControl. Once I deleted the folder & restarted the system everything just came back to good old days :)
     
  16. ultrabox macrumors newbie

    Joined:
    Oct 17, 2008
    #16
    so i just had a very similary problem, but possibly because of an entirely different cause.

    i opened my macbook and used my vacuum cleaner at max power to remove all the dust. i didn't notice however that a big ball of hairs and dust formed between the fan blades, and closed the laptop. smc fan control showed me 0rpm for the fan, so i opened it again, found and removed the clogging dust/hair ball, and the fan was working again, cooling the computer.

    worth checking, i guess, if nothing else works :D
     
  17. dudeimcool1 macrumors newbie

    Joined:
    Aug 25, 2015
    #17
    i really really thank you .. it worked for me though :p i signed up just to reply to u
     

Share This Page