Smoke just came out of my USB port

Discussion in 'MacBook Air' started by amytxoxo, Dec 2, 2016.

  1. amytxoxo macrumors newbie

    Joined:
    Aug 15, 2013
    #1
    I just plugged in my external hard drive through the USB port on my MBA and it started smoking right when I plugged it in. I immediately unplugged it and smelled burning. I've never had this happen and now I'm worried and too scared to try to plug it in again :/
     
  2. s15119 macrumors 65816

    s15119

    Joined:
    Nov 20, 2010
    #2
    I'd turn off that computer and not turn it on again until I could get it to Apple or a certified shop.
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
  4. amytxoxo thread starter macrumors newbie

    Joined:
    Aug 15, 2013
    #4
    Thanks for the responses! I took my computer and the hard drive to the genius bar. Genius couldn't find anything wrong with my computer. She plugged the hard drive in multiple times and nothing happened.

    When I got home I plugged the hard drive in and it smoked and burned my finger! Now there's a black spot on my finger and it smells terrible. I'm definitely never plugging that thing in again! :/
     
  5. Wackery macrumors 6502a

    Joined:
    Feb 1, 2015
    #5
    what drive are you using?
     
  6. amytxoxo thread starter macrumors newbie

    Joined:
    Aug 15, 2013
    #6
    It just says 2.5" SATA on it. Probably cheap junk
     
  7. Pootmatoot macrumors 6502a

    Joined:
    Nov 17, 2014
  8. amytxoxo thread starter macrumors newbie

    Joined:
    Aug 15, 2013
    #8
    Yeah!
     
  9. Pakaku macrumors 68000

    Pakaku

    Joined:
    Aug 29, 2009
    #9
    Can you use a different cable for the harddrive?

    Was the laptop on battery when it smoked, or was it plugged in? And what about at the Genius shop?

    If it was plugged in, was the charger on the extension cable or was it using the folding adapter? And is the charger definitely an Apple charger?
     
  10. amytxoxo thread starter macrumors newbie

    Joined:
    Aug 15, 2013
    #10
    It was plugged in the first time but not the second time when it burned me. I think I'm going to try using a different hard drive and a different cable
     

Share This Page