SMS doesn't make sound problem

Discussion in 'iPhone' started by opticalserenity, Jul 22, 2008.

  1. opticalserenity macrumors 6502a

    Joined:
    Apr 14, 2007
    #1
    Sometimes, even when not in quiet mode, SMS will only vibrate. The screen is off, and all it does is vibrate instead of making the chosen sound. I've tried restore, reboot, etc.

    Anyone else have this issue?
     
  2. mrtune macrumors 6502a

    Joined:
    Jun 23, 2007
    #2
    Happens to me too. All other system files work, but sms ringers just goes to silent after a while all by itself.

    A restart fixed it for me, but I got tired of doing it over and over again. Then I discovered a different method. I simply go into the system settings and change it to a different sound. If it stops working I change it again.

    This is a 2.0 firmware bug IMO. Hopefully it gets fixed with the next update.
     
  3. Pheelyx macrumors regular

    Pheelyx

    Joined:
    Oct 22, 2007
    Location:
    Brookland, AR
    #3
    My iPhone did the same thing. Upgrading to the new firmware fixed the problem. You have to restore your phone to get the new one. Apparently this was a silent update to the firmware. The version that came with the phone has a lot of problems.
     
  4. opticalserenity thread starter macrumors 6502a

    Joined:
    Apr 14, 2007
    #4
    I'm on the 5A347 firmware, unless there is something newer out there I don't know about.
     
  5. Pheelyx macrumors regular

    Pheelyx

    Joined:
    Oct 22, 2007
    Location:
    Brookland, AR
    #5
    That's the firmware I'm on and that fixed the SMS sound problem. I restored my phone just to fix this problem. I had read in other threads that the 5A347 firmware would fix it. I don't know why you would still be having that problem.
     
  6. scorpiusdeus macrumors member

    Joined:
    Jul 16, 2008
    Location:
    Ventura County, CA
    #6
    How does the average joe who doesn't know about firmware update this?
     
  7. opticalserenity thread starter macrumors 6502a

    Joined:
    Apr 14, 2007
    #7
    the average joe just needs to connect the iphone, and go to itunes and click restore.
     
  8. atiffarooq macrumors 6502

    atiffarooq

    Joined:
    May 27, 2006
    #8
    This happens to me too. All I do is go in to SMS and hold the Home button for about 7 seconds or so, which kind of hard closes the application. After that all is fine again, and the SMS tone sounds when a message is received.
     
  9. Ryhian macrumors member

    Joined:
    Jul 8, 2008
    Location:
    Orlando, FL
    #9
    I've been having the same issue. Its a 2.0 issue for sure. Im on the most recent firmware and it seems to happen to me from opening and closing apps from the app store.
     
  10. opticalserenity thread starter macrumors 6502a

    Joined:
    Apr 14, 2007
    #10
    Time to forward this thread to apple, with a "please fix, k, thx"
     

Share This Page