SMS Forwarding iOS 8.1

Discussion in 'OS X Yosemite (10.10)' started by Reapoxide, Oct 2, 2014.

  1. Reapoxide macrumors newbie

    Joined:
    Oct 2, 2014
    #1
    Dear MacRumor,

    When I try to enable SMS forwarding on my iPhone, it is asking for a code that should pop-up on my macbook.
    Messages app is opening on my mac, but it I don't see any code and after a few second it crashes, giving me a bug-report.
    Any idea on how to fix this?
    I really can't live without the SMS forwarding :(

    Thanks in advance!
     
  2. bkribbs macrumors 65816

    Joined:
    Jan 15, 2012
    #2
    Try repairing permissions and if that doesn't work, I would reinstall the GM.
     
  3. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #3
    Try turning the text forwarding option off and on. That should prompt the code to show on your Mac.

    I get the frustration although it isn't as dire as you may think. You were able to cope before this feature. I am sure Apple will iron things out some more before the official release of iOS 8.1
     
  4. Reapoxide thread starter macrumors newbie

    Joined:
    Oct 2, 2014
    #4
    I can never get it turned on, I need the code to turn it on.
    When I try to turn it on my messages app on mac opens and all I get to see is this:
    [​IMG]

    The annoying thing I'm really used to the feature, as it was enabled in previous betas..
     
  5. Dragonforce macrumors 6502a

    Dragonforce

    Joined:
    Apr 9, 2008
    Location:
    London (Ealing) UK
    #5
    You probably only have your mobile phone number registered in iMessage to send and receive messages from. Please add at least one email address to this, and it should work immediately.
     
  6. Reapoxide thread starter macrumors newbie

    Joined:
    Oct 2, 2014
    #6
    On both my mac and iPhone I have my mobile number and email address enabled. Problem is when I press enable SMS button on my iPhone, my Messages app on Mac crashes..
     
  7. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #7
    had this problem myself, email address fixes it.
    I just like having my mobile number take over, can I remove my email now and still have the SMS Forwarding work?
     
  8. jharnett macrumors newbie

    Joined:
    Mar 13, 2013
  9. Reapoxide thread starter macrumors newbie

    Joined:
    Oct 2, 2014
    #9
    It got fixed just by adding the e-mail? I have the email on both mac and iPhone but still getting no code and the messages app still crashes on mac :/
     
  10. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #10
    Working perfectly for me. I opened Message on the Mac, entered the code into my iPhone, and hey presto.
     
  11. dallardice macrumors regular

    Joined:
    Jan 29, 2008
    #11
    This didn't work for me at all yesterday - OS 8.1 beta and Yosemite GM.

    No combination of turning things on and off, adding and removing email addresses made any difference, I couldn't get the code to appear on my iMac.

    This morning, while getting ready for work, I tried it again on a whim and this time the code popped up immediately. "Just one of those things"

    Still can't persuade a code to appear on my iPad though.
     
  12. farleysmaster macrumors 6502a

    Joined:
    Feb 8, 2008
    Location:
    London, UK
    #12
    Does this require an iPhone 5S and above, or does it work on any handset with iOS 8.1?
     
  13. activate macrumors regular

    Joined:
    Dec 24, 2011
    #13
    Any
     
  14. joshuaad macrumors newbie

    Joined:
    Oct 21, 2014
    #14
    It's not working for me using the following: iPhone 4S, MBP early 2008, iPad 4.
    The phone sees the other devices but no codes pop up on either of them.
    Emails are in the settings. Any suggestion is appreciated.
     
  15. farleysmaster macrumors 6502a

    Joined:
    Feb 8, 2008
    Location:
    London, UK
    #15
    I'm having the same issues. I've always had email addresses registered on my iMessage.
     
  16. farleysmaster macrumors 6502a

    Joined:
    Feb 8, 2008
    Location:
    London, UK
    #16
    Ok, I set the iCloud address as the main address for iMessage, and then when I tried to activate sms forwarding, Messages opened on my Mac, but no code...
     
  17. lancastor macrumors 6502a

    Joined:
    Jun 25, 2011
    #17
    iOS8.1 / Yosemite 10.10 / MacbookAir 2012

    No popup with the code :(
     
  18. mrbyu macrumors 6502

    Joined:
    Jul 5, 2011
    #18
    If I recall it correctly, some people said in other threads that the trick was that you must enable in Messages (both on the Mac and iPhone) that you can be reached at your e-mail adress, not just at your phone number. Thus, the verification code shall arrive and after that you are free to disable your e-mail adress in Messages if you wish so.

    Edit: I see I'm kinda late with the answer, sorry :) Mine worked however without any tinkering, but I should add that I made a clean install of Yosemite.
     
  19. AJsAWiz, Oct 21, 2014
    Last edited: Oct 21, 2014

    AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #19
    How do you enable that you can be reached at your email address on your Mac? I'm not seeing this option at all.

    Strange . . . the option for Text Message Forwarding just disappeared on my iPhone. Now I can't do this at all.
     
  20. Gratefuldad macrumors newbie

    Gratefuldad

    Joined:
    May 16, 2014
    Location:
    San Diego, CA
    #20
    Mine wasn't working because it wasn't showing the phone # was reachable via iCloud from my iPad or MBP. I got it working by removing the iCloud acct from my iPhone. recreating/verifying the email/phone#. Now in message.app I now see the phone # and email under the iCloud acct.
    Also on the iPhone make sure under settings>>>messages>>>send & receive verify that "start a new conversations from" your phone # is checked.
    Then go back to the MBP sign out of iCloud and back in. After that I was able to setup and receive the pop-up for the txt message forwarding PIN #.
     
  21. pgv macrumors newbie

    Joined:
    Oct 21, 2014
    #21
    Text forwarding did not work for me at first (iPhone 6, 2013 MacBook Pro) but worked when I set up my wife (iPhone 5S, 2012 MacBook Air)

    I just got it to work. I tried everything else then solved it. Turn off iMessage on your phone. (Settings then Messages, iMessage slider). Now exit settings then go back in and turn iMessage back on. Next on my MacBook Pro I got a pop-up: Add 508-xxx-xxxx to Messages? Click yes. Next go back to your phone and now enable Text Message Forwarding. Then the pop-up with code will appear on your Mac.

    Note that when you first turn iMessages back on the option to forward does not show up immediately - but will reappear after awhile
     
  22. ipedro macrumors 68040

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #22
    I had to sign out and back in on all my devices one by one. It's not ideal, but it did eventually work. It works perfectly now.
     
  23. whackmack168 macrumors newbie

    Joined:
    Oct 22, 2014
    #23
    It only works on my early 2011 MPB and iphone 5 when I have at least 1 email selected in iMessages settings on the phone and computer along with my cell number. I selected the email that I use to log into icloud, itunes, app store, etc. I believe that you have to keep it enabled too.
     
  24. dakota747 macrumors member

    dakota747

    Joined:
    Sep 24, 2013
    Location:
    Utah
    #24
    Alright so it sorta works for me, however I cannot reply to an SMS text message that comes into my computer nor create a text because my Mac will only send it as an iMessage. Any suggestions?!#
    MacBook Pro 2013/iPhone 6 (Yosemite and iOS 8.1 obviously#)
     
  25. whackmack168 macrumors newbie

    Joined:
    Oct 22, 2014
    #25
    I had some issues with this also. I just made sure that I selected the email address that I use for my apple id on both my mac and iphone. I prefer just having my phone number selected, but it seems that you need to have the matching email addresses selected on both devices. My phone number is also selected and I think I may have rebooted both also just to be on the safe side. It is strange that there are no clear cut instructions on how to set this up.
     

Share This Page