SMS Forwarding not working

Discussion in 'iPhone' started by ineel, Oct 20, 2014.

  1. ineel macrumors regular

    Joined:
    Jul 8, 2010
    #1
    Hi, I have Yosemite and just installed iOS 8.1 on my iPhone 6. When I go to Settings > Messages > Message Forwarding > (turn on my mbp), it asks me to enter the code that is shown on my mac. No code is shown on my mac and thus i cannot activate sms forwarding on my mac. I've tried restarting my mac and my iPhone but no code is showing up on my mac. Anybody else having this problem?
     
  2. CoilTap macrumors regular

    Joined:
    Sep 19, 2014
    #2
    Just to verify - do you have bluetooth enabled on both devices?
     
  3. ineel thread starter macrumors regular

    Joined:
    Jul 8, 2010
    #3
    Yes, wifi and bluetooth are on on both my mbpr and iPhone 6
     
  4. smithy12 macrumors newbie

    Joined:
    May 29, 2012
    #4
    Try logging out off iMessages then back in ....also make sure your mobile number has a tick next to it
     
  5. HXGuyAZ macrumors 6502

    Joined:
    Sep 3, 2014
    #5
    You have to make sure you also have an email address enabled for iMessage on both the phone and the computer, not just your phone number and then it will work.
     
  6. Königsblauer macrumors newbie

    Joined:
    Aug 31, 2014
    #6
    Add a mail-address as an alternative to receive messages alongside your number on every device. This worked for me.
     
  7. iapplelove macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #7
    Works great for me! But now I can't use the excuse I only had my iPad on me when I don't get back to my gf right away.
     
  8. ineel thread starter macrumors regular

    Joined:
    Jul 8, 2010
    #8
    Thanks so much! I just had only my phone number selected and I listened to your advice and ticked my email as well on both my laptop and phone and now SMS forwarding works! Thanks so much!
     
  9. imac9556 macrumors 6502a

    Joined:
    Jul 12, 2004
    #9
    Yes! You have to have the phone number AND email address for SMS handoff to work!
     
  10. zakarhino macrumors 6502a

    zakarhino

    Joined:
    Sep 13, 2014
    Location:
    Bay Area, CA.
    #10
    I have enabled it successfully from what I can tell but the Mac Messages app has not updated to display all the conversations/threads that I have on my iPhone messaging app.

    Is this intentional? How do I sync the conversations?
     
  11. HXGuyAZ macrumors 6502

    Joined:
    Sep 3, 2014
    #11
    It'll probably only sync going forward, not back sync all your messages that aren't iMessages.
     
  12. jfyrfytr25 macrumors 6502a

    jfyrfytr25

    Joined:
    Dec 6, 2008
    #12
    It's not going to sync old threads. All this is doing is forwarding any new messages over to the iMessage servers to show up on your devices. Old stuff is just that, Old.
     

Share This Page