SMS from a contact shows as 'Voicemail'

Discussion in 'iPhone Tips, Help and Troubleshooting' started by tmiles81, Sep 28, 2012.

  1. tmiles81 macrumors member

    Joined:
    Sep 13, 2011
    Location:
    Melbourne, Australia
    #1
    Hi Guys,

    Hoping someone can help me out.

    I got my iPhone 5 set up on Telstra (Australian network) yesterday, but whenever my wife sends an SMS, the preview says it has come from 'Voicemail'.
    When i go into the message, it shows up as being from my wife along with all previous messages.

    I have had a SMS from a friend and theirs showed their name correctly in the preview screen.

    Has anyone had this or heard of it before? I tried deleting her from my contacts and then re-adding, but still hasn't fixed the problem.

    Thanks,

    Tim
     
  2. Sambob75, Oct 17, 2012
    Last edited: Oct 17, 2012

    Sambob75 macrumors newbie

    Joined:
    Oct 17, 2012
    #2
    Hi I have the exact same problem,

    I have tried deleting and adding, have tried a factory reset, nothing seems to work. I have lodged a ticked with Apple and they did not seem to care, have also lodged a ticket with Telstra and they are looking into the issue, by the way Apple said it was a Telco issue.

    Did you find a fix?

    By the way does you wife happen to have a HTC windows phone? perhaps it is a bug.

    And one more thing, does your wife have 101 in her number, I think it is a iPhone bug.

    Sambob.
     
  3. tmiles81 thread starter macrumors member

    Joined:
    Sep 13, 2011
    Location:
    Melbourne, Australia
    #3
    Hi, nah i haven't found a fix yet and i did the whole deleting and re-adding like you!
    Her phone is an iPhone 4 and yes she has 101 in her number too.
    Let me know what Telstra end up saying please its just so annoying when i get a sms from her!
    Thanks.
     
  4. Sambob75 macrumors newbie

    Joined:
    Oct 17, 2012
    #4
    Hi,

    No love from Telstra, I think it is a bug we will have to learn to live with I have tried numerous things but the phone has a mind of its own!!
     
  5. hammered24 macrumors newbie

    Joined:
    Sep 25, 2010
    #5
    Have the exact same problem.

    Telstra iPhone 5 running iOS 6.

    Number has 101 in it. Setting the contact to use the +61 4xx xxx xxx instead of 04xx xxx xxx seems to have fixed it.
     
  6. Sambob75 macrumors newbie

    Joined:
    Oct 17, 2012
    #6
    I tried that did not seem to work for me.
     
  7. 2011Mnglxr macrumors newbie

    Joined:
    Jan 22, 2013
    #7
    Exact same problem here!

    And yes 101 in the number..
    Please keep us updated if u find a fix
     
  8. marty085 macrumors newbie

    Joined:
    Feb 10, 2013
    #8
    I have the exact same issue on Telstra post paid on a 3GS running iOS 6.1, my mate's number has 101 in it.. it is really damned annoying.
     

Share This Page