SMS GV Extension configuration problems

Discussion in 'Jailbreaks and iOS Hacks' started by tmccartney66, Jun 7, 2012.

  1. tmccartney66 macrumors newbie

    Joined:
    Jun 7, 2012
    #1
    I am running SMS GV Extension on an Iphone 4 with Verizon. I've been using the program since late May. I just discovered that texts to my GV number apparently are being forwarded to my cell number, so those count against my monthly text allowance.

    I had previously turned off "Text forwarding" in the settings on the official GV app that's installed on my phone, because I was getting every message twice. But apparently that needs to be on, and I need to switch something else off. I'm just not sure what.

    Can someone tell me how to configure the extension, the GV account and the GV app so that I am getting messages ONLY through GV? Thanks!
     
  2. MastahRiz macrumors 6502

    Joined:
    Aug 7, 2010
    #2
    Do you have the google voice app installed on your phone?
     
  3. tmccartney66 thread starter macrumors newbie

    Joined:
    Jun 7, 2012
    #3
    Yep.
     
  4. MastahRiz, Jun 7, 2012
    Last edited: Jun 7, 2012

    MastahRiz macrumors 6502

    Joined:
    Aug 7, 2010
    #4
    Alright, this is my setup, and I don't have text forwarding, but just rerouting of the text from the Google App to my SMS app (which is BiteSMS btw).

    Here's what I have setup:

    1. BiteSMS
    2. SMS GV Extension (Comes with SBSettings Toggle)
    3. Google Voice App from App store

    In the Google voice app, hit the settings gear icon in the bottom right and once loaded, scroll down to where it says "This phone," and under that click "This phone's settings." Make sure you have text forwarding turned off in this settings panel.

    Back to home screen. Go to settings, go to SMS GV Extension:

    (Obvious but, just for the sake of thoroughness, make sure you have same google voice account info filled in here.)

    Scroll down to receive settings:

    Official GV app: ON
    Local mail: Off (up to you really)

    Monitored Accounts: All

    Advanced:
    Refresh cache: ON


    That should do it for the receive settings.

    I leave enable send off and just use the SBSettings toggle when I feel like I need to send a text from the google voice number but want to send it straight from my SMS app.

    Hope that helps.

    EDIT:

    If that doesn't work, go to google voice on your browser, as there are more settings that you can configure from the actual google voice site than from the app or phone. Just make sure all the forwarding settings are off. As long as only the app receives the texts, and nothing else, you should be fine.
     
  5. tmccartney66 thread starter macrumors newbie

    Joined:
    Jun 7, 2012
    #5
    Thanks, Mastah. I'll give that a try. Text forwarding was turned on in the GV app.
     
  6. MastahRiz macrumors 6502

    Joined:
    Aug 7, 2010
    #6
    Hope it works, if not, keep me posted. PS also made an edit above.
     

Share This Page