SMS/iMessage notification show phone number

Jay-Jacob

macrumors regular
Original poster
Sep 10, 2015
228
57
England
iPhone notification show phone number instead contact name.

I reboot then it seem work but someone unknown text me made it go back phone number again!

iOS 9 bug?
 
  • Like
Reactions: Rhonindk

Jay-Jacob

macrumors regular
Original poster
Sep 10, 2015
228
57
England
I receive more text. Seem iMessage will appear as name in notification centre but SMS still appear phone number. Very annoy.
 
  • Like
Reactions: Rhonindk

astralman29

macrumors newbie
Sep 18, 2015
1
1
I receive more text. Seem iMessage will appear as name in notification centre but SMS still appear phone number. Very annoy.
I have the same problem. SMS notifications show the phone number and not the persons contact name. It then shows the contact name when you open the text.
Had a play around with various settings but no luck so far.
 
  • Like
Reactions: Rhonindk

andreyirra

macrumors regular
Oct 27, 2014
173
19
Mexico
This happened to me in my Mac. Turns out the Contacs app was not syncing the info so the system didn't have contact names to show in exchange for numbers.
 

Jay-Jacob

macrumors regular
Original poster
Sep 10, 2015
228
57
England
Hope it fix itself soon cos I have keep open iMessage thread see who it from. I usually quick look notifications if from main person. Can't do that right now.

Hope it fix without need wait iOS 9.1 or something.
 

archvile

macrumors 6502
Oct 27, 2007
463
596
Hope it fix itself soon cos I have keep open iMessage thread see who it from. I usually quick look notifications if from main person. Can't do that right now.

Hope it fix without need wait iOS 9.1 or something.
This sounds like a basic contact sync issue, not with iOS itself. It is working perfectly fine assuming it is set up correctly. Have you checked to see if you have contacts in the Contacts app and/or if iCloud contact sync is turned on?
 

perkedel

macrumors 6502a
Dec 30, 2014
534
203
California
well this is an interesting problem. I got a text reply, and it says iMessage with (abc) abc-abcd phone number, but it shows in green instead of blue. my other texts don't say iMessage with <phone number>, the numbers are not shown like it's supposed to, so that's normal.

i'm seeing this phone number on my air, and macbook pro. it appears okay on the iPhone though. i logged out and changed my iCloud password last night,
so i don't think it's a sync issue as:
1. I reset my icloud password and logged out iCloud from all my Apple devices including my Win 10 PC iCloud client.
2. i can see the contacts just fine in all three Apple devices, so I know they're syncing.
 

Jay-Jacob

macrumors regular
Original poster
Sep 10, 2015
228
57
England
iOS 9.0.1 update bug still there. Now download and install iOS 9.0.2 and bug still there! :'(

I hope iOS 9.1 will fix it.
 

Zcott

macrumors 68020
Oct 18, 2009
2,302
46
Belfast, Ireland
Are your localisation settings set correctly? I changed mine to US so I could get the News app, and my contacts were showing as numbers. Changed back to UK and it was all ok.
 

Jay-Jacob

macrumors regular
Original poster
Sep 10, 2015
228
57
England
Settings app General - Language and Region.

Region set UK and iPhone Language set English UK. All look fine and still bug with SMS.
 

Jay-Jacob

macrumors regular
Original poster
Sep 10, 2015
228
57
England
Just update iOS 9.2 today and bug still there!! That very long time bug. Need report again Apple.
 

blinkie

macrumors regular
Sep 7, 2007
241
31
Hi guys,

I Just got a new SE an I'm having this exact problem. Does anyone have a solution or know what's causing the issue?

Thanks,

B
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.