SMS Messages Show Numbers Not Names

Discussion in 'iOS 5 and earlier' started by wcniedb, Oct 14, 2011.

  1. wcniedb macrumors newbie

    Joined:
    Oct 14, 2011
    #1
    I just got the 4S today. In order to get my old apps/contacts/messages loaded I clicked "Restore from backup". Now I notice that in my SMS messages, some messages show the contact name but most do not. Upon researching I noticed the names that show correctly have their numbers formatted as "+1 (XXX)-XXX-XXXX". However I have entered in a new contact with the exact same phone number format and when I send a new text to them it shows their name. But as soon as they respond, it shows the number and appears under a new SMS thread (detached from the original one I sent). Any idea why the SMS app is not able to match the phone number of the incoming texts to the numbers in my contacts list?
     
  2. filmfanatic24 macrumors 6502

    Joined:
    Sep 5, 2007
    #2
    Same problem here:

    I had 5.0 GM loaded on my iPhone 4 so I had connected to iCloud, etc. last week. I sold my 4 and went to a 3G and am running whatever the best it can run is (4.3.5?).

    Anyways, wife and mom and both running 5.0 now on their 4 and 4s respectively. For some reason my texts are showing up on their phones as my number ( like 1+(XXX) XXX-XXXX) in the text message log but when you click on that it brings my name up at the top. I confirmed that my name and correct phone number is stored in their Contacts.

    Anyone know why this is?

    Also, is there a setting as you are typing an iMessage or Text to toggle between the two? The best solution I have found is to just send the iMessage and then touch the sent message and then touch "Send as Text Message".
     
  3. wcniedb thread starter macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    Other tidbits about the problem...

    I also wonder if there is an issue switching between AT&T and Verizon. In other words, wonder if the incoming phone numbers are formatted differently depending on your carrier? Maybe one sends in numbers as 1234567890 where as the other sends in "+1 (123) 456-7890". Either way it seems like the issue is that the iPhone is considering numbers formatted differently as different numbers. Rather than realizing they are the same number with different formatting. Seems like this could be an issue between the format in which numbers are sent vs. received... not to mention when importing SMS messages from anorther version of iOS or another carrier.
     
  4. filmfanatic24 macrumors 6502

    Joined:
    Sep 5, 2007
    #4
    I'm not sure. I didn't switch between carriers. I looked at my wife's phone and everyone else she has been texting looks like they should, with the name, except for my phone.
     
  5. lonman06 macrumors regular

    Joined:
    Feb 23, 2010
    #5
    I had same problem. Just restore from previous backup of your iphone4 again and it will correct the problem.
     
  6. filmfanatic24 macrumors 6502

    Joined:
    Sep 5, 2007
    #6
    Weird. Like one before the update to 5.0 or one that is just made by plugging into iTunes?
     
  7. willxfox macrumors newbie

    Joined:
    Oct 4, 2011
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I am having this exact same issue. I switched from AT&T to Verizon and the names / numbers are messed up. Any ideas?
     
  8. MachAF macrumors newbie

    Joined:
    Jun 22, 2010
    #8
    Same issue here. Backed up and did a restore, that didn't fix it.
     
  9. MachAF macrumors newbie

    Joined:
    Jun 22, 2010
  10. MachAF macrumors newbie

    Joined:
    Jun 22, 2010
    #10
    Solution: Generel - Reset - Reset all settings. That fixed it for me
     
  11. JMC08 macrumors regular

    Joined:
    Aug 28, 2011
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Same problem. Any fix that doesn't require having to enter all your settings again?
     
  12. MeghanF macrumors newbie

    Joined:
    Oct 19, 2011
    #12
    Yay! Found a fix... hope this helps others!

    I was having the same problem. One member observed that it was only the phone numbers without the "1" before the area code, where this was a problem.

    Here's what I did that just worked to fix the problem, and assign a thread of text messages back to the appropriate contact:

    1) Scroll to the top and tap "Add Contact"
    2) Select: "Add to Existing Contact"
    3) Assign to the appropriate contact in your contact book
    4) You will see the contact's info with the text message # in blue font.
    5) ADD the number "1" to the front of the blue number.
    6) Hit Done!

    That worked for me, I hope it worked for you! I haven't tested out receiving new messages from the same person yet, I suspect deleting the number without the "1" might prevent further confusion.

    I too switched from AT&T to Verizon, so perhaps this does reflect a difference in the way the numbers are stored.

    MORAL OF THE STORY: Assign the text message number to an existing contact, and then add a 1 at the front.



    Good luck! Hope it works for others!!!
     
  13. andrewwynn macrumors newbie

    Joined:
    Oct 30, 2009
    #13
    I had this problem since i restored my iPhone 4 onto my iPhone 4s. turned out to be a corrupted address book database on the phone.

    deleting the database @ /Users/Library/AddressBook (all files starting with AddressBook) (while Addressbook NOT running and when iCloud sync and iTunes sync both off) and re-run address book to create empty database before re enable sync solved it!
     

Share This Page