SMS not working with Apple Watch S4 & iPhone Xs Max

HDJulie

macrumors 6502a
Original poster
Jun 13, 2008
714
95
Little Rock, AR
I’m having a problem with SMS messages on the new S4 watch. Texts sent to me will show on the watch as a notification. However, the text itself does not show in Messages on the watch. I can send an SMS message from the watch & it will show on the phone & the person gets it, but the watch eventually says it failed to send. It is a cellular watch & I upgraded from a cellular S3. Cellular does work. Anyone else have this problem?
 
  • Like
Reactions: smile1fish

jjk454ss

macrumors 601
Jul 10, 2008
4,342
447
Some show on mine, others don’t. Sometimes I am alerted on my watch, other times now. Same issue with texts on my iPad. Very poor experience with updgrading this year
 

dohspc

macrumors 6502
Jun 7, 2008
300
122
Plano, TX
I just upgraded from the X to Xs Max only getting SMS green messages on my phone but not on ipads or apple watch. imessage blue messages appear to be working though and synced across all devices. After testing I can send an sms message from both the apple watch and ipad and I get them on a test android device and the sent sms shows up on the iPhone. The strange thing is that eventually I will get a not delivered red error in the messages app on both the iPad and Watch even though they went though. When texting back from the android phone the reply only goes to the iPhone. After my health data finishes syncing I will try some troubleshooting to try and fix it but as far as I can tell my settings are good.
 

dohspc

macrumors 6502
Jun 7, 2008
300
122
Plano, TX
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages


Extra steps if needed.
6. Press Text Message Forwarding just below this (may take a few seconds to appear after turning iMessages on)

7. Slide button on for one or all preferred devices.

8. Device should be connected, shown by a green slide bar. If not power down the relevant device (not the iPhone) and repeat steps.
 

smile1fish

macrumors member
Sep 23, 2017
54
25
I’m having a problem with SMS messages on the new S4 watch. Texts sent to me will show on the watch as a notification. However, the text itself does not show in Messages on the watch. I can send an SMS message from the watch & it will show on the phone & the person gets it, but the watch eventually says it failed to send. It is a cellular watch & I upgraded from a cellular S3. Cellular does work. Anyone else have this problem?
Exact same thing happening to me.
 

Wolff Petersen

macrumors newbie
Sep 24, 2018
2
0
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages


Extra steps if needed.
6. Press Text Message Forwarding just below this (may take a few seconds to appear after turning iMessages on)

7. Slide button on for one or all preferred devices.

8. Device should be connected, shown by a green slide bar. If not power down the relevant device (not the iPhone) and repeat steps.

I do not have the Text Message forwarding option in my menu! I too updated my X to the XS. Same issue, unresolved with apple-care today. I'm on ATT, not sure if that matters.
 

smile1fish

macrumors member
Sep 23, 2017
54
25
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages


Extra steps if needed.
6. Press Text Message Forwarding just below this (may take a few seconds to appear after turning iMessages on)

7. Slide button on for one or all preferred devices.

8. Device should be connected, shown by a green slide bar. If not power down the relevant device (not the iPhone) and repeat steps.
This worked for me, I didn’t need the extra steps. Thank you!
 

Wolff Petersen

macrumors newbie
Sep 24, 2018
2
0
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages
DUDE! After proper testing mine is fixed too now! Thanks you... you are the man!!!
[doublepost=1537837318][/doublepost]So I closed iMessage on my macbook pro, and the strangest thing is going on. SMS's seem to be working still and my iPad, iPhone and Mac are synching, but I'm getting that green line in the SMS text again. WTF is going on! I do belive this is an apple software bug.
 

jjk454ss

macrumors 601
Jul 10, 2008
4,342
447
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages


Extra steps if needed.
6. Press Text Message Forwarding just below this (may take a few seconds to appear after turning iMessages on)

7. Slide button on for one or all preferred devices.

8. Device should be connected, shown by a green slide bar. If not power down the relevant device (not the iPhone) and repeat steps.
Thanks

Tried this, now I just need a text message;)
 

Tabby

macrumors newbie
Jul 27, 2010
21
2
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages


Extra steps if needed.
6. Press Text Message Forwarding just below this (may take a few seconds to appear after turning iMessages on)

7. Slide button on for one or all preferred devices.

8. Device should be connected, shown by a green slide bar. If not power down the relevant device (not the iPhone) and repeat steps.
OMG Thank You! Apple should hire you! I just noticed that I was experiencing the same issue with my S4 watch. Your fix worked! I had the exact same problem when I got my S2 watch, and no one could fix it. It was so frustrating. I spent hours on the phone with Apple and took it in to the Genius Bar. They eventually told me to return it because they didn’t know how to fix it. My second S2 didn’t have the same issue.
 

allanj37

macrumors newbie
Oct 5, 2007
8
0
This process fixed mine.

1. Power off all devices and then restart

2. Using iPhone, turn OFF iMessage in Settings/Messages (this is an important step)

3. Go to Settings/General/Reset & then press Reset Network Settings. (this will unfortunately also clear the passwords for any WiFi connections) s

4. Reinput passwords for WiFi connections in Settings/WiFi

5. Turn iMessage ON in Settings/Messages


Extra steps if needed.
6. Press Text Message Forwarding just below this (may take a few seconds to appear after turning iMessages on)

7. Slide button on for one or all preferred devices.

8. Device should be connected, shown by a green slide bar. If not power down the relevant device (not the iPhone) and repeat steps.
This did not fix mine :(
 

eagleglen

macrumors 65816
Oct 2, 2009
1,104
293
Phoenix, AZ
I had this problem and the fix above seemed to work. I stopped getting the Not Delivered warnings on my watch. But I have a similar issue where SMS messages were not being sent if your phone was off (and also not connected, obviously). Has this made a difference with anyone? The distinction IRL would be if you left your phone at home where it’s been left on verses if you’re out and your phone dies on you. If my phone is off, my sms messages from my watch are not being sent. But as soon as I turn my phone back on, they do get sent. I’m with AT&T is that’s relavent.
 

Brookzy

macrumors 601
May 30, 2010
4,780
4,819
UK
I had this problem and the fix above seemed to work. I stopped getting the Not Delivered warnings on my watch. But I have a similar issue where SMS messages were not being sent if your phone was off (and also not connected, obviously). Has this made a difference with anyone? The distinction IRL would be if you left your phone at home where it’s been left on verses if you’re out and your phone dies on you. If my phone is off, my sms messages from my watch are not being sent. But as soon as I turn my phone back on, they do get sent. I’m with AT&T is that’s relavent.
Don’t worry it’s not a bug, that’s just how it is unfortunately:
Not all notifications will appear when your phone is off, especially if the app doesn't have a native Apple Watch app. In this case it is simply because WhatsApp is not running when your phone is off.

The same applies to SMS text messages: you can't send or receive SMS messages from your watch unless your phone is connected to your carrier's network, either by cellular or Wi-Fi. (It could be miles away, sure... so you could leave your phone on and at home and you would still get all your notifications and send and receive SMS messages... but the phone has to be on.)

Apple says this in the small print:

To receive SMS, MMS, or push notifications from third-party apps on your Apple Watch with cellular, your paired iPhone must be powered on and connected to Wi-Fi or cellular.
If you want to test this, you can turn Bluetooth off on your phone, thus simulating your watch and phone being connected to the carrier network but not connected to each other by Bluetooth.
 

eagleglen

macrumors 65816
Oct 2, 2009
1,104
293
Phoenix, AZ
Don’t worry it’s not a bug, that’s just how it is unfortunately:
THANK YOU! I’ve spent a couple hours on the phone with Apple Support and reset my watch as new to try and solve this problem, all obviously to no avail. It’s disappointing they didn’t know this.
 

Brookzy

macrumors 601
May 30, 2010
4,780
4,819
UK
Yea, but shouldn't it work if you have the LTE version of the watch? AT&T adds its own number to it..
Even the LTE version can’t receive SMS when the phone is off. It’s explained in the full post including link.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.