SMS notifications broken?

Discussion in 'iOS 10' started by f00f, Sep 14, 2016.

  1. f00f, Sep 14, 2016
    Last edited: Sep 14, 2016

    f00f macrumors 65816

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #1
    iPhone 6S Plus, AT&T. iOS 10 installed in DFU mode and set up as new, no backup restored.

    With the phone's screen locked and off (sleeping), if an SMS is received by the device it does not trigger an audible notification sound nor light up the lock screen to show the notification. If the screen is woken up (via raise-to-wake, sleep button, etc), the notification is indeed present on the lock screen -- simply there was no sound triggered nor waking of the screen when the message was received. If the screen is awake but locked, the notification will be seen on the lock screen as it arrives, but still not heard. If the screen is awake and unlocked, the notification will behave as expected (notification sound and banner in this case).

    iMessage notifications, on the other hand, behave normally in all cases. The problem is only with SMS.

    Furthermore, if my Apple Watch is on, it also does not display a notification or emit a sound when the SMS is received. However the message is present in the Watch Messages app with an unread flag (as expected).

    No SMS forwarding from the iPhone is set up. No AT&T Wifi is enabled. I've searched high and low for a setting that could be silencing SMS. Another bug perhaps?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Does this happen with SMS messages from different people?
     
  3. f00f, Sep 14, 2016
    Last edited: Sep 15, 2016

    f00f thread starter macrumors 65816

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #3
    (edited again)

    Update: feature or bug, not sure, however it appears that SMS messages from "unknown" senders (those senders without entries in Contacts.app) are the perpetrators. SMS messages from known senders will generate notifications (visual and audible) as expected. If this is true then this is unfortunate in some legitimate unknown-sender use cases -- such as messages sent through an SMS gateway or any other such legitimate messages from a non-descript senders.

    Update2: Nope, that's wrong. Doesn't matter if the sender is unknown or not. Granted I have not seen or heard a notification (while phone is sleeping) from an unknown sender, notifications from known senders are wildly inconsistent at best.

    This is nothing to do with the "Filter Unknown Senders" option in Messages which has to do with iMessage solely.
     
  4. sheareb macrumors regular

    Joined:
    Dec 27, 2009
    #4
    I have this issue i think too.... I noticed that wasn't getting notifications for text messages bt thought i was imagining it -- also sure some iMessages aren't notifying when the phone is locked. Checked all settings and can't see what the issue is.
     
  5. travbz24 macrumors newbie

    Joined:
    Mar 15, 2012
    #5
    Exact same issues happening for all types SMS or iMessage.

    Haven't seen any solutions yet.
     
  6. f00f thread starter macrumors 65816

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #6
    I did some more work on this issue and may have stumbled on the root-cause of SMS messages not eliciting an audible tone and screen wake-up on my iPhone.

    It seems that in the case of multiple iOS 10 devices (and perhaps macOS Sierra which I have not beta-tested) on a particular singular iCloud account (I have one iPad Air 2 and one iPhone 6S Plus on iOS 10) that incoming notifications will tend to go to the most-recently used ("MRU") and/or active device first. You may indeed see the notification on every device in such a way that only the MRU/active device receive the sound & wake-up while other devices may quietly receive the notification. Kind of how Watch and iPhone work together. (Note: in this context "most-recently used device" means the last device that some stuff was done on before putting it to sleep.)

    In my scenario I did not have SMS forwarding turned on on my iPhone. This is important to note. When sending test SMS messages to myself I was sending them via email to the AT&T SMS gateway using Mail.app on the iPad, and then subsequently waiting for an expected notification sound and screen wake-up on my iPhone. By virtue of sending the mail from the iPad it was always the active device -- and I suspect that the Apple cloud *wanted* to deliver the notification there first but couldn't because SMS forwarding was off. This very well may be a bug; if SMS forwarding is off then, minimally, the iPhone should absolutely reflect the notification always. Instead the iPhone, not being the MRU/active device, quietly gets the notification.

    I also sent myself SMS via Google Hangouts from the iPad. Same behavior.

    I tried a couple of tests from my iPhone itself where I would send an email to the SMS gateway and then quickly hit the sleep button on the phone. The notification would always be received (sound and wake-up). Likewise with SMS sent from Hangouts.

    I then fiddled around on my phone for a bit, to "mark" it as the MRU device before sleeping it, and sent some emails from my wife's iPad to my SMS gateway address. Again, then notifications (sound and wake-up) came to the phone. Next logical step was to play around on my iPad a bit to mark it at the MRU device and send another test from my wife's iPad. Can you guess? Yep -- quiet notification received on the iPhone.

    Granted, these were all pure SMS tests. I did not fiddle around so much with iMessage or any other notifications.

    The logical solution here is to enable SMS forwarding unconditionally. Once this was done the notifications would show up on both iPad and iPhone. In my small sample of tests, sometimes both devices get the notification sound and screen wakeup and in all cases the MRU/active device gets it first. Except for the last test I just did which sent the notification to my iPad when I expected it to go to my iPhone... and it also went to my Series 2 Watch which is not even on my wrist. :/

    Guess we have some iOS 10 kinks to iron out, eh?
     
  7. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #7
    There are certainly a few (and more like more than a few) of those. Not that unusual for a x.0 release in a sense, so hopefully they'll get on most if not all of these in upcoming updates (that will hopefully be out sooner rather than later).
     
  8. travbz24 macrumors newbie

    Joined:
    Mar 15, 2012
    #8
    possible workaround for me. Switch the addresses to receive to only 1. The phone number for the phone.
     

Share This Page