SMS problem- "message send failure"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sportsfreak, Jun 30, 2009.

  1. sportsfreak macrumors member

    Joined:
    Nov 22, 2008
    #1
    I have recently encountered this problem. Quite a few times, when i want to send a text message, it will not go through and a red exclamation mark is shown beside the message. When i go to my message inbox, it states "message send failure".

    I have only encountered this problem after upgrading to the OS 3.0, before then i never had this problem. I called rogers and everything seems normal with my account. This problem persists with a multitude of numbers- so it is not a problem on the other end.

    I find the only way to rid of this problem is to delete my message entirly and create a new one.

    Does anyone have any insight to this problem.

    Also the phone is not jail broken and it the a 16 GB iphone 3G

    this problem only occurs with sms not mms messages- i have not tried mms messaging at the current moment
     
  2. iGuardian macrumors 6502a

    iGuardian

    Joined:
    Aug 26, 2008
    #2
    What phone modle? And are you sending MMS texts? Is it jailbroken?
     
  3. sportsfreak thread starter macrumors member

    Joined:
    Nov 22, 2008
    #3
    any sugesstions as to how to fix the problem. i have even restored my phone but the problem still persists.
     
  4. justsl2 macrumors newbie

    Joined:
    Jul 1, 2009
    #4
    Me Too!!

    I've been running into the same issue ever since I upgraded to iPhone 3.0 on my 3G 8GB iphone.

    I have tried restoring it without the backup and the issue still persists.

    I was able to delete the entire conversation like the OP posted and then I was able to send txt messages to that person up until they replied. After that point I can no longer send messages to that person until I delete the conversation again.

    I have tried MMS and it does work, but every time I go to reply to a regular text message I end up with the same "Message Send Failure".

    The one other thing I can add to this is that I can consistently send messages to my wife who is on a joint account, but otherwise I run into the above issue.
     
  5. sportsfreak thread starter macrumors member

    Joined:
    Nov 22, 2008
    #5
    yes the only way around the problem- is deleting the entire message and send a new one.
     
  6. sportsfreak thread starter macrumors member

    Joined:
    Nov 22, 2008
    #6
    the problem still persists and is getting worse. now everytime i get a reply from the number i am unable to send anther message. the only way to get around it is to delte the current convo and beign a new one.
     
  7. jgmarcel macrumors newbie

    Joined:
    Jul 24, 2009
    #7
    I've been facing exactly the same issue since the 3.0 update. Just for the sake of log collection, my device is an iPhone 3G (never jailbroken) sold by an officially supported carrier (Vivo - Brazil).
     
  8. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #8
    It sounds as if the phone is somehow corrupting the outgoing phone number when it receives an incoming message.

    Does this happen only with people who are already in your contacts, or also with people who are not?

    I notice Rogers mentioned, and I notice Vivo Brazil mentioned. Is the problem perhaps to do with the international programming of the phone, or the formatting of international numbers? Just thinking aloud.....
     
  9. smorgasbord macrumors newbie

    Joined:
    Jul 10, 2006
    #9
    I'm having the same problem too, with Rogers in Canada. I've only been able to solve this problem by clearing all the messages in the current conversation. Sometimes resetting the phone helps too. Hopefully they fix this soon...
     
  10. unoriginal macrumors newbie

    Joined:
    Aug 3, 2009
    #10
    Same problem here and its quite annoying. Indeed clearing the message log helps.

    Its only with 1 contact, the one I message the most often.. go figure :rolleyes:
     
  11. sportsfreak thread starter macrumors member

    Joined:
    Nov 22, 2008
    #11
    Yes i have the same problem as many of you above- i really hope that the 3.1 software update will fix this problem. And whats most annyoing is that this problem occurs with the one person i message the most just as the poster above me stated.
     
  12. djwazzy macrumors newbie

    Joined:
    Nov 11, 2004
    #12
    I've got the same problem. I'm on Fido, 16GB white 3G iphone on 3.0.1. I can't send text messages to this one contact (but can receive them) and can also receive and send to everyone else. The work around is to clear the entire conversation thread and send the message, that works.

    Has anyone been able to resolve this issue?
     
  13. MacFAQ macrumors newbie

    Joined:
    Oct 28, 2010
  14. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #14
    That was over a year and a half ago. 3.1.3 probably fixed it.
     
  15. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #15
    nope even on 4.0 i was experiencing this problem, I called rogers about it too, I was not able to send MMS or regular texts from time to time.

    what they did was have me turn my phone off while they made their networks forget me and then add me back to their network. It seemed to have worked at the time, but I think at a later date I was still experiencing the same problem.
     
  16. Quackmbush macrumors newbie

    Quackmbush

    Joined:
    May 3, 2017
    #16
    And here we are with iOS 10.3 and still getting the message send failure sometimes 6 times in a row when trying to send a text... some things never change!
     
  17. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #17
    Or could be entirely something different as to what's behind it compared to what might have been causing it for someone else (some time ago).
     

Share This Page