SMS relay not working in 8.1

Discussion in 'iOS 8' started by Scotth48, Oct 20, 2014.

  1. Scotth48 macrumors member

    Joined:
    Sep 17, 2014
    Location:
    East tn
    #1
    After updating to 8.1 my sms still doesn't work to other phones is there something I need to do first to get this to work.
     
  2. TahoeDust macrumors 6502

    Joined:
    Jul 2, 2010
    #2
    Do you have Yosemite installed?
     
  3. mactumors macrumors 6502

    Joined:
    Aug 3, 2008
    #3
    I opened messages on my Mac and it asked if I wanted to turn on SMS relay. Then a dialog box popped up on my iPhone and I had to enter a code from my Mac.

    So there is a set-up process. It doesn't work immediately.
     
  4. stickyfingers85 macrumors regular

    Joined:
    Aug 31, 2010
    #4
    I can't seem to get SMS relay working either

    Have ios 8.1 and Yosemite

    Is there a setting I have to turn on in the iphone or the mac?
     
  5. Scotth48 thread starter macrumors member

    Joined:
    Sep 17, 2014
    Location:
    East tn
    #5
    I have an iPad air and iPhone 5 it worked for a second now it doesn't work I tried turning off iMessage but it don't work
     
  6. mactumors macrumors 6502

    Joined:
    Aug 3, 2008
    #6
    On your iOS device there is now a Settings > Messages > Text Message Forwarding section.
     
  7. AllergyDoc macrumors 65816

    AllergyDoc

    Joined:
    Mar 17, 2013
    Location:
    Utah, USA
    #7
    All devices signed into same iCloud account.
    On iPhone, Settings, Messages, Text Message Forwarding will show what devices are available to forward to. If you don't see your device in there, check the settings on the device. Some people have had to sign in and out of iCloud on a particular device to get it to kick in.

    Edit: Basic info here from Apple.
     
  8. stickyfingers85 macrumors regular

    Joined:
    Aug 31, 2010
    #8
    Thanks for this, but when i turn it on it says enter the code shown on your iMac, but nothing comes up on the iMac.

    Tried closing and opening messages again, but no joy
     
  9. Oli20 macrumors member

    Joined:
    Oct 6, 2014
    Location:
    Mitten
    #9
    Does this only appear after setting up a relay? My phone doesn't have this option but I haven't gotten home yet to update my ipad and have it close to the phone.
     
  10. Scotth48 thread starter macrumors member

    Joined:
    Sep 17, 2014
    Location:
    East tn
    #10
    I see Rex message forwarding on phone it wants a code I don't see it on my iPad air how do I get the code
     
  11. TheAppleGeek macrumors 6502a

    TheAppleGeek

    Joined:
    Apr 18, 2010
    Location:
    St. Louis
    #11
    Thanks!
     
  12. Scotth48 thread starter macrumors member

    Joined:
    Sep 17, 2014
    Location:
    East tn
    #12
    Ok got it working but cannot send voice or videos to any other numbers but iPhones i thought you would be able to do this with any number? I can receive texts but the other features don't work unless they have an iphone
     
  13. stickyfingers85 macrumors regular

    Joined:
    Aug 31, 2010
    #13
    I'm still not getting a code appear on my Mac to enter in the iPhone

    Frustrating
     
  14. garettap macrumors newbie

    Joined:
    Jun 2, 2014
    #14
    Same! :(
     
  15. stickyfingers85 macrumors regular

    Joined:
    Aug 31, 2010
    #15
    Just noticed that if i try to make a call using my imac through the iphone it says that both devices need to be using the same icloud and facetime account.

    They are though

    Suspect something is wrong...
     
  16. b1gted, Oct 20, 2014
    Last edited: Oct 20, 2014

    b1gted macrumors regular

    b1gted

    Joined:
    Sep 27, 2007
    Location:
    Bartlesville, OK
    #17
    yeah works fine, I have 3 devices, they all show up turned off in messages option under settings. Turning them on, each device displays a code that I have to then enter on my phone. It then works great.
     
  17. kage207 macrumors 6502a

    Joined:
    Jul 23, 2008
    #18
    Gotta make sure both devices have an iCloud tied to the Messages (in Settings).
     
  18. Scotth48 thread starter macrumors member

    Joined:
    Sep 17, 2014
    Location:
    East tn
    #19
    I have it working but the feature to send a voice message or a short video clip only works from iPhone to iPhone it don't work with any other phones.that kinda sucks
     
  19. stickyfingers85 macrumors regular

    Joined:
    Aug 31, 2010
    #20
    Finally working for me, but had to turn off and on imessages on my iphone.

    THen when i opened messages on the Mac, it asked if i wanted to enable SMS relay

    It wasn't a smooth process
     
  20. itsmemuffins macrumors 68030

    itsmemuffins

    Joined:
    Jun 23, 2010
    #21
    You need to have your Apple ID email address ticked in iMessage as well as your phone number.
     
  21. apollo1444 macrumors 65816

    Joined:
    Jul 22, 2011
    Location:
    mexico
    #22
    not working and really don't want to turn on and off iMessage just for this
     
  22. dugbug macrumors 65816

    dugbug

    Joined:
    Aug 23, 2008
    Location:
    Somewhere in Florida
    #23
    this is it. I only used my phone #. both FaceTime (phone relays) and SMS relay require you also use your email address.
     
  23. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #24
    For me I just had to be consistent. On the one machine where I had not ticked my phone number, I could not get the authorization message until I check the box for my phone number.

    A.
     
  24. APlotdevice macrumors 68040

    APlotdevice

    Joined:
    Sep 3, 2011
    #25
    I don't see that option anywhere.
     

Share This Page