SMS Relay not Working

fenderbass146

macrumors 65816
Original poster
Mar 11, 2009
1,090
468
Northwest Indiana
I have a iPhone 6, 2012 rMBP 15", iPad 2, and 2007 iMac. They are all on Yosemite and iOS 8.1.3

I was able to get SMS relay working on both my rMBP and my iPad. If I went into Text messaging forwarding settings on the phone, only those two devices show up by not my iMac. I know it works and I have had it working before, however I just recently restored my mac because I put a SSD in it. Now I can't get my relay working on my iMac. It's not that I am not getting the code, but the options to even turn on SMS relay isn't showing up for my iMac.

Any suggestions? I have tried turning iMessage on and off, on both the computer and the phone. I have tried logging out and logging back into iCloud. I have tried everything within reason.

It may also be worth nothing that phone calls are working on both my iPad and Macbook but not the iMac

Any suggestions?
 
Last edited:

MarcusCarpenter

macrumors 6502a
Feb 18, 2013
755
81
London
Are they connected to the same network?
How are they connected?

I had issues using a Virgin super hub 2 where my Mac was connected to the 5ghz band and my iPhone was connected to 2.4ghz. I switched them both to 5GHZ signed out of all devices and signed back in and everything was super
 

fenderbass146

macrumors 65816
Original poster
Mar 11, 2009
1,090
468
Northwest Indiana
Are they connected to the same network?
How are they connected?

I had issues using a Virgin super hub 2 where my Mac was connected to the 5ghz band and my iPhone was connected to 2.4ghz. I switched them both to 5GHZ signed out of all devices and signed back in and everything was super
Yes, all connected on same Wifi network with Airport Extreme AC. I have my 5 Ghz and 2.4 Ghz named the same....I suppose that could be the issue. I doubt the 2007 iMac has dual band N card. Maybe I will try it with a wired connection temporarily. It is right next to my router but all my ethernet outs are in use for my other connections. (They really should put more then 3 ethernet outs on Airport)
 

MarcusCarpenter

macrumors 6502a
Feb 18, 2013
755
81
London
Yes, all connected on same Wifi network with Airport Extreme AC. I have my 5 Ghz and 2.4 Ghz named the same....I suppose that could be the issue. I doubt the 2007 iMac has dual band N card. Maybe I will try it with a wired connection temporarily. It is right next to my router but all my ethernet outs are in use for my other connections. (They really should put more then 3 ethernet outs on Airport)
Give it a try, when you enable SMS relay on your iPhone make sure you have Messages open on your Mac and then you should see a code to type in to verify :)
 

mikeyb99

macrumors newbie
Jan 10, 2014
10
4
Bluetooth 4.0?

I thought that features like continuity, handoff, call/msg forwarding needed Bluetooth 4.0 support. Does your 2007 iMac have it? It sounds a bit old to have this level of Bluetooth.
 

fenderbass146

macrumors 65816
Original poster
Mar 11, 2009
1,090
468
Northwest Indiana
I thought that features like continuity, handoff, call/msg forwarding needed Bluetooth 4.0 support. Does your 2007 iMac have it? It sounds a bit old to have this level of Bluetooth.
Handoff requires 4.0, however sms and call forwarding do not (they just require yosemite and iOS 8.1) To my previous helper, putting it on ethernet did not do any good. What I noticed that was weird was when I login to iMessage on another device all my devices get a notification saying my iCloud id is being used for imesssage on my macbook or iPhone. Those notifications are not popping up on my iMac
 
Last edited:

swordfish5736

macrumors 68000
Jun 29, 2007
1,897
104
Cesspool
Handoff requires 4.0, however sms and call forwarding do not (they just require yosemite and iOS 8.1) To my previous helper, putting it on ethernet did not do any good. What I noticed that was weird was when I login to iMessage on another device all my devices get a notification saying my iCloud id is being used for imesssage on my macbook or iPhone. Those notifications are not popping up on my iMac
Are you signing in to iMessage from the messages application? In the messages application click messages in the menu bar and then click preferences
 

perkedel

macrumors 6502a
Dec 30, 2014
534
202
California
What I noticed that was weird was when I login to iMessage on another device all my devices get a notification saying my iCloud id is being used for imesssage on my macbook or iPhone. Those notifications are not popping up on my iMac
If I remember, I had an issue like this. It turned out I enabled full firewall blocking on my MBA, once I unchecked block all incoming connection, it started to work with the pop up notification.
 

fenderbass146

macrumors 65816
Original poster
Mar 11, 2009
1,090
468
Northwest Indiana
If I remember, I had an issue like this. It turned out I enabled full firewall blocking on my MBA, once I unchecked block all incoming connection, it started to work with the pop up notification.
I never turned on my firewall :( It is a clean install and I also tried deleting my profile and re-adding it. Same thing happens. I did get the popup when i logged into my iMessage on my mac after recreating my profile that mentioned sms relay. I selected yes and never had a popup on my phone and still no option on my iPhone .
 

fenderbass146

macrumors 65816
Original poster
Mar 11, 2009
1,090
468
Northwest Indiana
I never turned on my firewall :( It is a clean install and I also tried deleting my profile and re-adding it. Same thing happens. I did get the popup when i logged into my iMessage on my mac after recreating my profile that mentioned sms relay. I selected yes and never had a popup on my phone and still no option on my iPhone .
So much for it just works...I am getting extremely frustrated.
 

perkedel

macrumors 6502a
Dec 30, 2014
534
202
California
If I went into Text messaging forwarding settings on the phone, only those two devices show up by not my iMac.
open the iMessage app, check preferences to see if you're signed in there.
On one of my MBP, when setting it up I did not choose OK to the use iCloud prompt. This has the consequence of not adding my iCloud account to the facetime/imessage app, and it could be why you are not seeing it.
If it's there, sign out and sign back in.