SMS relay / Sending from Mac stopped working (maybe with 10.12.04)

Discussion in 'macOS Sierra (10.12)' started by d4gli, Apr 5, 2017.

  1. d4gli macrumors regular

    d4gli

    Joined:
    Jun 15, 2016
    Location:
    Zurich, Switzerland
    #1
    Hi everyone,

    setup:
    - MacBook Late 08 @10.12.04 (private usage)
    - MacBook Pro Late 2012 @10.12.04 (for business)
    - iPhone SE @10.3.1 (Phonenumber 01 for private uage)
    - iPhone 4S @9.3.5 (Phonenumber 02 for business)
    - iPad Mini @9.3.5

    So everything went smooth till some day, maybe it happened with 10.12.04 updates, I'm not using SMS relay that often - much more imessage. My iPhone SE for private usage has sms relay enabled to all Macs und iPad, my old boy (iPhone 4S) is only enabled for sms relay to my business book (I don't want to have any alerts on my pager duty on my private one).

    Yesterday I saw that incoming messages have been displayed on my macs, but the caller IDs have been red layered (instead of green for SMS) and I've been unable to reply via both Macs. Unfortunately everything was smooth on my iPad. So I disabled one of my Macs and tried to reenable SMS relay to that deactivated one - no code has been pushed to my mac. Rebooted all devices, opened "messages" app on Mac...

    On my private book, which is still enabled for sms relay it still shows up my messages, but even there I'm unable to reply. On my synced iPad everything is works still smooth. Any idea except of removing and reconfiguring imessage on all devices? I only saw something like this, when numbers didn't match, or relaying has been (automaticly) deactivated, when a device has been powered of for a longer time. Even that there's no code for activation pushed - even after rebooting, is new to me.

    Any one else maybe fallen to this?

    Thanks
     
  2. f00f macrumors 65816

    f00f

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #2
    Short answer is yes. I had to disable SMS Forwarding to the Mac then re-enable it. The Mac never received the activation code (feature or bug? Not sure), but SMS Forwarding did work after this.


    Longer story:
    I think the 10.12.4 update is junk with a good assortment of bugs. I applied the 10.12.4 combo update to my 2012 iMac and MacBook Air. (The subject system of the "short answer" above is the iMac.) After applying the update on my Air first, I noticed that the iCloud preferences pane in System Preferences was very slow to load. It takes almost a minute for that pane to render before it is usable. This is unlike on 10.12.3, where that preferences pane takes only a handful of seconds to load and be usable. So I chose to log out of my iCloud account on the Air and I never did log back into the iCloud account there. I also logged out of iMessages, FaceTime, iTunes, and the App Store.

    I moved on to the iMac and tried the same scenario. Upgraded with the combo updater and again that iCloud preferences pane was slow. I logged out of iCloud, iMessage, FaceTime, App Store and iTunes also then proceeded to log back in. I noted that when logging back into iCloud it also logged me into FaceTime did not log me back into iMessage. This I had to do manually. I then checked my iPhone to see if SMS Forwarding was already enabled for this iMac and strangely it was, so I tested it by sending an SMS from my Google Voice number to my iPhone. The SMS was received on the iMac however the sender's phone number was "red" colored when I hovered the mouse over it, instead of green, meaning I would not be able to reply. It seems my iPhone, and Apple, believed the SMS forwarding to be there, but the iMac's iMessage app was not "aware" that this forwarding was enabled. The only logical next step was to disable SMS Forwarding to the iMac on the iPhone then re-enable it. I did this and like you there was no activate code sent from the iMessage app on the iMac to the iPhone. Despite the absence of the activation code, the forwarding works: I receive SMS on the iMac, with the sender's number being "green" and can reply with no problem.

    And oh... the iCloud preference pane remains slow to render. You can see it if System Preferences is closed already and then you open it and click iCloud.... it will take a short bit for the pane and then much longer before the pane is usable (before things can be clicked, scrolled, etc).
     
  3. dsusanj macrumors newbie

    Joined:
    Oct 29, 2008
    #3
    Same issue here; unable to reply to text messages from my Mac mini (2014) and MBP (2016). Turning Text Message Forwarding on the iPhone 6S Plus off and on again does not help. Logging out of iCloud and logging back in on Macs does not help either. Messages app on both Macs still highlights all sender names in red, and tries to respond via iMessage to any of them, which of course fails. (Text input field is labelled as 'iMessage' instead of 'Text Message' for all messages.)
     
  4. f00f macrumors 65816

    f00f

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #4
    Are we all on the same releases?

    My Macs are on macOS 10.12.4 via the combo update which effectively does an update from 10.12.0 to 10.12.4. This is as opposed to doing an incremental update via the App Store Software Update functionality.
    My iPhone is on iOS 10.3.1, carrier is T-Mobile.
     
  5. dsusanj macrumors newbie

    Joined:
    Oct 29, 2008
    #5
    Yes, I'm on 10.12.4 on both Macs and on 10.3.1 on the iPhone. For some reason I suspect that the newest iOS is actually the problem as the issues have started only a few days ago.

    Moreover, I can't send any messages from the iPad as well (10.3.1 too). Messages are being forwarded from the iPhone to the iPad and both Macs, but none of the devices can send any text messages via the connected iPhone. Only iMessages work.
     
  6. f00f macrumors 65816

    f00f

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #6

    Bizarre for sure. I really wonder what the difference is. At the moment I only have my two Macs updated to 10.12.4 (and only the iMac is logged into my iCloud account) and just my iPhone updated to 10.3.1. I'll update my iPad to 10.3.1 also, and log my Air into my iCloud account. So far, I've been sending and receiving SMS on my iMac all day with no issue.
     
  7. f00f macrumors 65816

    f00f

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #7

    I updated my iPad to 10.3.1 last night. This morning I enabled SMS Forwarding for it. Note that prior to the iOS update, and for quite some time actually, I have not had SMS Forwarding to the iPad. Upon flicking the forwarding toggle to "on", I was immediately presented with the activation code on the iPhone and the appropriate code dialog was shown on the iPad. Entered as per normal SOP and SMS forwarding worked just fine to and from the iPad.

    I hopped over to my iMac again and on the iPhone I toggled SMS forwarding off for the iMac. As expected the SMS recipients on the iMac went "red". I toggled it back on and although I was not presented with the activation code dialog on the iMac or the iPhone, the recipients again went "green". Sure enough I was able to send an SMS from the iMac without issue.

    Next I toggled off SMS forwarding for the iPad. On the iPad I tried to send an SMS and naturally, as expected, it failed. I toggled SMS forwarding for the iPad back on and was again presented with the activation code dialog on both the iPad and iPhone. Entered the code on the iPhone, tested sending an SMS from the iPad, and no issues.

    I'm going to ping @AppleSupport in Twitter. They've been pretty good helping out in the past & maybe they have some idea here. I also still need to test my MBA (which has no iCloud account on it yet), and can also try my wife's account on her newly-upgraded MBP which had 10.12.4 clean-installed -- just to have another data point.
     
  8. d4gli thread starter macrumors regular

    d4gli

    Joined:
    Jun 15, 2016
    Location:
    Zurich, Switzerland
    #8
    I got it back finally!

    It was never important, that my primary my mail address that is used for icloud needs to be activated for sending/receiving messages via imessage. After I clicked that checkbox on alle devices it worked again. So try to activate your primary icloud mailaddy for imessage and not only your cell number.
     
  9. dsusanj macrumors newbie

    Joined:
    Oct 29, 2008
    #9
    Thanks! This has helped; my iCloud address was also off since who knows when (as I have never used it for iMessage). I switched it back on on both Macs and the iPhone and the text message forwarding and sending now works normally.
     
  10. iphone joe macrumors regular

    iphone joe

    Joined:
    Feb 10, 2011
    Location:
    NY
    #10
    I don't understand what I should do. Can you please explain? Thanks for your help.
     
  11. dsusanj macrumors newbie

    Joined:
    Oct 29, 2008
    #11
    Go into Settings->Messages->Send & Receive (on your iPhone) and check if it's only your mobile number that is currently active or your iCloud address as well. Check the same on your Mac in the Messages app. Things started working for us again once we enabled the iCloud address in addition to our mobile numbers (the iCloud address was previously switched off in both cases).
    --- Post Merged, Apr 11, 2017 ---
    Additionally, after enabling the iCloud address as well, I turned text forwarding on the iPhone off and then back on again.
     
  12. iphone joe macrumors regular

    iphone joe

    Joined:
    Feb 10, 2011
    Location:
    NY
    #12
    Thanks, I'll try it when I get home. I just checked my phone and it was off, so I enabled it. Should the same settings be on my iPad also?
     
  13. dsusanj macrumors newbie

    Joined:
    Oct 29, 2008
    #13
    Well in my case I just needed to switch it on on my iPhone and one Mac; things automatically resolved for all the other connected devices (including my iPad where I made no changes, text forwarding and replying just started working normally).
     
  14. iphone joe macrumors regular

    iphone joe

    Joined:
    Feb 10, 2011
    Location:
    NY
    #14
    Thanks for your help, I hope this works, It's been driving me nuts.
     
  15. archvile macrumors 6502

    archvile

    Joined:
    Oct 27, 2007
    #15
    I was having this same problem and this fix worked for me as well... I have always had just my phone number as active in iMessage, once I enabled my email address as well, texts are able to be sent from iPad and Mac.

    Apple must have changed something on their iMessage backend that requires this to be enabled, and I would imagine most people by default never disable their Apple ID in the Send & Receive settings, which is why just a small number of users are having this problem.
     
  16. f00f macrumors 65816

    f00f

    Joined:
    Feb 18, 2009
    Location:
    New Yawk
    #16
    I fall into that group, since for a long while I was using a non-apple mobile device (ohhh the horror) and still iMessaged from Mac & iPad which obviously would only work with an email address since there was no phone number registered. So I always have my email address enabled for iMessage & FaceTime for that matter.

    I remain curious about the activation code not appearing on the Mac. For anyone else here: if you turn off Text Message Forwarding for your Mac & then turn it back on, do you get the activation code displayed on the Mac and prompted for entry on the iPhone? This occurs for my iPad but neither of my Macs.
     
  17. PBL macrumors newbie

    PBL

    Joined:
    Jan 17, 2018
    #17
     

Share This Page