SMS show up on iPhone but not new MBP

Discussion in 'Mac Apps and Mac App Store' started by Cave Man, Aug 8, 2017.

  1. Cave Man macrumors 604

    Cave Man

    #1
    So, I just got a new MacBook Pro and everything seems to be working fine except that I cannot send nor receive SMS text messages through iMessages. Works fine on my iPhone, so I'm sure the numbers are correct. I've turned iMessage on my phone off then back on hoping that it would repopulate my phone numbers in Contacts, but that didn't solve the problem. I also have a Mac Pro in my office and a Hackintosh desktop and neither of them have this problem. Any suggestions?
     
  2. tarsins macrumors 6502

    tarsins

    Joined:
    Sep 15, 2009
    Location:
    Wales
    #2
    Have you "turned on" the MacBook on your iPhone in Settings->Messages->Text Message Forwarding?
    2F825D6F-2521-46B7-8889-557EB15C3360.PNG
     
  3. Frankfurt macrumors regular

    Frankfurt

    Joined:
    Dec 4, 2016
    Location:
    USA
    #4
    "Text Message Forwarding" does not show up on my iPhone Message Setting menu? iOS 10.3.3 / iPhone 7.
    What am I missing?
     
  4. tarsins macrumors 6502

    tarsins

    Joined:
    Sep 15, 2009
    Location:
    Wales
    #5
    Strange. Same iOS version as you with a 7+. Could it be a carrier thing?
     
  5. Frankfurt macrumors regular

    Frankfurt

    Joined:
    Dec 4, 2016
    Location:
    USA
    #6
    I am on Verizon. Only the phone setting allows for designation of other devices to receive/make calls. It may very well be that text forwarding is automatically enabled with Verizon. I am not positive though as typically whoever I text with is on iMessage (or WhatsApp if Android).
     
  6. Cave Man thread starter macrumors 604

    Cave Man

    #7
    Ah ha! I did not realize that was even there. That fixed it. Thanks much.
     

Share This Page