SMTP wowes

Discussion in 'iPhone' started by WhatAmI, Apr 17, 2011.

  1. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #1
    Been running iOS since 3.0 days on a multitude of iDevices but have yet to come to terms with the email client and the SMTP 'logic'...or find a thread, which answers my Q's. I mix my usage between home WiFi (smtp.bredband.net) and 3G (smtp.euromail.se) and want to be able to send emails where ever I am w/o waiting for minutes for the email to be sent or finding it doesn't get sent unless I switch primary server in settings.

    I can't for the life of me understand wtf is up w/ this or why I don't see more complaints?
     
  2. WhatAmI thread starter macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #2
    so no one is experiencing even the least trouble with this huh?
     
  3. dffdce macrumors member

    Joined:
    Jun 30, 2010
    #3
    Why different servers for WiF and 3G? I use the same server for both and I suspect most iPhone users do too.
     
  4. jacollins macrumors 6502a

    Joined:
    Jun 19, 2010
    #4
    I send via gmail, so it hasn't been an issue for me. I assume you need to switch because you can only use one or the other depending on what network you are connected to?
     
  5. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #5
    Are you running your own smtp server on your home network or something?

    I dont get it, the point of a dns name lookup is it can get to any server no matter where you are coming from.

    I have gmail, hotmail and fastmail all set up and didnt have to do anything weird like that.
     
  6. alent1234 macrumors 603

    Joined:
    Jun 19, 2009
    #6
    most people use gmail or some other web based email. i laughed at my brother when he said he used his ISP's email service
     
  7. alent1234 macrumors 603

    Joined:
    Jun 19, 2009
    #7
    most email admins won't allow you to relay through their email server anymore or to send email through it unless you are doing it from their network

    the reason is spam. 10 years ago the easiest way to send spam was to just relay through one of a thousand servers. then blackmail lists started to pop and be used and people started to lock their servers down
     
  8. WhatAmI thread starter macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #8
    Issue is that if I'm on a certain IP-range I need to use that specific providers SMTP-server and since switching between 3G and WiFi gives me different IP-ranges managing servers becomes a pain. This was enforced in Sweden some 10 years ago to avoid spam.

    I have my own domain, hosted remote and I eventually managed to resolve it by getting access to a private SMTP-server where I'm able to log on securely to send emails. Case closed. Thank you for your input guys :)
     
  9. dffdce macrumors member

    Joined:
    Jun 30, 2010
    #9
    I know the OP's issue is solved but just a note to those who may be searching this topic in the future. Another way to avoid this type of issue is check to see if the outgoing server you're using supports SSL via port 587 (submission port). That is, under 'Outgoing Mail Server' turn on 'Use SSL' and and enter 587 for 'Server Port'. Unlike the standard port (25) 587 usually doesn't care where you're coming from as it requires authentication before mail can be submitted.
     

Share This Page