Smultron, Cyberduck, Forbidden!!

Discussion in 'Web Design and Development' started by Mary H, Jun 2, 2010.

  1. Mary H macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Canada
    #1
    Hi,

    I have been updating a website and added two new pages. On my computer they look fine. I worked on the pages using Smultron. Then I used Cyberduck to upload the pages. Any adjustments I made on old pages uploaded fine.
    The two new pages give me a
    Forbidden!
    You don't have permission to access *** on this server.

    If I do a CNTL click and press reload, it will reload to the home page. I am using an iMac with snow leopard and it did the same thing on my macbook pro as well. I use Firefox but also tried it in Safari with the same results.

    I tried reloading on IE from Web Ceo on my PC and it didn't help. I also changed the URL to go to its actual site instead of leaving the whole site with the domain name.

    The website is hogwildsunday.org and the bad links are 'friends' and 'show and shine'

    Any help greatly appreciated.

    Thanks,
    Mary
     
  2. citizenzen macrumors 65816

    Joined:
    Mar 22, 2010
    #2
    Check the file's info in Cyberduck (Right-click > info).

    It sounds like a permissions problem.

    Google permissions and see what you want to set it at.

    I just use 7-5-7 by default. (and probably don't do it right myself)
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    Have you checked the permissions of the file on the server?
     
  4. Mary H thread starter macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Canada
    #4
    How do I do that? I have never had this problem before and I have been with the same server since 1993.
     
  5. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
  6. Mary H thread starter macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Canada
    #6
    The ones we can view are
    rw-r--r-- (644)

    The ones we can't view are
    rwx------ (700)

    How do we change them?
     
  7. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #7
    Get Info, the blue icon with the "I" on it.

    Additionally, to avoid future issues go into,

    Preferences > Transfers (tab) > Permissions (sub-tab) > Lower half for Uploads:

    Code:
    Check the box for "[B]Change permissions[/B]"
    
    Radio box: "[B]to these permissions[/B]"
    
    "[B]for Files[/B]" (644)
      check [B]all[/B] the "[I]Read[/I]"
      [B]only owner[/B] gets "[I]Write[/I]"
    
    "[B]for Folders[/B]" (755)
      check [B]all[/B] the "[I]Read[/I]"
      [B]only owner[/B] for "[I]Write[/I]"
      [B]all[/B] for "[I]Execute[/I]"
     
  8. Mary H thread starter macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Canada
    #8
    I did it!
    In case anyone else is wondering...
    I changed the permissions on Cyberduck to be my choice and chose Read, Write, - , Read, - , - , Read, - , -

    Thanks!
     
  9. knello macrumors member

    knello

    Joined:
    Dec 2, 2004
    #9
    755 is the one you want. 757 allows anonymous users and visitors to edit the file, which would be bad.
     
  10. citizenzen macrumors 65816

    Joined:
    Mar 22, 2010
    #10
    You're absolutely right!

    I was speaking off-the-cuff (had to catch a bus) and didn't have my program open to check my settings.

    That's why I tried to steer them to Google to double-check.

    Upon returning home I see my settings are set as you indicated: 755.

    Bless you.
     
  11. citizenzen macrumors 65816

    Joined:
    Mar 22, 2010
    #11
    While we're talking permissions, perhaps the good people at MR could teach this old dog new tricks. I have out of habit assigned the permission 755 to all files and folders. But a little investigation on the web indicates that I may be taking an unnecessary step. From another forum...


    Mine (PHP) run at 644. Unless there's something bizarre about your server, 644 should be fine and 755 should be unnecessary. The extra +111 marks the file as "executable", which PHP files are not. It's for binary executables and shell scripts/Perl etc. scripts that have a "shebang" line 1 (#!/path-to-interpreter). No harm done running them at 755, but it's unnecessary.


    My sites are PHP, Javascript and HTML. So according to this and other sources it appears that 644 should be all that I need. If someone can confirm this, I would appreciate it.
     
  12. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #12
    As I noted in my post above, files should be 644 and folders get 755. PHP files do not need execute permissions on. For folders that have files to do not direct access publicly, like PHP include files, I use 700 so no one can try to access the files inside it.
     

Share This Page