Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

gusping

macrumors 65816
Original poster
Mar 12, 2012
1,383
1,353
London, UK
Anyone else having this? The settings for it are the same as other apps yet it doesn't make my watch buzz.
 

jhts

macrumors newbie
Apr 3, 2015
28
23
Do you have them set to vibrate on your phone? If not, you have to turn it on within the Snapchat app on your phone.

It's cool, but I wish you could turn off Snapchat notifications when someone is typing...
 

gusping

macrumors 65816
Original poster
Mar 12, 2012
1,383
1,353
London, UK
Do you have them set to vibrate on your phone? If not, you have to turn it on within the Snapchat app on your phone.

It's cool, but I wish you could turn off Snapchat notifications when someone is typing...

Where is this? All I see within the snapchat app settings is Notification Sounds which I have no turned on.
 

jhts

macrumors newbie
Apr 3, 2015
28
23
Notification sounds is indeed the setting, I have it turned on and they're vibrating fine on my watch. Checked your notification settings on the phone? Not in the watch app.

Not sure if you meant "now" or "not". ;)
 

gusping

macrumors 65816
Original poster
Mar 12, 2012
1,383
1,353
London, UK
Notification sounds is indeed the setting, I have it turned on and they're vibrating fine on my watch. Checked your notification settings on the phone? Not in the watch app.

Not sure if you meant "now" or "not". ;)

You sir deserve a medal because you have fixed my problems!!! Thanks!
 

Nmeyrick

macrumors member
Apr 10, 2015
43
14
Medal deserved indeed! I spent probably two hours last night trying to get any of three different third party email apps to give me haptic notification but no dice. Rebooted my watch and my phone and was about to call apple!

This should be a public service announcement - you need to have sounds switched on within notification settings on your iPhone for a third party app if you want it to give you haptics on the watch. This isn't a problem for me as I have my phone muted at all times but seems like a limitation
 

jhts

macrumors newbie
Apr 3, 2015
28
23
You sir deserve a medal because you have fixed my problems!!! Thanks!


Medal deserved indeed! I spent probably two hours last night trying to get any of three different third party email apps to give me haptic notification but no dice. Rebooted my watch and my phone and was about to call apple!

This should be a public service announcement - you need to have sounds switched on within notification settings on your iPhone for a third party app if you want it to give you haptics on the watch. This isn't a problem for me as I have my phone muted at all times but seems like a limitation

Haha! You're welcome chaps, I may or may not work for super global mega corp.

Also I was one of the lucky few to get my Watch on Friday.
 

ledzepfan1981

macrumors 6502
Mar 11, 2015
463
63
Haha! You're welcome chaps, I may or may not work for super global mega corp.

Also I was one of the lucky few to get my Watch on Friday.

Sorry can you explain in simple terms please (yes I'm simple, lol) what I need to do? I can't get any third-party apps to alert me on my Watch and thought I had a dud watch, but this seems like it could be the solution. Where do I need to go on my iPhone please?

Thank you.
 

Nmeyrick

macrumors member
Apr 10, 2015
43
14
What I did was:

1 open the main settings app on your iPhone
2 go to notifications
3 find the app you want in your watch
4 make sure notifications are enabled
5 make sure sounds are enabled

This last step seems to be the crucial one, when I switch sounds off for an app it doesn't come to my watch. Of course you also still need to go to the watch app, open notifications and ensure the app is enabled there as well

See if that works for your
 

jhts

macrumors newbie
Apr 3, 2015
28
23
Thank you for your help. However I don't think this is it. The following is a screen shot of my Runeblade settings. With these settings the app does not alert me on my watch:

https://www.dropbox.com/s/f8fo70zooj8h1ci/Runeblade.png?dl=0

One thing I have noticed is that it is on Banners as the alert type. Could this be the problem?

Thank you.

Question is, do the notifications normally vibrate on your phone, or do they just make sound, or no sound at all? The watch will mirror whatever the phone does.
 

ledzepfan1981

macrumors 6502
Mar 11, 2015
463
63
Question is, do the notifications normally vibrate on your phone, or do they just make sound, or no sound at all? The watch will mirror whatever the phone does.

I have muted the watch by the switch on the left-hand side of my iPhone. Alerts used to vibrate and show on the lock screen before I got my Watch. Now They don't vibrate on the iPhone or notify me on my Watch, but they still appear on the lock screen.
 

jhts

macrumors newbie
Apr 3, 2015
28
23
I have muted the watch by the switch on the left-hand side of my iPhone. Alerts used to vibrate and show on the lock screen before I got my Watch. Now They don't vibrate on the iPhone or notify me on my Watch, but they still appear on the lock screen.

Is there any chance you've enabled Do Not Disturb on the watch? By default, it will enable on the phone when you do so.
 

grant92801

macrumors newbie
Dec 7, 2016
1
0
Notification sounds is indeed the setting, I have it turned on and they're vibrating fine on my watch. Checked your notification settings on the phone? Not in the watch app.

Not sure if you meant "now" or "not". ;)
This did not work for me and I have tried EVERYTHING
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.