Snow Leopard 10.6.3 update is causing problems with my software RAID0 array

Discussion in 'macOS' started by jdhorner, Apr 14, 2010.

  1. jdhorner macrumors member

    jdhorner

    Joined:
    Dec 6, 2005
    Location:
    Montreal, QC, Canada
    #1
    Hi Everyone,

    I'll try to explain clearly what's happened with my mac since installing 10.6.3.

    I'm running a Mac Pro (1,1) with Dual-Core Xeon 2.66 and 6 gigs of ram. Currently, there are four physical hard drives inside the tower: Bay 1, which contains my startup volume, applications, everything from a default install, etc... Bay 2, which is my hard drive for my Windows boot camp; and Bays 3 and 4, each of which contain a 500gb drive merged into a software RAID0 array in Disk Utility, which is then shared on my local home network so we can watch movies and such in the living room.

    Everything before 10.6.3 worked amazingly well, without any problems.

    After the Software Update to 10.6.3, the system rebooted to my desktop, and I was immediately prompted to either ignore, eject, or initialize an unknown/unreadable disk. I of course ignored, and went to Disk Utility to see what was up.

    One of the two disks was listed as "missing", and so the entire array is listed as "offline". Also showing up in DU was an entry on the left listed only as "Media", and nothing else. Perplexed, I opened up System Profiler, and when I clicked on "Serial-ATA" tab it said this "There was an error while scanning for Serial-ATA devices." whereas before it simply listed all four of my internal drives.

    So I rebooted, reset PRAM, even pulled all the physical drives and reconnected them, just in case, all to no avail.

    Then it hit me that perhaps something went wrong with the update itself, so I downloaded and installed the full 10.6.3 combo updater, and upon reboot, lo and behold, my array was back, and perfectly fine! And System Profiler reported disks normally again.

    Or so I thought.

    Even though now the array is back, and everything appears to be in tact, weird things are happening. Files are no longer being shared in their entirety over the network, usually failing between 60 - 80%. Tiny files usually make it through fine (things like shared documents, and my spouse's to-do list that we both update) but anything over a hundred megs or so just chokes up and freezes, ultimately leading up to an error message and a cancel.

    At first, I thought perhaps it was a networking issue. So I tried to simply copy a large file from the local raid array to my local desktop (e.g. no networking involved) and I still get the error. I've repaired permissions (not a single error message at all, "This disk appears to be OK" in green in Disk Utility), and even scanned the array with Disk Warrior (just to see if it said there were any problems, I didn't let it make any changes), but it reported no problems anyway.

    So I don't think it's a file system corruption of any kind... I honestly think something is a bit borked with SATA drivers in 10.6.3. But it's completely weird: I can copy files of any size TO the array (anything from a few KB to a few gigs) with zero error, time and time again.

    But attempting to copy those large files BACK to my desktop, again all locally, not over the network, and they error out.

    I'm open to any and all suggestions, as currently now my own array is holding my files hostage.

    Thanks for your time and input!
     
  2. MacFanJeff macrumors regular

    Joined:
    Jan 28, 2008
    Location:
    IL, USA
    #2
    Well, this is not the exact same issue as yours but may be something like what is going on so thought I would post here.

    I have a 2008 Mac Pro, 10GB RAM and Snow Leopard on drive bay #1 and Windows 7 64 bit on bay #2.

    Everything on my system was rock solid with Leopard 10.5.8 with no problems. I decided to wait until more software was compatible with Snow Leopard to upgrade and decided to do so with 10.6.3 so I downloaded the "combo" update. The Snow Leopard install and update patch went smooth with no reported issues at all. Only two programs I had installed were removed due to them no being compatible.

    Now, I have a major issue that happens at random times. When I use Super Duper (most current version) to make a backup to my external hard drive connected via an external hard drive dock with Firewire 800, I get hard system freezes and kernal panics. When that happens all I can do is force a shut down with the power switch because this is a hard crash.

    I ran Disk Utility, like you, but it too reported everything was fine. Also, I used Tech Tools Pro and it reported the same thing, including the SMART check was OK too. However, I did find several issues when I ran "Repair Disk Permissions" but that fixed those issues.

    Currently, I am still having issues with external drive backups and I contacted Super Duper for help. The main tech guy replied and said it was not a software issue causing it because they were fully Snow Leopard compatible. What they said is it seemed like a low level I/O power issue. As my backups would start, but get frozen at around 80% finished. I tried troubleshooting but if my same dock and hard drive worked under 10.5.8 then why is it now not working?

    This seemed sort of like the issue you may have with the files stopping on your network at around 60-80% as you mentioned. I think there has to be something up with Snow Leopard and am trying to get to tier 2 Apple Care support to report this. Right now I don't have an answer except I may just go back to 10.5.8 from my last good backup.

    Hope this may help.
     

Share This Page