Snow Leopard Airport/Wifi Problem?

Discussion in 'macOS' started by NFLBlitze1, Sep 6, 2009.

  1. NFLBlitze1 macrumors newbie

    Dec 11, 2008
    i have read through a few threads and did some searching but i couldn't find the answer to this issue. I know there are threads that mention how airport drops a wifi connection and the only way to fix it is by turning airport on and off, but this is not my issue.

    Ive never had this issue in leopard, and its only happened until i upgraded to Snow Leopard, basically, Airport works, but it won't detect my network, i have removed and added locations multiple times. But airport seems to be working fine, but just won't pick up any networks, i know the network works fine because all the other wifi equipped computers in my house work fine and pick the signal fine. The only thing that seems to fix the issue is rebooting but then that only fixes it briefly. I am just curious if others are having the same issue. Right now i am hooked up through ethernet.

    Here is what im talking about

    thanks in advance <3 :apple:
  2. neuroMadness macrumors newbie

    Sep 13, 2009
    I have exactly the same problem after updating to 10.6.1 with one of our computers! Does anyone have a clue what the problem might be? :confused:
  3. Steve Mannix macrumors newbie

    Dec 4, 2007
    Same issue here... anybody have any ideas? I've deleted the contents of the SystemConfiguration folder as suggested in other threads, reset the PRAM, deleted the networks and readded them manually, etc. Can't get it to work.

    Thanks in advance....
  4. Acsom macrumors regular

    Jul 10, 2009
    Try entering your router profile and assign the IP address manually. I fixed mine by resetting my router, but the first suggestion is simpler. It takes two to make a handshake. It seems to me that SL is holding out its hand one way and is unable to move it, so you need to move the router's hand over to SL.
  5. jwflutterby macrumors regular

    Jul 9, 2008
    I had issues like this too, assigning a static IP has seemed to fix the problem... For some reason my MBA either wasn't checking if an IP was in use before attempting to use it or wasn't reserving it correctly with the router because a new device connecting to the network would attempt to use the same IP my laptop was already using (bumping me off the network). Since I set an IP manually I have not had issues and all of the other devices on our network seem happier too. At least until I put my MBA to sleep, but that's another post ;)
  6. three macrumors 65816


    Jan 22, 2008
    Washington State
    Same problem on my Mac mini. It's annoying to say the least.
  7. neuroMadness macrumors newbie

    Sep 13, 2009
    Setting a static IP adress seems to have fixed the problem. Many thanks for the advice ;)!

Share This Page