Snow Leopard and 16gb USB memory sticks not working correctly.

Discussion in 'Mac Basics and Help' started by Garrod, Sep 2, 2009.

  1. Garrod macrumors regular

    Garrod

    Joined:
    Nov 13, 2008
    Location:
    UK
    #1
    I have three 16gb USB memory sticks that don't work correctly with Snow Leopard. Disk Utility is will only format them in FAT32 format and I'm unable to successfully copy files to and from the sticks.

    They work perfectly fine under Windows in Boot Camp and also on my Windows based laptop. Sadly, I purchased them after I had installed Snow Leopard and I don't have access to another Mac with an earlier copy of Mac OS X to test them.

    Is this most likely a Snow Leopard anomaly do you think or is it just that these sticks are not OS X compatible?

    Any help would be appreciated!
     
  2. bbbarron macrumors newbie

    Joined:
    Sep 20, 2009
    #2
    16GB USB devices not working under Snow Leopard

    I wish I could offer you some. I'm experiencing exactly the same problem. I thought it was because my USB stick was old, but I also could copy/paste and format on a windows machine. I tried 3 different macs (all snow leopard) with the same results. I can read and copy from the device, but I can't unmount, or copy to the device. This USB device DID work on the previous version of Leopard.

    – Barry
     
  3. deijmaster macrumors newbie

    deijmaster

    Joined:
    Apr 19, 2006
    #3
    Samr thing here

    I have the same problem, do no what to do...
     
  4. deijmaster macrumors newbie

    deijmaster

    Joined:
    Apr 19, 2006
    #4
    Found a solution that works for me...

    If you can lose the data on the key, format the key using disk utility on your mac, then reformat the key using dos-fat32. Of course you'll be limited to 32 bit files and folders but at least you can use the key without any problems.

    My key was formatted using windows 7 and it did not like it. So once in disk utility snd now it works great.

    cheers,
     

Share This Page