Snow Leopard and Win7 file sharing?

Discussion in 'macOS' started by hehe299792458, Sep 18, 2009.

  1. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #1
    Network file sharing has always been buggy in my windows/mac mixed environment, but I managed to live with it. It worked for 85% of the time. However, since upgrading to SL, it now works less than 5%. It keeps telling me "there was an error connecting to the server. please check ip addr, etc.......". It'd work for a few minutes after each restart and then resume its habit of annoying the hell out of me. Is this a common problem with Sl and Win 7? (BTW, win7 to win7 or win7 to vista file sharing works perfectly). Any ideas? Thanks!
     
  2. RMXO macrumors 6502a

    Joined:
    Sep 1, 2009
    #2
    I run Win7 on my desktop & SL on my uMBP. I have no issues at all accessing data on my win7 PC and had to reboot the PC first time around though.
     
  3. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #3
    Same boat as OP. With Leopard, it read the Windows PC fine and vice versa. With Snow Leopard, it's on/off. The Windows PC will find it but you can't do anything (eventually it will work without changing anything). Snow Leopard just won't find the Windows PC. This is probably my biggest annoyance with Snow Leopard.
     
  4. Ariez macrumors regular

    Joined:
    Jul 20, 2007
    #4
    I never really figure this out either. Sometimes it just works, while others there just no way to connect to my Windows 7 desktop.
     
  5. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #5
    Check that you don't have any services disabled. I couldn't get Win7 to connect to the Mac and vice versa but after I reinstalled Win7 (wanted to do that anyway but setting services to default startup settings would've probably worked too) it works without a hitch.

    So far it has worked without any problems. I am using the RTM build of Win7 though.
     
  6. Slower Pace macrumors member

    Joined:
    Jun 5, 2009
    Location:
    La Grande, Oregon, USA
    #6
    Try using SMB to connect

    First, after updating to SL, I had to go to File Sharing and make sure SMB was enabled again (it wasn't so I checked the box): Preferences/Sharing/Options.

    Also, I used to turn on my PC and wait and wait till the Mac found it on its own. Now I go to the Finder window and click on GO on the top menu bar, then at the bottom "Connect to Server". A box will pop up asking for the Server IP address. It will likely be something like SMB//10.0.1.3. (You can find the PC address by typing Help on the PC and it will guide you. Ask for IP Address).

    If you can't find it just try it as above. My Mac address is 10.0.1.5. Anyway, once the PC password is entered it lists the files on the PC. Choose User, and it puts the Public folder there, ready to read/write/ and work with. Oh, and if you do not have a password on the PC (I don't), then leave it blank and that is considered the password! If you allow the Mac to save it in the keychain, that's what it is, Blank.
     

Share This Page