Snow Leopard asks for System

Discussion in 'macOS' started by jelmerjt, Aug 28, 2009.

  1. jelmerjt macrumors newbie


    Oct 28, 2008
    Zwolle, NL
    After installing Snow Leopard, it asked me where 'System' was. It wanted me to browse to find it, but I didn't know where it was, so I cancelled it. Is this a bad thing?
  2. tongteh macrumors 6502

    Aug 16, 2008
    i had the same problem.. cancelled it as well, not sure what is it..
  3. iPhone 62S macrumors 6502a

    iPhone 62S

    Aug 18, 2009
    System Events is a system app that manages... Well, system events.

    If it really was missing, the system wouldn't even boot properly, so it should be fine if SL has booted and everything seems in good working order.
  4. RemarkabLee macrumors 6502a

    Nov 14, 2007
    Clean install or upgrade? I've not seen this on a clean install...
  5. jelmerjt thread starter macrumors newbie


    Oct 28, 2008
    Zwolle, NL
  6. mysterytramp macrumors 65816


    Jul 17, 2008
    In Leopard, System Events is in the /System/Library/CoreServices/ folder. Spotlight won't find it.

    Funny, I've only seen scripts ask for user input on the location of applications. Is that what's asking for its location?

  7. jelmerjt thread starter macrumors newbie


    Oct 28, 2008
    Zwolle, NL
    Thanks. It's there. Just weird that Snow Leopard couldn't detect it. Oh well:D.
  8. jason.verly macrumors newbie

    Mar 12, 2009
    Same thing...

    Same question came up for me on an upgrade install of SL. Thx for the tip on where the app was located.
  9. nubee macrumors member

    Oct 25, 2008
    Happened to me too, but everything seems to be working fine.
  10. HappyAgain macrumors newbie

    Feb 26, 2009
    same for me

    exact same thing for me. seems to be running fine even though I hit cancel.

    Upgrade as well.
  11. krisgreen65 macrumors newbie

    Oct 7, 2008
    Same thing happened to me - thanks for the info on which directory it was in!

  12. brightlights macrumors regular

    Jan 6, 2004
    Same happened here. I cancelled, but if it comes up again I'll know where to look.
  13. gary001 macrumors member

    Feb 10, 2008
    I had two prompts on mine. When I located it on the first one, nothing seemed to be affected. The second however allowed the anti-virus scan to start. I don't know why Snow Leopard is such an idiot in locating it's own friggin files, but a little work on my end doesn't hurt me too much... wait... oowww, my heart! ;)
  14. bonzairob macrumors newbie

    Sep 1, 2009
    I think this is some applications asking for it - I have an app called Caffeine that stops the screensaver coming on, it wasn't working before I found SystemEvents (I had two dialogues so I'm guessing another app wanted it too).

    Thanks for the address anyways =D
  15. TaskerApp macrumors newbie

    Aug 24, 2009
    had caffein too

    I had that prompt come up on a SL upgrade and i also had Caffein installed. I'm guessing that is the app that is asking for it. I'm sure snow leopard itself already knows where its system events app is located.
  16. St. Germain macrumors 6502

    May 19, 2006
    I also was asked for it after upgrading to SL with a system that also has Caffeine installed. Love that little app.
  17. woodenbrain macrumors member

    Sep 2, 2009
    System Events is used by almost any applescript, or any application that uses applescript portions, on a regular basis.

    I had this problem too, and it seems that when SL is first installed it hasn't yet updated its launch services (not sure on term, but whatever the index is to installed apps), which means any login items you may use that are using any applescript portions will start asking you to locate all kinds of apps, including system events.

    Annoying but solved after next restart most likely.
  18. coachbb94 macrumors newbie

    Sep 16, 2009
    Boot of SuperDuper disk asked this question

    First, thanks for letting us know where the file is located.

    Second, I did not get this question until the first time I booted from my SuperDuper backup. Since I am rather new to using SuperDuper I immediately became worried when this message appeared. But knowing "Google is my friend" I did a search and found that this is a known issue and then finding the answer put me at ease with my SuperDuper backup disk.

    Thanks again for the files location.
  19. libstraight macrumors newbie

    Sep 22, 2009
    Caffeine, too...

    Got the System request. And, I too, use Caffeine.
  20. levifig macrumors member


    Jan 30, 2008
    Ames, IA
    Had this after a SL Upgrade (don't have Caffeine).
    Just had this again after a clean install (still no Caffeine)... :S

    Thanks for the info on file location. That might shut it up! :)
  21. durgadasji macrumors newbie

    Sep 2, 2010
    LaunchServices database is corrupt or incomplete

    The reason this happens is usually because the LaunchServicesDB has been corrupted, or was in the process of being rebuilt, but somehow didn't complete properly. I had this happen to me every time I didn't wait long enough for my LaunchServicesDB rebuild using CleanMyMac.
  22. SpiderDude macrumors regular


    Jan 29, 2008
    Portugal, Europe
    Nice, thanks

    Thanks a million man.
    I hate not having something in order on my mac
  23. garbeth macrumors regular

    Apr 13, 2010
    Just had this pop up after running all the maintenance scripts with OnyX. Thanks for the help! :)

Share This Page