Snow Leopard blocks incoming connections - firewall is off

Discussion in 'macOS' started by D A, Dec 17, 2009.

  1. D A macrumors regular

    Joined:
    Nov 21, 2008
    #1
    I got an iPod Touch today and I'm while I was testing out some apps I noticed that I cannot connect to my MacBook Pro.

    If I try to ping it I get no response. Going to the Mac's address in a browser (web sharing is on) I don't get any response either. I cannot connect to for file sharing either. I have turned off the firewall in OS X and rebooted the computer with no change. All sharing options are enabled. If I run "sudo ipfw list" I get this: "65535 allow ip from any to any".

    It appears however that Snow Leopard allows connection from outside the local network, as Internet, BitTorrent, Mail etc. works as usual.

    I've tried turning the firewall off in the router but connections are still blocked.


    Any ideas?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    What are you entering to try to connect and where?
     
  3. nata11 macrumors newbie

    Joined:
    Dec 19, 2009
    #3
    I have the same situation. Firewall is turned off. Personal web sharing is turned on. I can browse to the site locally but cannot browse from another machine on the same subnet. I can see that port 80 is being listened on all IP addresses. So I am not sure why its being blocked. I am able to ping to and fro from different machine.
     
  4. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
  5. mibmac macrumors newbie

    Joined:
    Dec 30, 2009
    #5
    I had the same problem. Firewall off and all traffic allowed through ipfw.
    I could see the incoming connection attempts (ftp, http) with tcpdump, but no connections accepted. Ping requests shown, but no response.

    I then realized that my CheckPoint VPN 1 Secure Client had a default security policy to allow nothing even when the client was not active. "Tools / Disable security policy" solved my problem. Maybe you have some software installed that acts like a blocking firewall?
     
  6. Mister9 macrumors regular

    Joined:
    Feb 11, 2008
    #6
    Bittorrent

    I'm having troubles with Bittorrent and stumbled onto this... I think its probably the same issue. I keep getting the error "Aborting, could not connect to Tracker while not Connected to any peers." I know all my port forwarding is correct, but I'm not sure what I need to do in Snow Leopard to get it working. Any ideas? Thanks :p

    [UPDATE]
    I just downloaded Transmission and it works fine! Weird, I tried Bittorrent and uTorrent with no success...
     

Share This Page