Snow Leopard cinema display and macbook pro sleep issues

Discussion in 'macOS' started by mwolverine, Aug 30, 2009.

  1. mwolverine macrumors newbie

    Joined:
    Sep 9, 2007
    #1
    I have a 2007 macbook pro connected to a 30 inch acd, installed snow leopard with no problems or so I thought. The problem I'm having is that using my macbook pro connected to my cinema display upon booting my computer will try to sleep shortly after booting, never had this problem before and it's very strange. I use a bluetooth mouse which seems to momentarily wake it but it's like it gets caught in some sleep then wake loop. The only way to make it work is to plug the magsafe in and everything works fine. Very frustrating, any help would be greatly appreciated. Oh and I did try resetting the pram.
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    So it works perfectly fine when the MagSafe is connected? If yes, sound like an issue with your battery.
     
  3. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
    #3
    I can see why you would say that but the battery holds a charge just fine and this was never an issue until I installed snow leopard.
     
  4. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    I understand it happened only when Snow Leopard was installed, but it could be a coincidence. it also does not matter how well the battery holds charge, it could have just been defective or become defective. Instead of playing around with settings and different things, go to the Apple Store and have them take a look. If you don't try a PRAM reset and a SMC reset.
     
  5. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
    #5
    One thing I left out is that with the lid open it works even if the magsafe is not plugged in. Sorry about that. Tried smc and pram reset.
     
  6. benlee macrumors 65816

    benlee

    Joined:
    Mar 4, 2007
    #6
    To be honest, I've had a similar, but different, problem. I'm connected to an external monitor in clamshell mode. When I go to manually sleep the computer, it takes close to 20 seconds, if not longer, before it goes to sleep.
     
  7. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
  8. Ron21 macrumors 6502a

    Joined:
    Sep 6, 2007
    #8
    This is normal behavior. All of my MBP's have always operated this way. With the lid closed you must have the MBP connected to a power source in order to use it in clamshell mode with an external display.

    http://support.apple.com/kb/HT3131

    I have no idea how it worked for you before..
     
  9. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
    #9
    I see what you are saying, however it has worked fine without being plugged in for over a year now until I installed snow leopard. You would think someone else must use their macbook and external monitor at the same time without it constantly being plugged in.
     
  10. Ron21 macrumors 6502a

    Joined:
    Sep 6, 2007
    #10
    I guess it was some type of glitch that allowed you to do that.

    Also, I remember someone suggesting to use an app called insomniaX that has the ability to disable sleep mode. Not sure if it works though.

    http://www.versiontracker.com/dyn/moreinfo/macosx/30315
     
  11. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
  12. Sir Timm macrumors newbie

    Sir Timm

    Joined:
    May 7, 2009
    #12
    Same problem here...


    I just experienced the same problem. That's why I came across this thread. Trying first time to start my MB (2007) in clamshell mode without magsafe after installing SL presented me with a very sleepy Mac, that showed the very same behaviour. And I have never experienced this before! (To be honest I must admit: I am not sure if I ever tried to use it in clamshell mode on battery before. But on the other side, why should I not have, since I am working with external display, mouse and keyboard almost all the time?)
     
  13. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
    #13
    Maybe I'm wrong but it just doesn't make sense to constantly have to have it plugged in all the time, and like I said for well over a year now it's worked fine without being plugged in. If you find any solution please let me know and I'll do likewise. Thanks.
     
  14. djbrad macrumors newbie

    Joined:
    Sep 4, 2009
    #14
    Same problem, 2008 macbook 45nm

    Hi,

    same problem here. Been using our macbook on external display on battery for a year and half.

    Now, the macbook go to sleep before login screen, but is ok when in ac power.

    I don't like to run on ac all the time!

    Please if someone have a fix, tell us.

    I hope for the fix in 10.6.1.

    Brad
     
  15. djbrad macrumors newbie

    Joined:
    Sep 4, 2009
    #15
  16. mwolverine thread starter macrumors newbie

    Joined:
    Sep 9, 2007
    #16
    Happy to report this fixed my problem. Thank you for recommending this.
     
  17. djbrad macrumors newbie

    Joined:
    Sep 4, 2009
    #17
    Hi,

    I installed insomniaX this weekend, it works.

    Boot in clamshell with ac, enable insomniaX, disconnect power.

    However, I hope that apple will supports it again like in leopard (or was it a bug?)

    :(

    Brad
     

Share This Page