Snow leopard corrupted my hard drive -> No backup...

Discussion in 'macOS' started by alexmbarton, Nov 10, 2009.

  1. alexmbarton macrumors newbie

    Joined:
    Nov 10, 2009
    #1
    Yesterday, I stuck the upgrade DVD in and started the upgrade. Half way through the process it rebooted. At this point a big warning sign came up saying there has been errors, please reboot (I haven't seen this again).

    The current situation is that the macbook (Black 250gb) boots for around 20 seconds (grey screen with apple and ajax style loader gif thing) before powering down.

    Attempted remedies and outcomes

    I have reinserted snow leopard and leopard to check the disc utility. It tells me quite quickly that the disk needs repairing. On clicking repair, it tells me that it requires me to backup erase/install.

    I have attached the mac to a macbook pro (the one i'm writing on) using target mode. The host (this one) cannot see the disk in finder mode but can in disk utility. The hard drive of the target is grayed out and i cannot right click for further options (such as reveal).

    I have tried starting in single user mode but i get the following message: Singleuser boot –– fsck not done.

    I have tried starting in verbose mode but i get an I/O disk error and then it turns itself off.

    I have tried to force mount the target in terminal but it says resource busy.

    I only have myself to blame as it is inexcusable not to backup prior to an upgrade. I'm just so used to mac products working perfectly. To make matters worse, the last backup was on a hard drive which i have just found out is also corrupt (and my itouch stopped working today too!). So basically I have no backup.

    To portray the gravity of the situation, the info on the computer is a 1.5 year project. that's basically over a 5th of my life that I may have to repeat!

    The problem (from reading) is that the file structure is messed up. I'm sure that my files are there, it's just I can't access them.

    My question is simple.

    How can I find and copy files from the broken macbook to this new and working macbook pro.

    Thank you so much and just to clarify, i know i should have backed up......

    Yours,

    Alex
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    Good chance that the HDD is failing. This might be a stretch but try to take the HDD out and put it into an external enclosure. Yes this is technically the same as putting the MacBook in TDM but you never know if the computer itself is to blame. By putting it into an enclosure, you're isolating the HDD from other problems and giving yourself a chance to recover data which is probably the most important thing right now.
     
  3. RaceTripper macrumors 68030

    Joined:
    May 29, 2007
    #3
    I agree it sounds like the HD has failed, and that trying it in an external enclosure might provide some hope for salvaging data from it.
     
  4. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #4
    New HD, a 3rd party drive repair utility, and a USB case.

    If you have printed the project out, a scanner and OmniPage could come in handy.
     
  5. Eric S. macrumors 68040

    Eric S.

    Joined:
    Feb 1, 2008
    Location:
    Santa Cruz Mountains, California
    #5
    And of course there are data services that may be able to recover your data. Possibly an extreme measure but if it's 1.5 years worth of project data (really, no backups at all?), it could be worth it.
     
  6. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #6
    I recommend getting some expert help.

    Get another hard drive, and make a clone of the original. NOT using any Mac-tard software that needs a working HFS filesystem. Use primitive tools; dd and stuff like that. Set the original aside, and then get to work trying to rescue the copy. The original may not be failing; it may simply be some bad corruption on the filesystem. Something will likely be able to recover it.

    I had something like this happen to me (glitchy firewire cable) and had to use disable_journal.c to force off journaling, so that I could get the drive mountable, so I could copy off what I needed before reformatting.

    I haven't used Disk Warrior, but I see people say all the time that it managed to fix nasty corruption that OS X built-in tools couldn't.
     
  7. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #7
    Possibly a good idea

    This sounds like a good idea i'll look into dd..

    The fault that it originally reported was invalid node structure. I feel that it is not the hard drive that is failing.. Can software create a hardware fault?

    I'm not sure what disable_journal.c means. Can i do this through single user mode? I have a command prompt.

    I am looking in to this.

    Thanks for you comments, it is really appreciated!

    Alex
     
  8. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #8
    I had a hard drive with all the data backed up but it is corrupt! Oh joy.. I'm now looking into data recovery services. Was kinda hoping to sort this out myself (No $$$)...

    Thanks for the advice, really appreciate it!

    Alex
     
  9. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #9
    If i had all these items, what would you recommend to be the next step?

    Many thanks, I appreciate it!

    Alex
     
  10. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #10
    Thanks

    I would just like to say thanks to everyone who has contributed so far!

    Really appreciative.

    Alex
     
  11. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
    #11
    Try ressetting the PRAM, and the other Mac favorites (there's a sticky thread on how to do it in MBP or OS X forum section). I know it sounds weird, but I got my MBP saying it had unrecoverable issues, and that Disk Utility couldn't repair it, that the Target mode couldn't see it etc....

    Did the above a few times, and then boom, worked. Worth trying!
     
  12. simplydru macrumors newbie

    Joined:
    Nov 27, 2005
    #12
    I've been a lurker for a long time on this site, and the resources have helped me over and over again. It's time I gave something back.

    I had exactly the same issue over the weekend with my mac mini. I was bricking it because my entire itunes library was on it - 30,000 songs build up over the last 20 years, ripped cd's and downloaded. Stupidly I didn't back up either.

    After lots of panicked googling I decided to restore my os disk onto a partitioned firewire drive and install the os onto another partition of that drive in the hope booting from it would enable me to access the corrupted internal hard drive. I managed to mount the internal drive and I managed to copy all the files off it and do a fresh erase and install of snow leopard on the 'corrupted disk.'

    I've run disk utility and it all looks good.

    The link that helped me is below:

    http://reviews.cnet.com/8301-13727_7-10329087-263.html

    Believe me I plan on backing everything up now.
     
  13. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #13
    I tried this a few times. It didn't seam to make any difference. It is however a favourite of the Apple Support team!

    Thanks!

    Alex
     
  14. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #14
    This sounds similar to what I have been doing (see post below)! Thanks for the link. I'm currently reading it (well in a sec when I press submit!)

    Thanks, much appreciated,

    Alex
     
  15. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #15
    Situ update

    Ok, I've managed to save some of my data....

    Alongside the geniuses at the apple store (which only opened a week ago!), I have managed to save the majority of my data (phew / jump with excitement / weep with relief).

    They booted off a hard drive and then accessed my hard drive. They then set up a firewire network from the broken computer to this one and I managed to copy some of my files.

    At the moment, it looks like I will lose all my music, photos, movies and personal documents (and a huge personalised code library).

    The reason why this is the case is that I don't have the permissions to copy the files.

    This also suggests to me that the HD is not wrecked, only the file structure.

    We also tried diskwarrier that fixed a lot of files but didn't manage to change the permissions.

    My new question is:

    How do I change the permissions of files on the corrupt disk?

    Thank you for your continued support!!

    Alex
     
  16. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #16
    You should still be able to click on a folder, get info on it and alter the permisions on the folder and inside it, by typing in the old user name and password.

    ---

    Hope you simply pulled the HD, and replaced it with a new one.

    Put the old one in the mobile drive sized USB case.

    As long as you resist the urge to format the drive, you should still be able to recover the data as soon as you get over the permissions hurdle.

    ---

    Also there is a chance that when you load the OS onto the new drive, if the long username and the short username are the same that you might be granted access to the data.

    Though not sure since Apple did the ACLs.
     
  17. JamieP34 macrumors newbie

    Joined:
    Nov 11, 2009
    #17
    Fixing permissions

    Select the corrupt disk in finder and get info on it. Under Sharing and Permissions check the "Ignore Ownership on this volume" checkbox (You may have to authenticate by clicking the lock)

    If that doesn't work, open terminal, cd /Volumes/corruptdiskname/Users/yourusername/

    hit return

    type sudo chown -R usernameOfUserYouAreLoggedInAs foldername
    or
    sudo chmod -R ugo+rwx foldername

    for each folder that contains files that you need to access. You will then be required to enter the admin password for the user that you are logged in as.

    I'd be surprised if ignoring the ownership didn't work though.

    Jamie
     
  18. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #18
    If the machine was able to boot off a USB/FW drive.

    You don't need to take the drive out.

    Grab a cheap USB drive, load the new OS onto it with the working machine.

    And when you restart from it the first time, enter all the info the same for the user in that was on the old machine.

    Chance when you boot from it on the broken machine that the same long/short username will grant you access.

    ---

    If not change the permissions as stated by the poster above.
     
  19. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #19
    I thought that this would be the case but some files the padlock is greyed out and others the padlock isn't even there at all!


    I agree...

    I'm not sure what the difference is between the long username and the short username are...

    So to clarify, if i set up the new OS with exactly the same info then the corrupt HD may be tricked into thinking the new OS is the old OS?

    Thanks,

    Alex
     
  20. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #20
    Something went haywire with the padlock... I've never seen an Ignore ownership on this volume checkbox! Is there something special I need to do to see this?

    This looks like the business! Excited with this post!

    Thanks Jamie,

    Alex
     
  21. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #21

    Off to (with perhaps a skip in my step!) PC world now to get cheap HD and USB cable (only got one firewire slot)....

    Ace,

    Thanks

    Alex
     
  22. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #22
    when you do finder/file/get info, aka in finder highlight icon and command I.

    you will see ignore ownership on volumes. Yours is likely showing as the same, so you will need to click on the padlock, enter your user name and password and ignore ownership.

    Short user name is the truncated one you see here and on your user folder inside Users, the long name is the one you type in.
     

    Attached Files:

  23. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #23
    Ah ok, I understand, I wasn't actually looking at the HD in info, I was looking at the actual files.

    I found an old hard drive with music and movies on (sweet!). So i'm copying these files to the working mac, then reformatting and installing osx 10.5.2. Once this is done i'll try the above!

    Got you! Thanks,

    As always, it's seriously appreciated.

    Alex
     
  24. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #24
    Latest Update

    Ok I've booted off the external HD and by setting up leopard using the same username and passwords it's freed up most of my data.

    There are; however, some last "pockets of resistance" hiding away.

    I have tried both chmod and chown in sudo mode but both times they claim that it's a read only file system.

    Is there a way around this?

    Thanks for bearing with me!!!

    Alex
     
  25. alexmbarton thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #25
    Final Conclusion

    Ok, here is the conclusion!

    I managed to get all my data back -> I just copied the entire user folder across to the capsule (10 hours).

    The original problem was the snow leopard disk was corrupted. I found this out when I reinstalled leopard and then tried to install snowleopard it said could not copy the support files, please restart and try again.

    Apple are now sending me a disc.

    Thanks to everyone who helped my bring this to a successful conclusion!

    You rock my world!!! :) :)


    _______

    Here are some concise search terms for people to find this post in case of similar problems...

    Snow leopard invalidated my node structures
    My computer doesn't work after failed snow leopard installation
    Snow leopard disc doesn't work and broke my computer.
     

Share This Page