Snow Leopard Disaster

Discussion in 'macOS' started by lexus, Sep 11, 2009.

  1. lexus macrumors 68000

    lexus

    Joined:
    Mar 26, 2006
    Location:
    Depends Greatly On The Weather
    #1
    My snow leopard install has been a disaster:

    My mail went haywire and i received 2500 duplicate messages.
    The mouse button keeps jamming (not physical)
    Expose freezes often.
    Safari and Firefox crash routinely.
    Address book no longer lets me dial skype.

    Why is it so bad???

    Any help would be much appreciated.

    BTW I have updated to 10.6.1.

    Thanks
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Your problems are not typical. Perhaps restoring a backup so you're back on Leopard is an option.

    Something certainly appears to be wrong, did you go the upgrade path or the clean install?
     
  3. Plegaria macrumors newbie

    Joined:
    Sep 3, 2009
    #3
    You are right, those problems are not typical, the typical problems are:

    Office programs crashing constantly, specially when I want to save something.

    Adobe CS4 crashing constantly as well, all the time.

    Firefox impossible to use.

    Many applications crashing, including Apple software like iphoto and preview.

    I installed SL directly (not clean install), it was totally chaos, I then made a clean install, erased completely my hard drive and it started working perfec for just 2 or 3 days, then the problems starting arising again. It is impossible to work on a Mac now, I am very embarassed because I am such a huge fan of Apple and I am very ashamed of how its OSX is working at the present time, I am thinking 2 or 3 times before recommending a Macbook now until its resolved. I know 2 other people that it has been the same since they installed SL. Please update quick.
     
  4. atheros07 macrumors member

    Joined:
    Mar 21, 2009
    Location:
    Cambridge, MA
    #4
    Maybe I'm the one who's atypical, but I did a clean install of SL last Friday night, it's been 6 days now and everything's been working perfectly, including Office 2008 (opening, editing, saving, printing), Adobe CS 4, iPhoto, Preview, you name it. Firefox is a bit slow but it hasn't been optimized for SL yet, and Safari hasn't crashed once on me yet.

    I really suggest that you completely wipe again and do another clean install, then install Office 08, Adobe CS4, and ILife one by one and make sure to install additional updates and service packs for all of them.
     
  5. drdrei macrumors newbie

    Joined:
    Dec 5, 2008
    #5

Share This Page