Snow Leopard: DNS broken after sleep?

Discussion in 'macOS' started by twinspop, Aug 31, 2009.

  1. twinspop macrumors newbie

    Aug 31, 2009
    Late 2008 MacBook, online via WiFi. Since upgrading to 10.6, about 50% of the time I wake the lappy, apps cannot resolve hostnames. Ping by IP and dig to resolve names works on the command line. However, no apps can get DNS. Safari and Firefox report "offline" mode.

    Anyone else see this? A reboot is the only fix I've found, and that's a pain.
  2. benthewraith macrumors 68040


    May 27, 2006
    Miami, FL
    Hmm, strange. I've had much better DNS since upgrading from Leopard to Snow Leopard.
  3. ErwinF macrumors newbie

    Sep 1, 2009
    I have a similar problem, also with a late 2008 laptop.

    From time to time, with about 5-10 minutes interval, my laptop cannot resolve hostnames anymore, and Safari reports offline mode.
    It occurs either with ethernet connection, and with WiFi connection.
    I have not been able to figure out what causes this.

    The problem occured after i upgraded to Snow Leopard, with Leopard i had no such problem......

    What works for me, but it is not a longterm solution, is to switch locations.
    I have configured 2 identical locations, and switch between them whenever this problem occurs.
    I have configured everything with DHCP set to automatic, and the settings are exactly the same as before... I checked this with a colleague.

    If anyone has a clue what the problem is, i am more than happy to hear it.... It's getting very annoying and frustrating.
  4. dropadrop macrumors member

    Sep 2, 2006
    Similar problem here on an iMac C2D.

    After updating to snow leopard my dns was broken. Trying to ping the dns servers my airport extreme receives via dhcp is ok. Trying to do a direct query to the dns servers from the command line works just fine and they seem to be resolving everything.

    Now if I want to open a webpage I need to open terminal, do a direct dig hostname @dnsserver and then paste the resulting ip address in the address field of my browser...

    Rebooting did not help
  5. Mwaltjr macrumors newbie

    Sep 1, 2009
    Possible Solution

    I came across this possible solution. It has enabled me to stay connected for over 10 minutes, which is longer than I've been able to stay online for the last several days. I'll post again if it does not last.

    Here is a common fix that has worked for some people:

    1. Open System Preferences.

    2. Select Network > Location.

    3. Clic on Edit Locations…

    4. Add a new location. You can name it anything you like.

    That’s all you have to do! It seems that this process resets the networking and makes it work again.
  6. Mwaltjr macrumors newbie

    Sep 1, 2009
    The above solution does not work.

    After about 20 minutes, I was back to the same problem. Apparently the possible fix posted above doesn't work. Sorry for the trouble.
  7. pitt1717 macrumors 6502

    Jul 13, 2007
    2 things to try when this happens.

    1, do an nslookup and see what the dns server is or if you are even getting one

    2, under sys prefs, network, your connection (advanced), DNS tab. is anything listed there
  8. alan1l macrumors newbie

    Nov 5, 2008
    Same here

    I have seen the same problem twice now on my late 2008 15" MBP using the AirPort. Both times it was sleeping for awhile (like more than an hour). When I checked the Network Diagnostics, all the lights were red (AirPort/AirPort Settings/Network Settings/ISP/Internet Server). I had full bars on the AirPort indicator and it said I was connected to my WiFi network, but I could not even connect to my router admin page.

    After reboot it fixed itself. Then I put it back to sleep for a few seconds to check again. It was able to connect. Why would it only happen after sleeping awhile?
  9. radellaf macrumors newbie

    Oct 29, 2007
    Late 2008 MacBook, similar problem. DNS is often very slow (10-30 sec) and a browser may time out. It's not absent, though, as reloading the page almost always succeeds.
  10. JohnDCCIU macrumors newbie


    Sep 5, 2009
    DNS definitely messed up in Snow Leopard

    I've seen DNS weirdness on multiple machines that I've upgraded to Snow Leopard, both at home (wireless) and at work (typical LAN environment).

    What I usually see is the ability to dig an address and have it returned correctly, but then any app (command line or GUI) can't actually use the address.

    Even doing a "curl" with the same DNS name that returned successfully from an immediately previous dig command results in the error "curl: (6) Couldn't resolve host '<hostname>'"

    I've tried dscacheutil -flushcache with no luck. The only (temporary) workaround seems to be to change some network parameter, or perhaps switch Locations, which seems to kick it back into gear for awhile.
  11. shaman macrumors newbie

    Sep 7, 2009
    DNS problem

    I have the same problem with DNS.
    I think, I have some solution.
    I hope this is temporary and Apple solve this bug in the future.

    I just configured my Airport manually.
    1. Select TCP/IP configuration page.
    2. Select 'Manually'
    3. Put some address from DHCP pool
    4. Use the same mask and router
    5. Switch to DNS page and put the same DNS address but manually(It should be black not gray).

    In my case I also should restart DSL router.

    Now it seems to work.
  12. blackant macrumors newbie

    Aug 13, 2009
    I have the same problem too.
    I am using a router, hence the default dns is
    So what I did was to manually enter my ISP's dns servers to get it work again.

    hope this helps for others.
  13. KevinC macrumors member

    Apr 21, 2008
    Chandler, AZ
    Both my rigs are working fine ('07 iMac, recent 13" MBP). Then again, I'm using OpenDNS. You guys should give it a try.. MIGHT resolve your issues, even if it doesn't, it's a better DNS mousetrap, and it's free.
  14. daswafford macrumors newbie

    Sep 15, 2009
    I'm also seeing this problem as well. I run an internal BIND DNS server that has been running rock solid for the last year and after doing the upgrade to Snow Leopard I'm constantly having to reboot my laptop to get DNS lookups to work again. I'm also seeing a problem when launching a terminal window -- it will hesitate for about 5-10 seconds before providing a shell prompt.

    When I issue NSLOOKUP I get the correct server information however it appears that there is a bug regarding the default domain suffix as it is not being appending once the flakiness starts up. For example, my DNS suffix is davidswafford.local and my primary server is named NAS. When I issue nslookup and query for "NAS" I get no results, but appending the full suffix (which the computer already knows about via DHCP) then it returns properly. After doing a reboot of only the Snow Leopard Macbook Pro, queries for just "NAS" work fine without any hesitation.

    I've verified that DNS is operating normally for all other systems on the home network, which is 2 other MACs, a handful of Cisco gear (using the same DNS server), and also a few other linux boxes.

    Hardware is a 2007 MacBook Pro, 2.2Ghz/2Gb 15" model. It's since been upgraded to 4GB and a 7200RPM hard drive.

    David Swafford.
  15. daswafford macrumors newbie

    Sep 15, 2009
    I don't think this problem has to do with upstream DNS servers, to me it feels like the OS is forgetting how to perform simple DNS queries. As the original posted mentioned, I as well, it appears to surface after waking from sleep mode.
  16. hphoto macrumors newbie

    Sep 22, 2009
    I upgraded my Macbook Pro and also experienced this same problem. Aside from sleep, applications will not resolve local domain hostnames after a few minutes after boot. Disabling and renabling DHPC in Snow Leopard would cure this problem until a few minutes later and same problem occurs.

    This thread gave me a hint:

    Seems like Snow Leopard is not respecting DNS ttl value of 0 by not querying the DNS server? I use DNSMasq (in a dd-wrt router) and that is the ttl default for local domain hostnames. Use "dig myhostname any" to confirm. I modified DNSMasq ttl to 1 second by adding this option:

    and I no longer experience this problem. I hope this information can help someone.
  17. hphoto macrumors newbie

    Sep 22, 2009
    never mind. my MBP slept overnight, and the problem is occuring again. urgh! i should have never upgraded to Snow Leopard.
  18. glenalex macrumors newbie

    Sep 22, 2009
    Dropped Airport

    I have a similar problem which Apple Tech Support have been trying to resolve all day. Only occurred since I went to Snow Leopard on my iMac.

    Kept having to turn Airport off and on to sort out to me what looked like a DNS lookup problem.

    Selecting a new network location seems to have improved the situation - now it just hangs for a few seconds and then finds its way.

    Have no problems with my macbook running exactly the same software.
  19. timbrown macrumors newbie

    Sep 24, 2009
    Welcome to the world dns misery I've been experiencing with Leopard for quite sometime. With no fix in sight following hours and hours and hours of apple support still nothing (i've resorted to putting IP addresses in my host file for my favorite sites just to get them to resolve ).

    This issue seems to be rooted in the way that since leopard os x has changed it default method for requesting DNS information. It by default uses SRV (service) records. Many older routers do "not recognize nor forward to SRV requests." Also it's possible "Your ISP’s DNS servers don’t recognize or doesn’t respond to SRV queries or respond with NXDOMAIN". If the hardware doesn't even respond to the initial SRV request Leopard (and now apparently Snow Leopard) will continue to try to send the SRV request numerous times instead of reverting back to the a traditional A (address) lookup.

    I've been thinking about going back to Tiger for some time because apple has not addressed this issue (and many people were experiencing this same exact issue on Leopard) and seemingly won't acknowledge this as an issue with the OS as they repeatedly told me it was a hardware issue (hardware diagnostic tests passed with no warnings or failures) so we know that can't be the case).

    The quoted text comes from a great post discussing this issue concerning leopard but I assume much of which still applies to Snow Leopard.

    This pretty much sums up what I was trying to paraphrase above.

    "With Leopard, a major change occurred in DNS lookups. Any program in Leopard that can use version 6 IP addresses (IPv6 explained below) will send out a new type of DNS lookup request - the SRV Record. In Tiger and previous OS X versions, DNS lookups were A record requests.

    SRV records are new (sadly, 8 years old is new in the DNS world), provide more information than A records, but have terrible support in terms of hardware (your DSL router or cable modem) and DNS servers that answer with SRV information. For every SRV request that Leopard sends it must wait for a valid reply. If the request fails, Leopard must try again. If it fails again, Leopard will finally ask for an A record. This is one reason why Mac users are experiencing slow Internet on new Macs with Leopard or after upgrading to Leopard from Tiger." [from]

    Even disabling IPv6 lookup in the network location didn't solve this issue.

    Does anyone know any command line routine that would disable using SRV requests at all and solely use A requests. I think this would solve the majority of the problem which seems to be a failure to communicate between New OSes using an SRV request and antiquated DNS servers and routers that have never been replaced or updated to meet the new standards (8 years old as stated above). Apple simply followed specifications that recommend using the newer protocol.

    Any help with this issue would be greatly appreciated.
  20. Reclaim3r macrumors regular

    Jul 15, 2009
    I am also having a problem with my Airport connection. It seems like it messes up my network, too. My roommate's computer and my Xbox are all also connected to the network, but a lot of the times they don't get internet. We have to reset the router to fix it. I believe this is caused by my Mac using IP addresses that are all ready taken. I got a message once saying something like "This IP address is already in use". Apple really needs to fix this. It's quite annoying.
  21. hphoto macrumors newbie

    Sep 22, 2009
    I've never had the problem as described in this thread with Leopard.
  22. gps macrumors newbie

    Sep 12, 2008
    Lucky you...

    I tried to solve the issue we have here at home... Three Mac, a PB12, a Macbook Uni2008 and my MBP17... connected to a TC, same issues. This is my scenario, to give you the entity of the problem, which from my perspective is HUGE!!!! (please note that I had the exact same issue when Apple released 10.5.7, very same problem... I spent rivers of digital ink talking about this issue in the past on the ADF, but seems someone at Apple just forgot to bring in that patch, released in 10.5.8).

    - PB is quite reliable now (actually is the most reliable machine at home), connected via eth to the TC (which is connected to a Linksys AM200, with DHCP off, NAT on, DNS provided by ISP), is running on 10.5.8, sometimes it has problem with cookies, just temporarily forget to keep connected to services like FB or Tw, Linkedin still a nightmare (with the empty white pages, but Firefox solve the issue), so far, no DNS problems (it doesn't have the two OpenDNS IP configured).

    - Macbook Unibody... once upgraded to 10.6 had severe issues with DNS and prefs... solved doing a manual erase of some plist... but DNS resolution is crappy again, even when opendns settings were helping a bit. We use less this machine...

    - The REAL nightmare is the MBP, 10.6.1 with double upgrade/re-install (not clean, we cannot lose several configurations of this machine made in the past and successfully migrated to this MBP), console is full of messaging of Debugger was called by WebKit, and I tried all the possible solutions... rolled logs, cleaned caches, restored dns, applied new network configurations and locations, switched from Airport to Eth,... no chance!)...

    The problem is still there, what I see in my console there is a "weird" relation between the missing address resolution (which ends with Safari not able to load or declaring internet missing...) and this message. I tried to log more with WebKit, but I was not able to get more info.. this is the message I got:[351] Debugger() was called!

    I don't believe there is a relation with some missing Plugins or something, the problem is the damned DNS... and we are on the right path.... too many people are suffering the very same problem.

    Any other idea?
  23. timecmdr macrumors newbie

    Jul 11, 2008
    Yeap I'm getting the same on my iMAC. After a sleep it takes forever to resolve Web addresses.
    I thought it was a problem with my internal DNS server at first but all was fine on my, er hem, windows box.
  24. cjd1 macrumors newbie

    Oct 19, 2009
    I too can say that I have experienced connectivity problems with my Mac Air 2nd Ed since fairly recently. This has been true using many wireless networks.

    Surely, someone from Apple must care about this issue that is affecting so many of us? Or am I simply far too optimistic? All I know is my solution until now has been to boot into Windows where things seem to zip along pretty well online using either Firefox or IE8.

    Cheers, cjd1
  25. Sweener88 macrumors 6502


    Apr 27, 2006
    omg this is SOO annoying!!! has anyone found a solid fix? it seems after i restart my router its fine but i dont want to have to run downstairs and restart the router every single time i want to connect to the internet :confused:

Share This Page