Snow Leopard does not allow me to connect to 802.11n networks, Leopard worked fine

Discussion in 'macOS' started by donovan1983, Sep 4, 2009.

  1. donovan1983 macrumors newbie

    Joined:
    Aug 26, 2009
    Location:
    Maryland, USA
    #1
    I have an Airport Extreme card with the Atheros AR5416 chipset in my Mac mini (late 2007 rev.) and it worked perfectly in Leopard. I could connect to my roommate's Airport Extreme just fine on its 802.11n network. But with multiple tries installing Snow Leopard it just has not worked to connect to that same network. Despite the antenna only being connected to the connector for 5GHz networks, I can connect only to 802.11g (2.4GHz) networks but not 802.11n (5GHz) networks. If the network card was defective I would expect Leopard to have similar issues but it was rock solid. Right now I am using an Airport Express as a bridge through ethernet to get internet connectivity. This is something I fully expect to deal with in Linux or even Windows with old drivers, but certainly not on Apple's own OS on their own hardware.

    Has anyone else had similar issues with Snow Leopard? Whether you do or not, what chipset does your Airport Extreme card use? You can get this info from Apple menu -> About this Mac -> More Info -> Airport -> Firmware version. From what I understand, Apple is still using both Broadcom and Atheros chipsets in their Airport cards, so I'm curious to see if it's an issue with Atheros chipset drivers in particular. Thanks for any assistance.
     
  2. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #2
    Possibly a problem with the Airport Extreme. Just yesterday I got the D-Link DIR-655 WLAN router and it works just fine in 802.11n, giving about 70/40 Mbps speeds according to Speedtest.net (wired connection gives 90/60 Mbps) on my 100 Mbps connection.
     
  3. davork macrumors newbie

    Joined:
    Jan 3, 2007
    Location:
    Woodbridge, NJ/ Dublin, Ireland
    #3
    Hate to say it but 'me too'

    I have a 15" MBP week 44 in 2006 with the same chipset and same problem under 10.6.1

    Tried against:
    - Airport extreme (fast ethernet)
    - Airport extreme (gigabit)
    No joy on either (and no problem before snow leopard)

    Works fine in 802.11g mode against an airport express (non N mode) that I use for my Chumby(!)

    People on the apple board have suggested creating a new location etc, but that doesn't change anything for me

    methinks it's a driver issue!

    Anyway superduper back to 10.5 over the weekend for me!
     
  4. gjas18 macrumors newbie

    Joined:
    Sep 20, 2009
    #4
    I fixed this by taking the 80211 framework off of the 10.6.0 disc and replacing the one installed by the 10.6.1 update.

    This is located in system>library>private frameworks

    Grab the apple80211.framework and replace the one on your harddrive. You'll need to see hidden files to be able to see the system folder on the CD. Do a google search for how to enable this.
     
  5. davork macrumors newbie

    Joined:
    Jan 3, 2007
    Location:
    Woodbridge, NJ/ Dublin, Ireland
    #5
    :-( I didn't have the 10.6.1 upgrade installed :-(

    Oh well, as per the subject line... anyway off to install 10.6.1... perhaps it'll work for me (r-i-g-h-t!)
     
  6. Koppenhoefer macrumors newbie

    Koppenhoefer

    Joined:
    Oct 28, 2009
    Location:
    Lausanne, Switzerland
    #6
    802.11n + SN failure... but now works

    Hello,..
    I've been struggling with this for 1 hour.
    Magically, while fighting it, the problem went away (flick enough switches and the light will go on, I guess).
    Here is my work log (in case it helps):
    ----

    THE PROBLEM:
    Previous to upgrading to Snow Leopard, no problems.
    Upgrading to Snow Leopard 10.6.0 ok.
    Upgrading to Snow Leopard 10.6.1 not ok.
    Post upgrading, I can see my home network (let's call it koppenhoefernet) but joining the network fails.
    I was/am using 801.11n 3rd party card on a Mac Mini.

    MY FIRST EFFORTS (failed):
    I have removed all references to my timecapsule and to my wifi network koppenhoefernet from the keychain (multiple mentions were found in login and system).

    OBSERVATIONS:
    When I do try to access the network, I am asked the WPA password.
    Once I've answered that the following message appears in /var/log/system.log :

    Apple80211 framework[393]: _ACNetworkCopyKeychainItem()
    expected password for "koppenhoefernet" not found: -25300
    (The specified item could not be found in the keychain.)

    and the name of the network with password is added to the Keychain under both system and login.
    However, the connection to the network doesn't succeed.


    Notes:
    1.
    My iphone can still use the network.
    The iphoneApp Wififofum shows it to be very strong and wpa2.
    The other wifi's in the area are using other channels.
    My squeezebox can still use the network.

    2.
    Once the above error was noted, the Keychain now contains a reference to my network name in the System entry.
    Kind,Account, and Where are prefilled with values.
    Password is not.
    Activating 'Show password' causes a popup window querying: 'kcproxy wants to use your confidential information stored in "koppenhoefernet" in your keychain. Do you want to allow access?".
    Saying Allow reveals the password that I typed in the wpa query when joining the network.
    Cycling the Airport on/off/on has no effect and doesn't reproduce the system.log message.

    3.
    The network does NOT appear in the preferences panel advanced Airport tab.
    But choosing it from the non-advanced pane succeeds.
    But Airport gets a self-assigned IP address 169.254.17.140
    subnet 255.255.0.0 and no DNS values.
    At this point the network shows up in the preferred networks.

    4.
    Removing my newly appeared network from the preferred networks doesn't affect the entry
    in the keychain.

    5.
    When using an invalid password to join the network, the dialogue box informs of the invalid passwd.
    The system.log reveals:
    airportd[2174]: Apple80211Associate() failed -3924 (Invalid PMK)
    Oct 28 16:02:00 shawnmac-8 Apple80211 framework[348]:
    airportd MIG failed (Associate Event) = -3924 (Invalid PMK) (port = 80419)
    Oct 28 16:02:00 shawnmac-8 SystemUIServer[348]:
    Error joining mynetwork: Invalid password (-3924 Invalid master key)

    6.
    If I try to connect to my network, but not choosing to 'remember this network'.
    The following error appears in system.log:

    Oct 28 16:09:14 shawnmac-8 ntpd[31]: bind() fd 30,
    family 30, port 123, scope 6, addr fe80::21d:7dff:fe45:52ab,
    in6_is_addr_multicast=0 flags=0x11 fails: Can't assign requested address
    Oct 28 16:09:14 shawnmac-8 ntpd[31]: unable to create socket on en1 (19)
    for fe80::21d:7dff:fe45:52ab#123

    7.
    Turned off autoconfigure of IPv6 in preferences pane tcp/ip.

    8.
    Delete unused locations from PreferencePane locations (removed 'Automatic')

    9.
    connected My Squeezebox ethernet port to the Mac (the squeezbox can share his b wifi connection with anyone connected with a crossover cable).
    DHCP on the mac failed.
    Manually gave the mac an ip address for ethernet use.
    Disabled the wifi to get this working.
    Set the router to 10.0.1.1
    Still couldn't *see* the internet.
    (my next step will be tethering).

    10.
    Just in case,.. retry the wifi.
    Oh my god.. It works!

    11.
    reboot,.. (does it still work?). yup.
    Keep my fingers crossed.
     
  7. Koppenhoefer macrumors newbie

    Koppenhoefer

    Joined:
    Oct 28, 2009
    Location:
    Lausanne, Switzerland
    #7
    802.11 Snow Leopard problem revisited

    Hello,..

    After successfully using my 802.11n network since my last post (despite several reboots... I had no more problems) suddenly the connection stopped working again.

    This occured at the same time that I used my Bluetooth connection (successfully) to pair with the Logitech Pure-Fi Mobile speaker and then turning those speakers off. Note that I have been using a bluetooth wireless keyboard with no problem.

    This time.. .here is what I did (which ended up successfully restoring my wifi connection):
    -------------------- (flip enough switches and the light'll go on!)

    1.
    disactivating and reactivating - no joy

    2.
    preferences connection.
    Reveals yellow Aiport diagnosis. IP is self-assigned!
    Turn airport off, then on… no joy. No ip address! slowly then becomes self-assigned.

    3.
    preferences connection.
    Advanced.
    remove the network
    cycle the airport
    no joy

    4.
    try usb tethering.
    no joy on the wifi.. but usb tethering works fine through my 3g connection.
    + recylcing airport.
    now turn OFF tethering and ensure airport on… nope.. no joy.

    5.
    switch tcp ip to using dhcp with manuel address
    10.0.1.200
    succeeds in connecting to network BUT not useable.
    Not even manually ip address with router dns and search domains specified.
    no joy.

    7.
    renew dhcp lease? no

    8. SUCCESS !
    Once again... By connecting my Sqeezebox and using the ethernet port as a bridge, I was able to use the network. When I removed the connection and turned airport back on,.. it worked. Go figure. :)
     

Share This Page