Snow leopard- Ethernet does not work

Discussion in 'macOS' started by puffnstuff, Sep 2, 2009.

  1. puffnstuff macrumors 65816

    Joined:
    Jan 2, 2008
    #1
    I installed last weekend no problems noticed. I was using wifi up until today I started using the ethernet. I could not log on to the internet. The light on the modem was not blinking but in the networking status everything was green except "internet" and "server". I called the ISP and they said everything was fine on there end could not figure out what it was so I knew what it was. I downgraded to Leopard and the internet is back.

    how to get in snow leopard? :(
     
  2. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #2
    1. Did you do a clean install or an upgrade?

    2. Have you tried manually releasing your DHCP connection? (If you don't know how I can tell you how to)

    3. Do you have a router? If so, have you tried plugging the ethernet cable into a different port?

    4. Have you tried a different ethernet cable and/or one you can verify works?
     
  3. puffnstuff thread starter macrumors 65816

    Joined:
    Jan 2, 2008
    #3
    ^this
     
  4. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #4
    Have you tried power cycling your cable modem? How are you getting wireless?
     
  5. puffnstuff thread starter macrumors 65816

    Joined:
    Jan 2, 2008
    #5
    The ISP reset the modem. I was getting wifi from the neighbor but that stopped working today so I had to go back to using my ethernet cord.

    Like I said it's working fine now since I downgraded to Leopard. So, it has to be something with Snow Leopard.
     
  6. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #6
    Possibly, but it could also be any number of reasons. I upgraded to SL and my ethernet worked fine out of the box, but I run through a router.
     
  7. EdDean67 macrumors newbie

    Joined:
    Aug 5, 2006
    #7
    I upgraded all 3 of my macs on Monday to Snow Leopard. No problems on Tuesday but this morning I started having problems with the airport. I use one of my macs to share the ethernet to the other macs airports as of today that will not work even though it worked yesterday. I also noticed today when trying to figure out the problem that the wifi in the houses around me are at a much weaker signal now.
     
  8. huwon9 macrumors newbie

    Joined:
    Sep 10, 2009
    #8
    delete the SystemConfiguration folder

    Library >> Preferences >> SystemConfiguration

    Delete the SystemConfiguration folder to get rid of all the old plist files.

    I did a clean install of Leopard and update with Snow Leopard on a Macbook Core Duo. Airport and Ethernet worked perfectly. Did a Snow Leopard update on an iMac Core 2 Duo with Leopard and lost the Ethernet.

    Tried all the suggestions to reconfigure the network/reset router/change port/etc given in various forums to no avail.

    Looked in the SystemConfiguration folder and there was a mess of plist files from various OS X updates.

    Deleted the SystemConfiguration folder and rebooted. Works perfectly.
     
  9. frankcsf macrumors newbie

    Joined:
    Sep 11, 2009
    #9
    lost connection too

    after upgrading, i have also been having issues with wired connectivity. wireless has been working fine. i will try to delete those pref files and see if that fixes things. what a pain it has been.
     
  10. coolcat21 macrumors newbie

    Joined:
    Oct 23, 2009
    #10
    Thanks SO much for this tip! :) In my case Ethernet wouldn't work after upgrading to SL; Airport worked perfectly.

    I copied the plist files in "SystemConfiguration" and saved (just in case), deleted the folder, shutdown and restarted. The Ethernet connection worked perfectly then. I had to go reselect my wireless network in System Preferences | Network to get the Airport connected again, but no biggee.

    Thanks again huwon9!
     
  11. mretondo macrumors newbie

    Joined:
    May 14, 2011
    #11
    Amen,

    I just updated to iCloud and somewhere in the course of updating my wife as well and syncing my Ethernet connection stopped. I rebooted with an emergency backup partition and the Ethernet port work fine so I knew my hardware was okay:) Then I knew it had to be software and found this post and gave it a try and bingo, it worked. Thanks!!!
     
  12. TimTheRaccoon macrumors newbie

    Joined:
    Jan 24, 2012
    #12
    Worked perfectly in my case too. You rock!
     
  13. Udar macrumors newbie

    Joined:
    Mar 14, 2012
    #13
    LAN still not working after Snow Leopard update

    Hi,

    good information here. I also updated to Snow Leopard (from Leopard) and the ethernet and airport quit working. After trying various things (including deleting the plist files and rebooting), the airport is now working, but still no luck with the ethernet. In System Preferences >> Network, it shows that ethernet is connected. I work in a large office, so I'm a little reluctant to go ask our sys admin to turn off/reset the network switches/routers.

    On the part about
    Library >> Preference >> SystemConfiguration

    There is no System Configuration on this computer. The plist files are all in the Preferences folder. I deleted all these (after backing up) and the airport worked after that. Need to get the ethernet working too.

    Any suggestions? Why does everyone have the SystemConfiguration folder and it's not here?

    Thanks..
     
  14. galavanter macrumors member

    Joined:
    Aug 8, 2008
    #14

    You saved me hours of troubleshooting I'm sure. Thanks!
     
  15. dbernie41 macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ohio
    #15
    I also have no System Preferences folder and have this same issue. Did you ever find an Ethernet fix?
     

Share This Page