Snow Leopard - Expose not working with F keys.

Discussion in 'macOS' started by pavinder, Oct 10, 2012.

  1. pavinder macrumors member

    Joined:
    Jan 16, 2009
    #1
    I have some problems with my keyboard shortcuts.

    The media keys are working fine.
    If I choose the "Use all F1, F2, etc. keys as standard function keys" in keyboard preferences then as expected I activate them by holding the Fn key and pressing the media key.
    If I uncheck the "Use all F1, F2, etc. keys as standard function keys" in keyboard preferences then as expected I activate them by just pressing the media key.

    But the Expose keys aren't working. I have them set as defaults (F9=all windows, F10=application windows, F11=desktop) and Expose is switched on.
    However if I press them, I just hear the alert sound and nothing happens.
    This is the case regardless of how I have set the media keys to function (as described above).

    In Expose preferences, if I change these Expose functions to any function key from F1 to F19, I still only hear the alert sound.
    But if I change the expose functions to the right or left Shift/Ctrl/Alt/Option keys, they work fine.
    Of course activating expose whenever I hit the shift/ctrl/alt/cmd key is ridiculous, I want to use F1-F19.

    Any advice would be much appreciated.
     
  2. WSR macrumors regular

    Joined:
    Jun 9, 2011
    #2
    Since you said Expose preferences:
    Pull up keyboard preferences,
    select the "Keyboard Shortcuts" page,
    select "Expose & Spaces" on the left,
    and check under "Expose" one the right.

    Are the 3 options under Expose checked and set to the Fn key you want? (see image)

    The only other thing I can think of is if any other app could be reassigning them.
     

    Attached Files:

  3. pavinder thread starter macrumors member

    Joined:
    Jan 16, 2009
    #3
    Yes, all set as you suggest.

    I also deleted the symbolichotkeys plist and restarted again, still the same problem.

    Reinstall system?
     
  4. WSR macrumors regular

    Joined:
    Jun 9, 2011
    #4
    I'm hesitant to suggest going to the extreme of a reinstall yet. Doing a reinstall can be a pain to download all of the updates again.

    A few more straws to grasp:
    1)
    In keyboard Pref., Keyboard page,
    click on the "Modifier Keys..." button and make sure is set right.

    Mine gives me options of "Apple Extended USB Keyboard" and "USB Receiver". Mine is set to "Apple Extended USB Keyboard", but I have an iMac without the Fn key and I think you have Macbook. So keyboard pref. are a bit different for us.

    2)
    Also, think about any software you've installed recently. Could any of them be effecting the keys. At one point for me, Safari's ability to drag tab to a new window began began to have major delays, then I learned that the RightZoom.app I had installed to change the behavior of the green zoom button caused the problems with Safari.

    To really test this out, try creating a new account with no additional software installed. Basically you want it as close to factory setting as possible. If it's still doing it, then I wouldn't think it's the installed apps.

    3)
    Can you try a different keyboard? Even if it's just to see if the behavior persists.
     

Share This Page