Snow Leopard - External USB HD doesn't work anymore

Discussion in 'macOS' started by crazysnake, Aug 26, 2009.

  1. crazysnake macrumors newbie

    Joined:
    Oct 29, 2006
    #1
    Hello All,

    i have a problem with my Snow Leopard installation. Since I've installed Snow Leopard, my external USB HD won't work anymore. It's a ICY BOX case with USB 2 and Firewire 400 interface. The mac is a mid 2009 mac mini (9400m).

    Has somebody an idea what could be wrong?

    thanks :(

    P.S.: It doesn't show up in the disc utility
    PP.S.: I tried two different hard drives in the enclosure, but all worked fine before Snow Leopard!
     
  2. crazysnake thread starter macrumors newbie

    Joined:
    Oct 29, 2006
    #3
    UPS i meant SL, Snow Leopard! Sorry!!
     
  3. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #4
    Does USB not work, or does the drive not even mount w/ FW? Do other USB devices work in the port you are using? Do you have another computer (a friends or something) to see if the drive works on another machine?

    Were you using USB or FW before SL? If FW, was it plugged in when you did the update?

    Have you tried all the obvious things like restarting your computer, unplugging and then reinserting the USB, etc (asking b/c you don't mention what steps you've taken so far).
     
  4. BashStreetYouth macrumors member

    Joined:
    Dec 28, 2007
    #5
    Did you ever fix this? Strangely, my icy box usb has stopped working under SL. Not sure if it's the box itself or something causing the drives not to show up in SL?
     

Share This Page