Snow Leopard: Help with Services

Discussion in 'Mac Basics and Help' started by sonictonic, Sep 6, 2009.

  1. sonictonic macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #1
    Hi Guys,

    I'm not knowledgeable enough to use Automator and all that kind of stuff, but I did download some really cool services for Snow Leopard from the macosxautomation website, installed 'em, but can not get them to show up in the services menu at all on my main (standard) user account.

    Just to see, I logged into my Admin account and the services are listed correctly depending on what files are selected. But I go back into my main standard user account and no such services exist, even in the Services Preferences.

    Any ideas? What am I missing? Is there an on/off switch I'm not seeing somewhere?

    Thanks in advance :)
     
  2. sonictonic thread starter macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #2
    One last attempt... Can anyone help me out?

    Thanks in advance... :eek:
     
  3. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #3
    Captain obvious would say: you create services under a certain user account and you won't be able to see them in other accounts. The solution is simple: move the services from ~/Library/Services to /Library/Services and be a bit patient because it needs a couple of seconds to pick that up. Also a great way of moving your created services to another Mac.
     
  4. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #4
    For services to be available to all users they must be placed in HD > Library > Services. In Snow Leopard each user needs to go to System Preferences > Keyboard > Keyboard Shortcuts > Services & "activate" the third-party services by checking the boxes. I could not activate WordService's lowercase function until I changed it's keyboard shortcut. The ⌘ L shortcut is already in use by another service so I double-clicked "lowercase" & changed it. For me, I changed it to ⌘ ⌥ L (Command + Option + L).
     
  5. sonictonic thread starter macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #5
    I don't have a Services folder at all in my standard user account folder. I ONLY have a Services folder in the main Library folder and the services I installed are there.

    Also, in the preferences, they are not listed to enable or disable at all. I only see them if I log into my Admin account.

    What's wrong here? :(
     
  6. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #6
    You can create a Services folder in your user library & put services in there. I don't know how enabling works in a standard account. I only have admin accounts on my Macs.
     
  7. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #7
    I think the problem would be you're using a standard user account. You can not install anything when using such an account, you need an admin account to do so (which you have). When you install one of the packages you get the installer which tells you something like "Installs the following service workflows in the Home > Library > Services folder:". When you want to install it you use the admin account so I think that some of the services are copied to the services folder of your admin account and some will be in the main Library. There might also be some issue regarding user rights in this case. I'm not quite sure if a standard user account has enough rights to use whatever you put in the main Library folder. I think the easiest way if finding that out would be to log into the standard user account, browse to the services and open them (they should open in Automator). You could also try to copy the services to the standard user account (when logged in with the admin account of course) and so what will happen to the services menu.
     

Share This Page