Snow Leopard indexing not completing

Discussion in 'macOS' started by jwr38, Mar 9, 2010.

  1. jwr38 macrumors newbie

    Joined:
    Apr 25, 2009
    #1
    I just upgraded to snow leopard from leopard. My problem is that it won't finish indexing. Spotlight now doesn't work. I have tried going into system preference and turned everything off but it still does nothing. How do I go about fixing this?

    [​IMG]

    any help would be great. Without spotlight my work productivity is really taking a hit.
     
  2. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #2
    How long is it stuck trying to reindex your drive? It may take a while to initialize and complete. If you are still having problems, open Terminal and type sudo mdutil -E -i on /
     
  3. jwr38 thread starter macrumors newbie

    Joined:
    Apr 25, 2009
    #3
    Well after three days waiting for it to do anything I just about treated OX like windows. i.e. I was going to fresh reinstall.

    I am not impressed. Mac's should have less of a concern with faults as they have less of a range of hardware that f's up. topping that off it is a macbook pro so really I don't know why mistakes like this should happen (apple build this sucker and make the software).

    I did fix it and this is how

    Well the first thing I did was go to disk utility and repaired the permissions. I then removed bootcamp, cleaned out all cache and repaired permissions again and this time it worked. It took 3 hours on a 300 gig drive but it worked.

    Why are my disk permissions changing all the time? I don't understand.
     

Share This Page