Snow Leopard install problem - can't choose drive after reboot

Discussion in 'macOS' started by psxguru, Aug 28, 2009.

  1. psxguru macrumors 6502a

    Joined:
    May 19, 2006
    #1
    Anyone else experiencing the same problem?

    Macbook 2.4Ghz with Leopard 10.5.8, 320Gb drive (2 partitions)

    Doing the standard upgrade install so I shove the SL disc in and run the installer, after an age it eventually reboots.

    Then after another long wait the installer finally appears but when it asks to choose the drive to install to, my drive doesn't appear.

    From the utilities menu, I can access disk utility and it only shows the DVD drive.

    If I access system profiler my hard disk is still there in the SATA section.

    Seems like I'm going to have format and do a clean install unless anyone has any ideas? :(
     
  2. FanCarolina macrumors newbie

    Joined:
    Aug 28, 2009
    #2
    MacMini

    I'm having this exact same problem.

    Late 2008 MacMini 1.83ghz
    4gb RAM
    128gb Patriot Warp v3 SSD
    1TB MiniStack

    Even doing a clean boot from the DVD doesn't fix the issue. I can't even reformat and do a clean install if my drive doesn't appear in the Disk Utility.
     
  3. ddsaluki macrumors newbie

    Joined:
    Aug 28, 2009
    #3
    Same problem here with a 2.4Ghz MacbookPro, doesn't show my hard drive. Disk utility won't show it either.

    I have tried a couple of things, all to no avail including:
    -Removing bootcamp partion
    -Fresh install of 10.5 followed by 10.6 (didn't work)
    -Reset PRAM
    -I hooked up an external USB drive, and it recognized it, but still not my internal hard drive!!!

    The only thing I can think at this point is that I replaced the stock hard drive with a 320GB western digital about 6 months ago... could it be that 10.6 doesn't like my HD? It works great in leopard, no problems.

    My next logical step in the troubleshooting process will be to take out my 320GB hard drive and put back the stock 160GB, but I really don't want to because it is kind of a PITA.

    Are either of you with the same problem running aftermarket HDDs?
     
  4. FanCarolina macrumors newbie

    Joined:
    Aug 28, 2009
    #4
    Aftermarket

    I had issues getting mine to work initally but that was because I didn't know about Apple using a GPT (GUID) Partition Table over a standard MBR but once I figured that out Lepoard has no issues seeing and working with the drive.

    I know Snow Lepoard won't install to drives with a SMART failure but I don't see how this could be an issue.
     
  5. psxguru thread starter macrumors 6502a

    Joined:
    May 19, 2006
    #5
    yeah I replaced the original drive with a Western Digital 320Gb too (WD3200BEVT). Can't see why it would affect the installer though!
     
  6. FanCarolina macrumors newbie

    Joined:
    Aug 28, 2009
    #6
    It may be that Apple is checking for something else that we aren't getting set quite like the OEM drive.
     
  7. FanCarolina macrumors newbie

    Joined:
    Aug 28, 2009
    #7
     
  8. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #8
    It's not the swapping of the harddrives, I have a 500gb western digital in my macbook pro and my install went fine.
     
  9. ddsaluki macrumors newbie

    Joined:
    Aug 28, 2009
    #9
    Just for grins, I put the 10.6 disc in my wife's macbook (that now has my MBP's old, "factory" hard drive). Boots up and recognizes the HDD with no problems.

    By the way, the non-working drive in my MPB is also a WD3200BEVT.

    I also tried rolling back to 10.4 to see if that made any difference, but no dice. What kills me is that both 10.4 and 10.5 (older versions) have no problem seeing the drive, but 10.6 does!!!
     
  10. psxguru thread starter macrumors 6502a

    Joined:
    May 19, 2006
  11. sadpanda82 macrumors newbie

    Joined:
    Aug 28, 2009
    #11
    I am having the same problem.

    2 GHz Macbook with an aftermarket HDD (320 GB Western Digital WD3200BEVT)
     
  12. sadpanda82 macrumors newbie

    Joined:
    Aug 28, 2009
    #12
  13. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #13
    From what I've read, it sounds like the people with problems may have formatted their HDs with MBR (Master Boot Record) or Apple Partition Map and not GUID, which is required by SL to boot from.
     
  14. sadpanda82 macrumors newbie

    Joined:
    Aug 28, 2009
    #14
    I'm pretty sure my disk is correctly formatted:

    [​IMG]
     
  15. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #15
    Hmmm... guess that theory is out.
    I'm afraid to install on my machines.
     
  16. sadpanda82 macrumors newbie

    Joined:
    Aug 28, 2009
    #16
    Well the good news is that if you quit the installation process, reboot and eject the installation disk Leopard starts up perfectly with everything intact.

    I was a bit worried that I'd killed my Macbook when it failed the first time.
     
  17. eoren1 macrumors 6502

    Joined:
    Aug 17, 2007
    #17
    Same problem as above with my WD3200!
    I was able to install SL by putting the HDD into a firewire enclosure device and running the install. Took an hour and the computer seemed to be dead for at least 20 minutes of that - no lights/screen dark! But waited it out and worked fine. Reinstalled into the macbook and it is running great.
    I spent one hour on the phone with Apple support last night trying to figure it out - their two thoughts - checking SMART status (fine) and resetting the system something (hold power x 5 secs with battery out and no outlet) didn't help. Must be something about that drive!
    E
     
  18. ddsaluki macrumors newbie

    Joined:
    Aug 28, 2009
    #18
    Partial Solution

    Well, I think I have a partial solution (but far from perfect).

    Refer to this thread on the apple support forums:
    http://discussions.apple.com/thread.jspa?threadID=2132162&tstart=0

    Basically I booted my MBP in target disk mode, then booted the SL installer on my wife's macbook. SL recognized the drive via firewire with no problems, and the install went off without a hitch. I'm typing this message on my MBP in 10.6 now.

    Also check out this thread:
    http://forums.macrumors.com/showthread.php?t=774890

    In the update at the bottom, the poster was able to install successfully by taking the drive out of his computer and placing it into a firewire enclosure (just for the install).

    So even though there is a long way around solution now, that sucks for people with a MBP who's hard drive is buried deep inside the computer and doesn't have a second computer to run the installer from.

    I agree with sadpanda's assessment, that seems to be a SATAII/EFI firmware issue rather than a partitioning issue.
     
  19. sadpanda82 macrumors newbie

    Joined:
    Aug 28, 2009
    #19
    Thanks for posting, I'm glad you got it working.

    Do you think you could walk me through exactly what you did? It sounds like the (or at least a) solution is to swap the disk out and install it from an external device.

    I'm not all that confident on how to do this so it would be great if you could elaborate a little on what you did.
     
  20. Spades macrumors 6502

    Joined:
    Oct 24, 2003
    #20
    I managed to work around this by installing to a different drive and then cloning back to the drive that the installer couldn't see. Fortunately Snow Leopard itself has no problems with the drive. I'll still be waiting for a solution, in case I ever need to reinstall.
     
  21. eoren1 macrumors 6502

    Joined:
    Aug 17, 2007
    #21
    Here goes:
    Power off Macbook and take out battery as well as magsafe adapter
    Remove battery
    Remove hard drive
    Find external enclosure that fits SATA drive and has a firewire port (USB drives won't boot so won't work) - this is the one I have LINK
    Put HDD into enclosure and attach via Firewire (I also used the USB to power attachment to be on the safe side)
    Power up Macbook holding Option key when you hear the chime
    Select your HDD (there may only be one option if the install DVD is not in)
    Boot up as you normally would
    Put in SL install DVD and double click
    Continue, agree, continue... Make sure you select your hard drive as the destination (it will likely have a yellow/orange color to it instead of the gray hard drive icon when it is installed in the machine)
    DO NOT TOUCH MACBOOK FOR 1 HOUR! No really! You'll think it died or failed but it IS working:D
    Run through Setup Assistant.
    Power off Macbook
    Reinstall HDD
    Done

    Hope that helps,
    E
     
  22. sadpanda82 macrumors newbie

    Joined:
    Aug 28, 2009
    #22
    Thank you very much. Looks like I'll have to buy a firewire HDD enclosure.

    UPDATE: I had no problems using an external USB hard disk enclosure and Snow Leopard is running smoothly on my Macbook.

    @eoren1 Thank you again for the helpful instructions.
     
  23. Exegesis48 macrumors regular

    Joined:
    May 2, 2009
    #23
    I had the same problem on my wife's Macbook. I was able to get things working by taking the hard drive out and connecting it to the computer via a USB SATA adapter. The install went fine after that and then I just put the drive back in and everything is going smoothly now.

    Real pain that Apple has this problem, the drives in my Macbook Pro and my wife's Macbook are exactly the same, but for some reason Apple doesn't like hers.
     
  24. psxguru thread starter macrumors 6502a

    Joined:
    May 19, 2006
    #24
    This is going to be a bit of a PITA but at least there is a workaround although it's far from ideal.

    @eoren1 - you can boot off usb enclosures with intel macs so you don't necessarily need a fw one.
     
  25. Seven Ocean macrumors newbie

    Joined:
    Oct 25, 2008
    #25
    My MBP also has a problem of detecting a drive after restarting. Only after I shut off and re-boot, does the computer detect a hdd again. I keep receiving installation failed errors, and also this message: "the installer can't extract files from the package for BaseSystem". Has anyone else had that message come up?

    BTW, I'm using a OCZ Vertex 120GB SSD.
     

Share This Page