Snow Leopard Installation Trouble - 2.53 MBP

Discussion in 'macOS' started by SubaruNation555, Dec 3, 2009.

  1. SubaruNation555 macrumors 6502

    Joined:
    Dec 3, 2007
    Location:
    Arlington, VA USA
    #1
    I am having trouble installing Snow Leopard on a new MacBook Pro. I have searched here and on Google and found many suggestions but none have worked so far.

    The computer in question is a base 2.53 GHz MacBook Pro with a new Seagate Momentous 500GB 7,200rpm HDD from OWC.

    I installed the drive, formatted it and began installing Snow Leopard. After several hours it said that the installation could not be completed because several system files could not be copied from the DVD. I wish I could post up the install log. I can say that there are several errors early on that go something like this:

    -Looking for system privileges
    -No system privileges found
    -No or invalid system privileges found on /Volumes/Macintosh HD
    -Attempting fallback using /System/Library/Private Framework/Systemmigration/Resources/Fallbacksystemfiles.plst
    -Finding system path cache
    -Error writing cache to volume

    -The installer then checks the drive for consistency and says it is ok and proceeds with the installation only to hang about 10 minutes in.


    So far I have tried the following to remedy the problem:

    -Zeroed out the disk and reformatted (Mac OSX extended journaled with a GUID partition). Got an error but the drive eventually zeroed out after several hours.
    -Tried a retail Snow Leopard DVD (which I have used on three other computers with no problems).
    -Tried creating a bootable copy of Snow Leopard on an external USB drive to install from. Didn't seem to work-when I went to restore the disk image to the external drive I got this error. I am now trying to restore directly from the CD.
    -Repartitioned the drive (tried the trick of dragging the partition sizes around).
    -Tried installing with each memory module removed. (wish I had some extra RAM modules lying around...)
    -Tried installing from another computer using remote install OSX.


    I can't tell if it is the hard drive, the DVD that is the problem or if I am missing something obvious. I just wanted some last ditch suggestions before I returned the drive to OWC.

    Thanks for your time.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Based on the errors you're getting, I strongly suspect the hard drive as the culprit.
     
  3. SubaruNation555 thread starter macrumors 6502

    Joined:
    Dec 3, 2007
    Location:
    Arlington, VA USA
    #3
    Got a replacement drive but Snow Leopard still won't install. I tried using the drive in my MBP (3,1) with the same SN disk and it installed perfectly. So it is something with the new MBP even though it allow SN to be installed on a 160GB Hitachi drive.
     

Share This Page