Snow Leopard, Late '08 MBP, and trackpad

Discussion in 'MacBook Pro' started by lordthistle, Oct 6, 2009.

  1. lordthistle macrumors 6502

    Joined:
    Feb 29, 2008
    Location:
    Italy
    #1
    I have a Unibody MBP (Late '08 - first model) running Snow Leopard. After the installation of SL and the upgrade to 10.6.1 (which I did in the same days), I have problems with my trackpad.

    Basically, every once in a while the system ignores hard clicks for some minutes: if I tap it, the click is registered. If I press it down the click is not registered.

    I do not think it's hardware-related: nothing happened and the noise/pressure/feeling are the same as before.

    Is there anyone else with a similar problem?

    thistle
     
  2. MACWhite macrumors member

    Joined:
    Nov 18, 2008
    #2
    I've got the exact year and mdel with SL and mine is absolutely fine.

    it more likely is a hardware problem.

    (ps. i actually "clicked" the trackpad on " Post reply" and it worked.)
     
  3. smadder macrumors member

    Joined:
    Apr 28, 2006
    #3
    I did have some of the same glitches. I did a PRAM cycle and it cleared it up. I've had to do it a few times. Nothing that will drive me insane, but I imagine it will get worked out in a service update or system update. 10.6.2 is supposed to be on the way.


     
  4. Xapphire13 macrumors regular

    Xapphire13

    Joined:
    Jan 14, 2009
    Location:
    South Australia
    #4
    my late '08 uMB works fine under Snow Leopard (updated to 10.6.1 within same timeframe as you)
     

Share This Page