Snow Leopard: Lost My MPEG-2 Playback Component

Discussion in 'Digital Video' started by Mac In School, Sep 2, 2009.

  1. Mac In School macrumors 65816

    Joined:
    Jun 21, 2007
    #1
    I have FCS 3.0 installed. I recently upgraded to Snow Leopard, and lost my MPEG-2 Quicktime playback component.

    Other than buying it again, or re-installing the entire suite again, is there a way to re-install the component?

    Thanks.
     
  2. Mac In School thread starter macrumors 65816

    Joined:
    Jun 21, 2007
    #2
    Hmmmm... Okay...

    I guess I could reinstall all of FCS. Does anybody know if FCS 3 still comes with the MPEG-2 Quicktime playback component?
     
  3. psingh01 macrumors 65816

    Joined:
    Apr 19, 2004
    #3
    If you have a Time Machine backup just get it and pop it back into the quicktime components folder. That's what I did. If you don't have the backup then I would suggest contacting apple to get the installer.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Did you try installing the optional quicktime 7 in SL?
     
  5. evil_santa macrumors 6502a

    evil_santa

    Joined:
    Sep 23, 2003
    Location:
    London, England
    #5
    put in your FCS installer disk,

    in the finder GO menu > Go to Folder, type /Volumes/Final Cut Studio/Installer/Packages/

    this will show all the installers,

    Double-click the QuickTimeMPEG2Pro.pkg
     
  6. Heb1228 macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #6
    I tried that it said I needed to install Rosetta to install... this is from FCS v.2. Does that mean the MPEG-2 component is only a PPC utility/app? Is there a version for intel so I don't have to install rosetta?
     
  7. GentleGim macrumors newbie

    Joined:
    Mar 9, 2008
    Location:
    Los Angeles, CA
    #7
    This fix worked perfectly for me using FCS v3.0 installer disc. Thanks. I do have Rosetta installed (why not?).
     
  8. Bunsen macrumors member

    Joined:
    May 1, 2007
    Location:
    Orlando FL
    #8
    This happened to me also, I used Pacifist to go into the installer package on the FCP install disk, and copy the mpeg 2 component into the System/Library/QuickTime folder.
    BTW, you can skip the scan of all the other disks when Pacifist asks, it's on the first one.
     
  9. bobznc macrumors member

    Joined:
    Jun 12, 2006
    Location:
    Chicago, IL
    #9
    Thanks you all so much! Worked for me except I was using a disk image and had to change the folder search to:
    /Volumes/Final Cut Studio Installer/Installer/Packages/
     

Share This Page