snow leopard macbook won't stay asleep

Discussion in 'macOS' started by almostaskater62, Aug 29, 2009.

  1. almostaskater62 macrumors regular

    Joined:
    Nov 15, 2007
    #1
    hey, i upgraded to snow leopard today, upgraded from leopard, and now my computer won't stay asleep. i put it to sleep and it stays for about 30 seconds and then it wakes up and i can't tell what app or system event is making it wake up.
    is anyone else experiencing this or does anyone knwo what the deal is?
    thanks
     
  2. ChefDanMar macrumors newbie

    Joined:
    Mar 4, 2008
    #2
    Same Problem

    Hey I just updated my 2 GHz intel core 2 duo Imac as well and am experiencing the same exact problem. The problem seems to effect all the different methods of "sleeping" the computer. Also tried to remove all USB devices and nothing worked. Anyone else know whats up?
     
  3. Steve686 macrumors 68020

    Steve686

    Joined:
    Nov 13, 2007
    Location:
    US>FL>Miami/Dade>Sunny Isles Beach>Condo
    #3
    Maybe check under advanced Bluetooth options. Turn off "allow bt devices to wake computer".
     
  4. almostaskater62 thread starter macrumors regular

    Joined:
    Nov 15, 2007
    #4
  5. ChefDanMar macrumors newbie

    Joined:
    Mar 4, 2008
    #5
    Fix, this definately fixed it, its from his link

    My issue was:
    "Wake Reason = RTC"
    "RTC: Alarm 2098/12/31 23:58:00, sleep: 2009/8/30 12:00:03"

    WHY DOES IT THINK IT'S DECEMBER 31st 2098?!!
    Now this means there was a scheduled Wake event.

    In:
    com.Apple.Autowake.plist

    I have 79 entries under 'Wake' all with the dates:

    31 Dec 2098 23:58:00

    I can't edit the file to remove them but this seems to be the cause.
    If anyone can tell me how to edit this plist I'd be grateful, I don't have rights.

    Workaround
    To overcome this I had to create at least one real scheduled event.

    System Prefs/ Energy Saver
    Click the Schedule button
    Check' Start up or wake' and create an event, I chose Saturday at 09:00 for example.

    This has fixed the problem but my MBP will wake up each Saturday as a result!
     
  6. almostaskater62 thread starter macrumors regular

    Joined:
    Nov 15, 2007
    #6
    so the fix on that other post was just to delete all those files in the system configuration folder.
    what you're saying is you don't need to delete or modify any of them and just create one actual scheduled event? and taht fixes it?
     
  7. Siguy macrumors newbie

    Joined:
    Jul 12, 2008
    #7
    I had the same problem. I also found the same post above and deleted all the .plist files in /Library/Preferences/SystemConfiguration before restarting.

    It was an annoying solution because I lost a lot of settings but it's been a day and everything works perfectly now.
     
  8. brasmussen macrumors newbie

    Joined:
    Oct 17, 2009
    #8
    I had the same exact problem and the schedule solution worked for me (at least for now). Unfortunetly, i couldn't find a better and ultimate solution for that.
     
  9. PhenomCat macrumors newbie

    Joined:
    Dec 13, 2009
    #9
    I had this problem with my MacBook also! Same date and everything! It turns out it was iTaf, this little alarm application. I hadn't used it in probably 4 years and it had defaulted to an alarm on December 31st, 1998 or something. Apple couldn't even figure it out... they replaced the motherboard and something else and finally just gave it back to me (after they took $300...)

    Apparently iTaf and Snow Leopard don't mix... :eek:
     
  10. ervalerio macrumors newbie

    Joined:
    Dec 14, 2009
    #10
    I've the same problem. In the logs I see:

    Code:
    Dec 14 16:35:06 binerzia kernel[0]: System Sleep
    Dec 14 16:35:13 binerzia kernel[0]: Wake reason = RTC
    Dec 14 16:35:13 binerzia kernel[0]: RTC: alarm 2098/12/31 23:58:00, sleep 2009/12/14 15:35:12
    Dec 14 16:35:13 binerzia kernel[0]: System Wake
    
    I've deleted the entries in the file com.Apple.Autowake.plist but it doesn't seem to solve.
    Moreover, in my special case, this problem only occurs when the power adapter is plugged in.. (i've detailed more or less this issue here: http://discussions.apple.com/thread.jspa?threadID=2264877&tstart=0 )

    Any other possible solution to this very annoying problem ?
     
  11. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #11
    I had this issue and realized that going to Energy Saver settings>Power Adapter and UNCHECKING "Wake for Network Access" was my issue. Try that.
     
  12. pasi3000 macrumors newbie

    Joined:
    Jan 3, 2010
    #12
    http://support.apple.com/kb/HT3774

    Quote:
    "New Macs ship with Wake on Demand enabled by default, but for some earlier Macs this option must be enabled using the steps below. Macs that have Wake on Demand enabled will occasionally wake for a brief time, without lighting the screen, in order to maintain registrations with the Bonjour Sleep Proxy. On some Macs, sounds from the optical drive, hard drive, or fans may be heard during these brief maintenance wakes."
     
  13. Skateaboard macrumors newbie

    Joined:
    Apr 9, 2010
    #13
    Bluetooth seems to be my issue

    I noticed when the problem arose that my Bluetooth was "unavailable" my quick fix was just shutting down... Really annoying. Then randomly today when I powered up the Bluetooth was on and so I tried turning it off, problem solved. Alas now I have no Bluetooth, what's the deal with this? The box for "allow to wake from sleep" wasn't even checked...
     
  14. BVGuitarPlayer macrumors regular

    Joined:
    Jan 14, 2006
    #14
    I believe the issue is with Kerberos. I've basically isolated that as the main issue, I could be wrong. I know there are a lot of threads about this, I'm posting here first because I just found this and I'm a little bit lazy… no worries, I will search shortly for the best Apple Discussion thread to mirror this to as well.

    I've seen that there are people having problems with all kinds of things such as peripherals, network time server, and etc. I've also seen that some people have tried trashing Library/Preferences/SystemConfiguration with random, spotty success. I've already done SMC resets, zapped the PRAM and disabled many non-essential startup items and created a new admin user. I don't want to download any third party fix for this, let's fix our systems without third party patches, they're basically another daemon to keep our computers busier than they need to be.

    For testing sake, do this:

    Quit all apps, change your energy saver pref to 1 minute display sleep and 1 minute computer sleep (power if you're on power, battery if you're on battery). Now, give it 2 minutes, 5 is best if you're patient. Is the light pulsing? Probably not…

    Mark the approximate time that your screen shuts off. Now, you're probably having the sleep problem if you're here (duh) so touch the trackpad to wake the screen, open up Console. Look at the apx. time when your screen shut off. You need to select "All Messages" on the left hand side, scroll to the correct time and date. What do you see? Kerberos??

    I took my Mac in to a buddy who works at the Genius Bar and has passed this on to the OS engineers for a fix (we'll see how that goes). He also tossed the SystemConfiguration folder—no luck. The only way to make it work properly

    In my case every time, it's a Kerberos problem and its happening when its supposed to start sleeping (again, every time). After I went today, I started isolating more causes. Meantime, let's troubleshoot Kerberos, and this is where it's up to you, because there are a lot of Kerberos files if you search system files in spotlight. I don't know if there is a magical corrupted one on all of our SL installations… so if you're feeling brave, give it a shot, trash some, report back here or if you're good with the Kerberos and/or the Terminal, I'm waiting to hear back.

    PS there is no Kerberos process in (my) Activity Monitor, so that rules out that potentially quick fix.

    Code:
    loginwindow in pam_sm_authenticate(): Failed to determine Kerberos principal name.
     
  15. Dillyew macrumors newbie

    Joined:
    Dec 17, 2007
    Location:
    Devon, England
    #15
    Mac won't stay asleep

    Thank you so much (as above) tried that and it worked! :)

    I had already turned off Airport so knew it wasn't that. Guessed it must have been something that needed to have access.
     
  16. robbienh macrumors newbie

    Joined:
    Jan 11, 2011
    #16
    I have a couple of queries on this thread guys if anyone is still looking in !

    My problem is the same as that described at the top of the thread and it also appeared after upgrading from 10.5.8 -> 10.6 -> 10.6.6 (not sure whether the problem existed at the initial 10.6 upgrade or the subsequent software update to 10.6.6 - I suspect the former.

    In addition to my Macbook waking straight up when put to sleep (this also happens in a continuous loop with the lid down), my problem extends to not staying shut down ! When shutting down by either the power button followed by the shutdown prompt or by the apple menu the machine powers down and then restarts more or less instantly ! The only powerdown that stays off is the emergency extended hold down of the power button !

    My log suggests the same problem with the RTC: alarm 2098/12/31 23:58:00 issue and I suspect it is related to ITAF which I had previously installed in Leopard.

    Now to the questions (not before time you say) :

    1. Has anyone found a solution that negates the need for the scheduled event ? It has worked for me but it's hardly ideal in the long term.

    2. No doubt I'm being thick here but I can't find the com.Apple.Autowake.plist that everyone refers to in ~system/library/SystemConfiguration ! There are a load of bundles - one of which is a powermanagement.bundle which looks promising - go into the contents and there are no plists of the type above ! Am a looking in completely the wrong place - I can't find any com.Apple.Autowake.plist anywhere ?
     
  17. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #17
    Yes, you're looking in the wrong place. /Library/SystemConfiguration, not /System/Library/SystemConfiguration.

    jW
     
  18. blow45 macrumors 68000

    Joined:
    Jan 18, 2011
    #18
    Same problem here in lion, read the whole thread but I didn't get any solution out of it, any tangible one that is....

    console:

    Where it says MYNAME it's my name edited out.
     
  19. TeneCursum, Feb 28, 2012
    Last edited: Feb 28, 2012

    TeneCursum macrumors newbie

    Joined:
    Feb 28, 2012
    #19
    Solution is on the iTaf website itself:

    Edit - Forgot to mention that it solved the problem for me.
     

Share This Page