Snow Leopard Mighty Mouse Glitch

Discussion in 'macOS' started by siddercins, Oct 5, 2009.

  1. siddercins macrumors newbie

    May 19, 2009
    I just recently upgraded to Snow Leopard and immediately my mouse started acting funny. It seems like every 2 seconds it pauses for about half a second and then repositions itself where it should be if it hadn't paused. If I wiggle it side to side it will be fine for about 2 seconds and then pause....and then jump across the screen and keep wiggling. It's not so bad that I can't deal with it, but it makes using programs like photoshop or illustrator a bit of an adventure as i'll never know where the cursors gonna stop. :confused:

    Iv'e switched mouse pads so it's not that. And restarting my computer several times made the gap between pauses a little longer(it was originally a little less then a second in between). My guess is I need a new Mouse driver but I don't know how to go about it at all. I was even wondering if there was some way I could just reset the one in Snow leopard somehow...
  2. Ashka macrumors 6502a


    Aug 9, 2008
    New Zealand
    Place mouse upside down on a clean piece of paper. Move mouse firmly in all directions till the little ball is clean.
  3. bongwater macrumors newbie

    Oct 17, 2009
    I have the same problem, brand new MacPro.. with mighty mouse

    I've swapped the mouse out with another, and tried both on my MacBook...
    They work perfect on my macbook, but glitch out on my Mac Pro

    I think it may be a USB port issue, as when I hold a key down in typing... the text pauses at the same interval as the mouse time out...

    I've got a call into Mac, there spose to call back.. if i get a solution, I'll post it..
  4. siddercins thread starter macrumors newbie

    May 19, 2009
    It's not the mouse ball its the cursor itself.

    I tried turning off my computer, unplugging it for 5 seconds, then starting it back up and that temporarily fixed it for about an hour. Then it started back again...

    I downloaded SteerMouse hoping that would help, but it hasn't shown any effect so far.
  5. spark6969 macrumors newbie

    May 7, 2010
    My fix so far to mighty mouse and snow leopard

    I went to expose in preferences and disabled the use of expose and any mouse buttons. Seem to work so far on my 3+ year old macbook and 10.6.3.
  6. zoumtag macrumors newbie

    Dec 27, 2010
    Just for future reference,

    I just had the exact same problem described above on my imac27"_late2009 (mouse glitching and keyboard pausing for a microsecond every 2 seconds or so...)

    After trying a couple things, I noticed the problem didnt came from the mouse nor the keyboard. The problem was linked in some way with my video TV output cable miniDVI to HMDI. Prior to this problem, I had cleaned the computer and unplugged all cables, this was probably related. Unplugging the miniDVI cable fixed the problem, then rebooting, repluggin and redetecting monitors fixed it.

Share This Page