Snow Leopard Mouse Cursor Image Not Changing

Discussion in 'macOS' started by ViViDboarder, Nov 28, 2009.

  1. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #1
    So I recently got a new iMac that has Snow Leopard and I noticed that this is about the second time that my mouse cursor has gotten stuck... not stuck in location, but the image of the cursor.

    I'll move over a textbox and then it changes to the I bar cursor, but then I move away and it stays that... I move over a link and it turns into the finger icon, then I move away and it's still a finger.

    Any ideas?

    Still in the beginnings of diagnosing, but I do have two user accounts logged in. The other account only has a Safari window open though, nothing exciting.
     
  2. BlackNTan macrumors newbie

    Joined:
    Feb 14, 2006
    #2
    ever find out the cause

    I have noticed this too ... did you ever find a root cause?

    Thanks,
    j
     
  3. federaicor macrumors newbie

    Joined:
    Feb 13, 2010
    #3
    Me too

    I'm having the same problem.

    I hope someone knows how to fix it.
     
  4. MacAndroid macrumors newbie

    Joined:
    Feb 20, 2010
    #4
    Me too.

    I'm also having this problem. Hope someone can figure out the cause.
     
  5. [DL] macrumors 6502

    [DL]

    Joined:
    Feb 19, 2010
    Location:
    Louisiana
    #5
    Happens to me all the time. I wish someone would know why this happens.
     
  6. aidanh macrumors newbie

    Joined:
    Mar 25, 2010
    #6
    Snow Leopard Mouse Cursor Image Not Changing * SOLVED! *

    We had this behaviour too. It was very very annoying as the edit cursor is very difficult to see. Weirdest of all was the red-eye edit tool in iPhoto, which has a large and annoying cursor graphic which would persist even if you clicked away from iPhoto to another application.

    I solved this on our computer (brand new iMac 21.5" running 10.6.2) by upgrading the flash plugin from the default version to the latest version (10.0.45.2). You can get it here. You can also check what version you currently have.

    I know this sounds improbable, but it worked pretty much instantly. I did go to a flash based website to make sure flash was running, but I don't know if that is required.
     
  7. ViViDboarder thread starter macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #7
    That almost does make sense since the other app on the other user was safari... Maybe it could have been the embedded flash player even after the window was closed or something... I'm updating.

    Do you know it's solved for good? Or just haven't seen it since?
     
  8. aidanh macrumors newbie

    Joined:
    Mar 25, 2010
    #8
    Only did it last night so can't know for sure. Seemed to immediately fix the problem which was very widespread. Even resizing finder windows would set the cursor graphics to that little double arrow and refuse to go back to normal.

    I signed up and posted to this thread (and one over on the official apple forums) because these were the two hits I got on google when I searched, and I figured it was such an easy fix and was so damn irritating that it'd be great to help out others with the same problem.
     
  9. log macrumors newbie

    Joined:
    Jun 30, 2010
    #9
    Came across this thread from a Google search and had a very tough time finding the solution to this problem so wanted to post here and hopefully can help someone else.

    Besides the cursor issue in multiple browsers, I also noticed the mouse hover was not working either in any application -- including the dock!

    I came across an article that suggested unplugging the USB mouse receiver and plugging it back in. Doing to so apparently reinstalls the driver. This fixed my problem immediately. Strange since a reboot did not resolve it and I needed to this.
     
  10. mudsoma macrumors newbie

    Joined:
    May 22, 2008
    #10
    Apple Cursor Issues

    I have been experiencing a similar, yet slightly different issue. My mouse cursor will occasionally become "scrambled" or distorted, like the image file that is being referenced is corrupted. It only occurs upon a wake from sleep condition, yet has persisted through a 10.6 reinstall, directory rebuilds etc..., the issue is more annoying than anything else as the cursor will return to aan expected state upon mouse over something that will invoke a cursor condition change. does anyone know where the mouse cursor preference files and image files reside, or is there something wrong with my sleep image or RAM? Any ideas?
     

Share This Page